This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Riffaz 2 months, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
July 23, 2019 at 11:00 am #4265289

Speciale

I am trying to: see site working in italian (backend)

Link to a page where the issue can be seen: all pages eg. hidden link

I expected to see: My account translated in italian (Il mio account)

Instead, I got: All woocommerce string are in english, not italian. Checkout are in english. WordPress backend is in english. This issues happen after update woocommerce and wpml.

July 23, 2019 at 11:44 am #4265621

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPMLM support.

What is the language selected here? hidden link

Let me know.

Regards,
Riffaz.

July 23, 2019 at 12:02 pm #4265791

Speciale

Your profile -> Language -> Site Default

Settings -> General -> Site Language -> Italiano (locked)

/wp-admin/admin.php?page=sitepress-multilingual-cms%2Fmenu%2Flanguages.php#lang-sec-1

Lingue del sito
Queste lingue risultano abilitate per questo sito:

Inglese
Italiano (predefinita)

July 23, 2019 at 12:15 pm #4265863

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Please make sure like this:

1) Go to WPML->Languages and set default language as Italian (already you have it like this).
2) Go to WPML->Languages->Admin language and select Italian and save.
3) Go to Your Profile -> WPML language settings -> and select Default to Italian Language
4) Uncheck the "Set admin language as editing language" check box and save.

Let me know how it goes.

Regards,
Riffaz.

July 23, 2019 at 1:08 pm #4266197

Speciale

1) ok
2) where I can find it? see attachment
3) ok
4) ok (never checked)

Same issue

July 24, 2019 at 5:59 am #4270461

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

2) is fine as per your screenshot.

All your settings are fine.
Yet, you have this issue.

Let me know your site login details to check this what we can do from our site.
The next reply is private.

Regards,

July 24, 2019 at 3:07 pm #4275993

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you.

I am checking this.
I will update again as soon as I find the solution.

Regards,

July 25, 2019 at 7:43 am #4280245

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I did nothing but migrated your site to our server and the backend/admin pages are in Italian: hidden link

So it seems that the issue comes from some setting of your server.
Could you please explain this to your server support and ask them regarding this?

You can login to the migrated site using your username and password: hidden link

Let me know how it goes.

Regards,
Riffaz.

July 25, 2019 at 7:52 am #4280407

Speciale

The test site is ok. But before the updates everything was ok. Only after updating wpml and woocommerce did the translations no longer work as expected. It is some incorrect setting depending on the update that is corrected with the move

July 25, 2019 at 8:33 am #4280831

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I escalated this to second tier support.
Please be patient till we get back to you.

Regards,

July 26, 2019 at 3:25 pm #4290427

Speciale

Any news? Thanks.

July 28, 2019 at 7:43 am #4294981

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Our second tier is checking on this.

If you disable WPML temporarily, is your backend back to Italian?

Let me know.

Regards,

July 29, 2019 at 7:20 am #4297303

Speciale

After disable temporary WPML back end was in english.
So I've set wp default language to Italian -> backend is in italian
after reactivate WPML -> backend is in english and woocommerce in english

July 29, 2019 at 10:16 am #4298645

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for all the details.

Our second tier is still working on this.
Allow us some time to dig more and then we will get back to you.

Regards,

August 1, 2019 at 10:10 am #4320373

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Second tier replied:

In sandbox (we tried to reproduce in a fresh environment), not all WPML add-ons are active like on client' site.
If still not able to reproduce on clean install then ask the client to disable drop-ins.

So please try install all the WPML plugins in sandbox just as you have it on your site.
If you still do not see the issue in the sandbox try to disable WPML plugins one by one and check, when the admin backs to Italian.

Let me know.

Regards,

The topic ‘[Closed] Woocommerce not translated, backend in english (not italian as expected)’ is closed to new replies.