Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Noman 3 years, 1 month ago.

Assigned support staff: Noman.

Author Posts
November 6, 2018 at 3:18 pm #2881600

robinG-6

Woocommerce order emails are always sent in English even if Swedish is the selected (and default) language.

The subject is sent in the correct language but the email body is not.

It doesnt matter if I turn off the Email Customizer Plugin for woocommerce, the result is the same.

November 7, 2018 at 3:34 pm #2886021

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. This is a know issue and our development team is working on it, please check this link for details and workaround:
https://wpml.org/errata/an-order-completed-e-mail-is-sent-to-the-purchasing-user-in-the-default-site-language/

Thank you

November 7, 2018 at 5:58 pm #2886803

robinG-6

Ok, I have implemented the workaround and still get the same results. The email subject is in Swedish and the email body is in English. Any further suggestions?

November 8, 2018 at 12:58 pm #2889434

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

- Please make sure minimum requirements for WPML meet:
https://wpml.org/home/minimum-requirements/

- Please make sure you are using updated version of theme and plugins in your site.

- Please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

- If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site – preferably to a test site where the problem has been replicated if possible, so that I can look into your setup and try to solve this issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important

✙ I’ll use this email address to place test order: mo.n@onthegosystems.com

Thank you

The topic ‘[Closed] Woocommerce order emails getting sent in wrong language’ is closed to new replies.