This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Itamar 3 months, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
June 27, 2019 at 10:21 am #4099047

Mike de Leeuw

I'm currently using WooCommerce Multilingual and WPML. I have 3 langugages for my products.. But when I check my orders counts its not displaying the correct counts/total..

Currently I have 34 orders, but in the All languages it showing (78 orders). Also the filter for user is not working.

You can see the example below of the current orders you can see the totals/counts is not correct.

All (56) | Processing (2) | Completed (52) | Cancelled (2)
NL (33) | EN (0) | DE (1) | All languages (78)

Hoping for a fast solution.

Thanks

June 27, 2019 at 11:35 am #4099597

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm not sure that I understand the problem.

You wrote: "But when I check my orders counts its not displaying the correct counts/total..
Currently I have 34 orders, but in the All languages it showing (78 orders). Also the filter for user is not working."

Where do you see the orders counts?
Is it in WooCommerce -> Orders?

Please let me have access to your site and explain to me how to see the issue. Also, sometimes screen-shots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

June 27, 2019 at 2:44 pm #4100949

Mike de Leeuw

Hello Itamar

Please check the images attached.

Thanks

June 27, 2019 at 8:34 pm #4102943

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi,

Could you please go to WPML -> Settings -> Post Type Translation and check what translation option is set for 'Orders (shop_order)'?
It supposes to be set to 'Not translatable' and be locked. Please see the attached screenshot.

If you have changed this setting, please let me know what the purpose of this was.

Thanks,
Itamar.

June 28, 2019 at 7:40 am #4105159

Mike de Leeuw

Hello,

This is my settings on Post Type Translation. (Please check the images attached)

I think we set the shop-order to Translatable so it will display the Languages order buttons otherwise it won't. Please check the image (Shop-order-2.png)

I tried set to 'Not translatable' but it will not display the (Shop-order-2.png), and filter still not working.

Regards,

Mike

June 30, 2019 at 3:01 pm #4114305

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

The shop_order is set in the wpml-config.xml file that is found in /wp-content/plugins/woocommerce-multilingual/wpml-config.xml. By default, it is set to 'Not translatable,' and it is locked. By pressing the 'Lock' icon, it is possible to set it differently, but it is not possible to lock it again. You have it set to 'Translatable - only show translated items,' and it is locked.
Could you please explain to me how you have set it like that?
Was it by changing something in the WooCommerce Multilingual files?

Thanks,
Itamar.

The topic ‘[Closed] Woocommerce Orders not showing the correct counts and filter is not working’ is closed to new replies.