This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bigul 6 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
March 19, 2019 at 12:56 am #3374123

justinianJ

I am running WooCommerce Point of Sale. When i activate WPML string translation plugin the POS screen does done load / show. when WPML string translation plugin is off, but other WPML plugins on, then it does load / show. Any idea what the issue is?

March 19, 2019 at 12:18 pm #3378851

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

I have a request. Please upgrade the following configuration for the expected performance of your site and make sure is there any difference in the site performance.

1) Please upgrade your MySQL version to 5.6(if you are not using MariaDB), the minimum required MySQL version for WPML and the recommended version for WordPress. Check these articles for more details -- https://wpml.org/home/minimum-requirements/ & https://wordpress.org/about/requirements/

2) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

3) Increase the *MaxInputVars* of PHP settings to *5000* or more. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

Also please visit WPML>>String Translation, then choose all String domains for translation from *Auto register strings for translation* section. Check the attached images for more details.

--
Thanks!

Bigul

March 21, 2019 at 10:51 pm #3427195

justinianJ

tried the above and still same problem. server people are updating php version and maxinputvars but i dont think that will help. can i run WPML wit string translation plugin turned off for now when we debug this. need the POS to work. thanks

March 22, 2019 at 8:37 am #3438579

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please enable the String Translation plugin. Then please try the following troubleshooting steps after a full site backup and check is there any difference in the site performance or not.

1) Go to WPML>>Support page
2) Click on Troubleshooting link (blue link in the middle of the page)
3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

--
Thanks!

Bigul

March 25, 2019 at 9:45 pm #3458297

justinianJ

Hi Bigul, i followed instructions as you said for troubleshooting / clean up but still same problem. please keep helping to debug. thanks,

March 26, 2019 at 7:25 am #3459579

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Please share the following information for tracking the issue.

1) Which type of hosting you are using now, shared or VPS or dedicated?

2) Please activate Query Monitor and check you are getting any slow queries related to WPML on the pages/section you are having troubles with the String Translation plugin

3) Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

The topic ‘[Closed] WooCommerce Point of Sale stops working when string translation activated’ is closed to new replies.