This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The new version of WooCommerce includes a text field in appearance->customize->woocommerce->checkout->privacy policy

This text field appears in strings translation but it does not work when translated.

Solution:
- Go to WPML -> Translation Management -> Custom XML Configuration tab -> Add this code and Save the changes.

<wpml-config>
  <admin-texts>
    <key name="woocommerce_registration_privacy_policy_text"/>
    <key name="woocommerce_checkout_privacy_policy_text"/>
  </admin-texts>
</wpml-config>

- Go to WPML -> String Translation -> Search and translate the strings -> Save the changes.

Relevant Documentation:

This topic contains 19 replies, has 5 voices.

Last updated by Carlos Rojas 1 year, 4 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 24, 2018 at 2:58 am #2219370

Thierry

Hi,

The new version of WooCommerce includes a text field in appearance->customize->woocommerce->checkout->privacy policy

This text field appears in strings translation but it does not work when translated. There are no issues with the other text fields added in this version of WooCommerce.

The "translated" text in french:
"Your personal data will be used to process your order, support your experience throughout this website, and for other purposes described in our politique de confidentialité."

May 24, 2018 at 8:33 pm #2225472

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

Could you tell me if the issue persists with a WordPress default theme like Twenty Seventeen?

Kind regards,
Carlos

May 25, 2018 at 11:32 am #2228781

jonasL-7

I have the same thing. Tried with Twenty Fourteen and the issue is still there.

May 25, 2018 at 12:17 pm #2229127

gaborN-2

I have a similar problem too. In my case I have an English and a Hungarian version of the same site. On the checkout page for both languages the terms text appears in Hungarian. I have String translation for both languages.

May 25, 2018 at 12:42 pm #2229217

francoisA-9

Same for me. I can't even find the text in WPML string translation. I have the latest version of everything (theme, plugins etc).
There are actually two texts in Woocommerce > Settings > Accounts & privacy:

*Registration privacy policy*
Your personal data will be used to support your experience throughout this website, to manage access to your account, and for other purposes described in our [privacy_policy].

*Checkout privacy policy*
Your personal data will be used to process your order, support your experience throughout this website, and for other purposes described in our [privacy_policy].

Where do I find those??

May 25, 2018 at 1:01 pm #2229272

francoisA-9

Ok, I found them both!
WPML > String translation
"All strings", "All domains" and Make a search for: "throughout".
Both strings are there and appears as "translation complete" but the text is still in English; However, right above it, in highlighted yellow color, is the translated string.
Hope that helps.

May 25, 2018 at 2:42 pm #2230287

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

Thank you very much for your comments and feedback.

I will try to reproduce this issue on a local environment and I will get back to you as soon as possible.

Thank you very much for your patience.
Best regards,
Carlos

May 25, 2018 at 7:38 pm #2231584

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

In order to translate this string you need to follow this steps:
- Go to WPML -> String Translation -> Translate texts in admin screens » link (bottom left) -> Search for 'woocommerce_checkout_privacy_policy_text' -> Select it -> Save the changes.
- Go to WPML -> String Translation -> Search for the string and translate it.

Regards,
Carlos

May 25, 2018 at 8:43 pm #2231719

Thierry

Hi Carlos,

I tried this before. As far as I know "Translate texts in admin screens" doesn't work on any of my installs. When I load the page it crashes my tab after I start scrolling. This has been happening consistently with every site I've ever used WPML on.

May 25, 2018 at 8:51 pm #2231723

Thierry

Just tried that again and the tab crashed. The string does appear in string translation, but somehow it doesn't show the translated version on the french site

May 25, 2018 at 9:32 pm #2231790

francoisA-9

Hi Carlos, thank you for the "Translate texts in admin screens" method, I hadn't notice that lilnk at the bottom of the page.
I did that, found the strings, the translation is there but does not shows on the front end; it's always English.
--
Also, Thierry, your crash problem comes form your browser. If the list of strings is for "all domains", it's a pretty long page and it slows down , sometimes crashes.

May 25, 2018 at 9:35 pm #2231793

Thierry

Thanks @francoisa-9,

Is there any way to filter by a specific domain so the whole page doesn't load?

May 25, 2018 at 9:50 pm #2231803

francoisA-9

@thierry Not for the "Translate texts in admin screens" page, I'm afraid. Are you using Firefox or Chrome? I had to turn off the LastPass Add-on in Firefox because it was slowing down the page's loading too much. Maybe try disabling some add-ons?
In any case it seems we have the same problem. Even if your page doesn't crash, you will find the strings, the translation as well, but it still doesn't show on the page 🙁

May 25, 2018 at 10:23 pm #2231824

francoisA-9

Ok now something very strange:
the text displayed on the checkout page is NOT the one displayed on the string translation page. It is the one displayed in the Woocommerce > Settings > "Accounts & privacy" tab; Which is NOT the same text. Look at the screenshots below.
I've edited the text in the "Accounts & privacy" tab by adding a comma after the 3rd word ("personal data,"). Saving that, going back to string translation, the text is unchanged and the comma is not there.
Refreshing the checkout page, the comma is there. The text from the string translation page, no matter if it's English or French are NOT used at all.
What's going on??

May 28, 2018 at 11:45 am #2238152

gaborN-2

@carlos Rojas, thank you for fix, but I have the text translated already. It just doesn't translate it on the FE of the site. Can you advise further?