Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 5.33 hours from now. Thank you for your understanding.

This topic contains 19 replies, has 3 voices.

Last updated by James 6 years, 11 months ago.

Assigned support staff: Harshad.

Author Posts
February 1, 2013 at 3:42 pm #101317

James

I'm having some challenges integrating wpml with woocommerce even though I have the latest version of both and have carefully followed your documentation. Can someone look at my site and give me a hand?

February 1, 2013 at 4:52 pm #101341

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello James,

Ok lets have a look. I've sent you a private email regarding a link to your website.

Have you also installed the "Woocommerce Multilingual plugin" ?
http://wordpress.org/extend/plugins/woocommerce-multilingual/

Also, just to mention it we have a short Woocommerce tutorial in our documentation section:
http://wpml.org/documentation/related-projects/woocommerce-multilingual/

Which challenge is the most urgent one at the moment?

February 1, 2013 at 4:57 pm #101343

James

The site is here: hidden link

I've already installed the plugin and gone through the tutorial.

Once I activate the plugin, I don't even have access to my pages; the switcher on products doesn't work; etc. etc. It becomes terribly broken.

February 1, 2013 at 5:12 pm #101350

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello James,

Thanks for the link! This might not solve the problem immediately but is important to do:

# Could you update "Woocommerce" to version 1.6.6 ?

# Could you also install our plugin "Installer" available here hidden link ?
Once installed please go to "Settings > Repositories" and login there into WPML.org

February 1, 2013 at 6:09 pm #101374

James

Okay, updated woocommerce and installed the "Installer" plugin.

Now my theme is really broken. 🙁

February 4, 2013 at 6:19 am #101662

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello James,

If the upgrade to Woocommerce 1.6.6 has broken your theme then is an issue you should definitely report also to the author of your theme. Other theme users will experience similar issues.
I have sent you also an email regarding the credentials you've sent me.

February 4, 2013 at 2:09 pm #101818

James

I'm the theme author.
It just broke the styling, which I can fix, but I'll leave it for now so you can take a look.

It's weird because the styling on the english pages is broken: hidden link

but the french pages are fine: hidden link

February 4, 2013 at 7:20 pm #101921

James

Any luck? I'm really hoping to get this resolved sooner rather than later.

February 5, 2013 at 4:15 pm #102151

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello James,

I assume that the styling "falls apart" on the English part because of yet missing content.

The content on hidden link , below heading "Mannequins adultes" comes from where exactly? A page, post or product?

Once we know that we need to find the English equivalent since your website's default language is English.

February 5, 2013 at 4:29 pm #102156

James

It's a page. You'll see it in the wp admin area. The english equivalent is also there if you look.

This process is taking a really long time. Can we chat? or can I call you? I'm finding this painfully slow.

February 5, 2013 at 4:33 pm #102157

James

Here's the link to the page in the wp admin area
hidden link
It looks like it's weirdly become a post, even though at the top it says "Edit Page"

February 5, 2013 at 6:02 pm #102186

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hi James,

Thanks a lot. Now, this page should be a translation of an existing English page.
Could it be that you haven't created this page yet?

February 5, 2013 at 6:10 pm #102190

James

Of course I created that page.

I don't want to be rude, but are you even trying? if you click on the English Translation link on the right hand side, you can see the english version of the page.

Sorry if I'm coming off as abrasive but I'm finding this incredibly frustrating.

February 6, 2013 at 12:07 pm #102312

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hi James,

This is exactly my point, bear with me here, just to outline the problem:

1) Where in the WP backend, in the list of "Pages" is...
-the French page with title "Mannequins adultes"
- the English page with title "Adult Manikins" ?

2) If I search fro them via the box "Search Pages" I end up in the Products of the shop.

3) And to make the confusion perfect under "Posts" you have altogether 24, but only 1 for English and one for French.

Means, some database relation between the different post_types is not intact anymore.
I am going to discuss this issue with two other developers and we will get back to you soon.
Thank you for your patience!

February 6, 2013 at 1:31 pm #102335

James

Exactly. I've put in all the content correctly but it's not showing up properly at all.