This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 16, 2018 at 9:02 am

oriolc-3

I am trying to: add a product and nothing happens, it changes de currency from my website

Link to a page where the issue can be seen: hidden link
inspect to see: an option to add 60ML Balm
Instead, I got: as soon as you add, the currency changes automatically, and nothing is added on the cart, different currencies showing on the page.

** I had to deactivate the plugin add-on because it's broken currencies by default, so I had deactivated, better reproduce in local. JFYI

September 18, 2018 at 2:43 am #2743221

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Could you tell me if this Woocommerce Add-on appears in our Multilingual-Ready Plugins list? https://wpml.org/documentation/plugins-compatibility/

2.- Have you contacted the plugin's support service about this issue?

Kind regards,
Carlos

September 18, 2018 at 6:19 am #2743645

oriolc-3

1-YES
2-YES

September 18, 2018 at 5:52 pm #2746192

oriolc-3

any update is highly appreciated.

September 18, 2018 at 9:21 pm #2746565

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

I would like to ask you to follow this steps:
- Back up your site first before making any change, this is for security reasons.
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link -> Sync all products.
- Go to WPML -> Languages -> Language filtering for AJAX operations -> Activate this option -> Save the changes.
- Go to Woocommerce -> Woocommerce Multilingual -> Status tab -> Fix any issue that might appear there.
- Go to WPML -> Support -> Troubleshooting link -> Click on the 'Clear the cache in WPML' button.

If the issue persists after the steps above then I kindly ask you to:
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Looking forward to your answer.
Best regards,
Carlos

September 19, 2018 at 7:04 am #2747479

oriolc-3

I tried everything you mentioned below,

the problem still persists, unfortunately. and just a quick reminder, this is a production site, for testing purposes you already have a backup from my site.

Any other ideas?

thank you

September 19, 2018 at 4:29 pm #2749463

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

I'm downloading the copy of the site you shared. My next step will be try to reproduce the issue on local and isolate its cause.

I will get back to you as soon as I have an answer.

Best regards,
Carlos

September 19, 2018 at 9:59 pm #2750138

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

In the local copy of the site I followed this steps:
- Flushed the cache memory.
- Deactivated all plugins except WPML plugins, Woocommerce, Woocommerce and WooCommerce Product Add-ons.
- Went to Woocommerce -> Settings -> Products -> Set the Shop page -> Saved the changes.
- Went to WPML -> Languages -> Activated the Ajax cookie.

In this scenario the issue disappeared, which means that its cause is not in the interacction between WPML plugins and WooCommerce Product Add-ons plugin.

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Flush all cache memory.
- Deactivate all the plugins except WPML plugins, Woocommerce, Woocommerce and WooCommerce Product Add-ons.
- Double check that the issue is gone and activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Best regards,
Carlos

September 23, 2018 at 10:49 am #2758508

oriolc-3

I'll try to do my best, it's a production environment, and we can't be deactivating all plugins.

thank you

September 23, 2018 at 12:13 pm #2758594

oriolc-3

I reproduced myself, and I found the problem was with the plugin "WooCommerce One Page Shopping" so thank you so much.

September 24, 2018 at 4:39 pm #2761320

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos