This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 2 voices.

Last updated by Carlos Rojas 12 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 28, 2018 at 12:05 pm

jasonN-10

Hi,

I am having problem with the custom product base. Its working for the default language but its not working for other languages. Please consider the following URL(s).

hidden link ~ Working

hidden link ~ Not Working

I was only able to create an archive of the database via duplicator you can download the files from FTP.

I am granting the access to the website please check and let me know

Thanks

September 30, 2018 at 4:47 pm #2776681

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Finish the Woocommerce database update.
- Update all outdated plugins and themes.
- Flush any cache memory that might exist.
- Go to Woocommerce -> Woocommerce Multilingual -> Status tab -> Fix any issue that might appear there.
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link -> Sync all products.

Could you tell me the result of this steps?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

October 3, 2018 at 5:39 am #2783519

jasonN-10

Hello Carlos,

Apologies for the delay. I have implemented all the above steps but still not able to make it work. I am having some problem with my dev server so I have moved the website to a new server.

hidden link

The login details are same.

Please check and let me know

Thanks

October 3, 2018 at 5:44 pm #2785424

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

Before we continue isolating the cause of the issue I need to ask you to update all outdated plugins and themes, specially WPML plugins, to their latest version. Outdated functionalites can cause conflicts in the code.

Note: Please don't forget to create a full backup of the site before making any change.

Looking forward to your answer.
Best regards,
Carlos

October 4, 2018 at 4:44 am #2786428

jasonN-10

Hi

I have updated all the plugins Related to WPML. Please check

Thanks

October 4, 2018 at 5:22 pm #2788377

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I visited the site and I still can see 19 pending updates, including WPML pending updates. Please update all plugins to their latest version so we can rule out some possible compatibility issue that has been solved already.

Please let me know if the issue persists after updating all plugins.

Best regards,
Carlos

October 5, 2018 at 4:17 am #2789546

jasonN-10

Hello Carlos

As I mentioned in my previous message, I moved the site to another server. Please check here
hidden link

Wp admin details are same.

Thanks

October 5, 2018 at 6:25 pm #2791524

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
I'm sorry, I made an honest mistake. Please accept my apologies.

I took a deeper look at the issue and it seems that the cause is in the permalink structure for the products. I set the default permalink structure for products and the issue disappeared. Also, I fixed the slug translation for the Products German (WPML -> Settings -> Post Type Translation -> Products).

Note: I also increased the memory limit to 128M to meet WPML minimum requirements: https://wpml.org/home/minimum-requirements/

Could you confirm that the issue is solved?

Looking forward to your answer.
Best regards,
Carlos

October 8, 2018 at 4:15 am #2794735

jasonN-10

Hello Carlos,

Yes the default permalinks are working but due to SEO practices we cannot use the default ones. For Example for the product category Stereo Microscopes the permalink works for default language but not the other languages

hidden link ~ Working (UK english)
hidden link ~ Not Working (German)

Can you please let us know that how can we have the permalink working in other languages too.

Thanks

October 8, 2018 at 6:23 pm #2797088

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

Please check this two links:
- hidden link
- hidden link

Could you confirm the issue is solved in this test site?

Regards,
Carlos

October 9, 2018 at 4:15 am #2798227

jasonN-10

Brilliant mate , Can you please let me know how did you fix the issue.

Thanks

October 9, 2018 at 5:19 pm #2801351

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Great! 🙂

I have modify the slugs according to your request. Please check this configurations and compare it with the live site:
- WPML -> Settings -> Post Types Translation -> Under Products click on 'Set different slugs in different languages for Products.' link.
- Settings -> Permalinks -> Product permalinks -> Custom base
- Woocoomerce -> Woocoomerce Multilingual -> Store URLs tab -> Product category base

See attached images.

Note: Please keep in mind that I was focused on German language, for the other languages you might need to add slugs and translate them.

Best regards,
Carlos

October 10, 2018 at 8:54 am #2803491

jasonN-10

Hello Carlos

I see you changed the product custom base to /products which results in 404 for this permalink hidden link

We want it as /products/%product_cat%/.

Please check and let us know

Thanks

October 10, 2018 at 7:15 pm #2805512

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

There is an inconsistency in your message. As you can see from the last attached image in my previous message the product slug is set to 'product' in singular and the plural ('products') is used in the Product Category Base (first attached image).

Also you mention that the URL hidden link throws an 404, which is correct, because it is the wrong URL, the correct URL is hidden link because this is a category page, not a product page.

Lastly, you say that you want to use '/products/%product_cat%/'. Just to confirm: do you want to use this URL structure in single product pages or in product category pages?

Looking forward to your answer.
Best regards,
Carlos

October 11, 2018 at 4:18 am #2806641

jasonN-10

Hello Carlos
Apologies for the misunderstanding

The default language(UK English) is having permalinks like /product/catname for product categories and /products/catname/productname for single products.

You can check the live site if there is any confusion
hidden link
hidden link

I hope its clear now,

Thanks