This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: My product gallery images do not show in the secondary language.

Solution: I found that in the secondary language, the images have different titles and they were all throwing 404 not found errors in the browser console. I went to WooCommerce -> WooCommerce Multilingual and changed the settings to edit the product using the native WordPress editor. I then uploaded a copy of the image that I made from the DE product. Now you can see that the image zoom is working correctly on the English translation.

This topic contains 5 replies, has 2 voices.

Last updated by jasminF 1 year ago.

Assigned support staff: Lauren.

Author Posts
September 28, 2018 at 4:54 pm

jasminF

I am trying to:
Show the image on second language, but it dosent work well. On the Primary Language it show right, on the Secondary it show mostly the smal image ( thumnbail ), but when you wana look the bigger version it dosent work.

Link to a page where the issue can be seen:
Primary-Language DE:
hidden link

Secondary-Language EN:
hidden link

I expected to see:
The Correct Image like on Primary-Product

Instead, I got:
Only the Thumbnail.

October 1, 2018 at 3:50 pm #2778668

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Are you seeing any errors in your browser console when you try to click the image in the secondary language?

I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentySeventeen. With these settings, is the issue resolved?

October 5, 2018 at 10:03 am #2790289

jasminF

Hi Lauren
I test it on my DEV-site with your instructions, but the its the same Problem. I make a normal page, and add a gellery tho them, its the same problem. I make for you a account, so when you want you can logged in and check it.
i have a full backup.

October 5, 2018 at 7:13 pm #2791569

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I tried to reproduce the issue on a clean install, but was unable. Can you please tell me if you are using a plugin or if it is in your theme settings where you can set the ability to zoom on the pictures when you hover over them?

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

October 6, 2018 at 8:54 am
October 9, 2018 at 12:30 pm #2799964

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks so much for sending over the files. I found that in the secondary language, the images have different titles and they were all throwing 404 not found errors in the browser console. I went to WooCommerce -> WooCommerce Multilingual and changed the settings to edit the product using the native WordPress editor. I then uploaded a copy of the image that I made from the DE product. Now you can see that the image zoom is working correctly on the English translation.

Please test this on your end and let me know if you have the same results.

October 12, 2018 at 7:56 am #2811040

jasminF

My issue is resolved now. Thank you!