This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
May 21, 2018 at 8:08 pm

andisZ

I am trying to:Resize product images and thumbnails, however changes appear only in additional language, not base language.

Link to a page where the issue can be seen:hidden link
I expected to see:hidden link

Instead, I got:

May 22, 2018 at 6:32 pm #2211282

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to ask you to follow this steps in order to solve the issue:
- Go to WPML -> String Translation -> Translate texts in admin screens » link (bottom left) -> Search and select 'woocommerce_thumbnail_image_width' and 'woocommerce_single_image_width' -> Save the changes.
- Go to WPML -> String Translation -> Search for the values of this strings (600 and 250) -> Translate the strings (keep the same values), make sure the option 'Translation is complete' is selected -> Save the translation.

Could you tell me if the issue persists?

Kind regards,
Carlos

May 24, 2018 at 2:25 pm #2223692

andisZ

Hi!

Thanks! It kind of helped. 🙂 Regenerated thumbnails as well. Probably my core problem is theme incompatibility with WooCommerce 3.4, I it causes several tricks with product images. After everything being fine, a day later again image settings changed, but now at least i know how to keep settings between the languages. I will investigate more myself and let you know if more help is needed.

May 24, 2018 at 2:30 pm #2223705

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I'm glad to hear that you found the cause of the issue 🙂

Please don't hesitate to contact us if you need our help in the future with WPML.
Best regards,
Carlos

May 24, 2018 at 2:57 pm #2223735

andisZ

Just give me small additional hint, please - I installed WooThumbs to deal with image and thumbnail issues. And again synchronization between languages seems lost. But this time, the admin text strings are not being added to String translation.
I found WooThumbs settings in admin texts (Translate texts in admin screens)

display_images_single_image_crop_width
display_images_single_image_crop_height
display_images_gallery_thumbnail_image_crop_width
display_images_gallery_thumbnail_image_crop_height

But after selecting them and pressing Apply, I get message "Saved", but afterwords cannot find them in String translation. 🙁

May 24, 2018 at 3:37 pm #2224212

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

The cause of this issue is ussually associated to a low value in the max_input_vars. I recommend you to contact your hosting providers and ask them to increase the value in max_input_vars.

Then try adding the strings of the admin texts again.

Regards,
Carlos

May 24, 2018 at 5:25 pm #2224757

andisZ

My hosting is Pressable.com. They are not allowing increase of these parameters. I actually have added lot of unneeded texts for string translation (by automatic adding). If I delete them, could this help somehow? I actually tried, it didn't help, but maybe I have to "empty trash" or something?

May 24, 2018 at 6:25 pm #2224976

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Increasing the max_input_vars should be the correct way to solve this issue. I recommend you to install a copy of the site on a local environment and try to fix the issue. If the issue gets solved then restore the copy of the site in the hosting.

This way you can rule out if the max_input_vars value is the culprit of this issue.

Please let me know if you need further help.
Best regards,
Carlos

May 24, 2018 at 6:36 pm #2224989

andisZ

That could be too complex, I have no local environment or other hosting. Maybe I can run an SQL query in MyPHPadmin to add the needed strings? I have to deliver project on Monday and become nervous... Maybe upgrade to WPML 4 beta could help? 🙂 or that is too dangerous... I am just wondering why could I add admin texts all the time and suddenly not anymore? Is it really max_input_vars cause? Or maybe I did something wrong when doing clean-up in WPML-Support-Trubleshooting?

May 24, 2018 at 7:07 pm #2225146

andisZ

My current setting is PHP max input vars: 6144

May 24, 2018 at 8:00 pm #2225244

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

If you authorize me I can create a copy of the site and test it on a local environment. This way I can apply the tests without affecting the live site.

Regards,
Carlos

May 25, 2018 at 5:54 am #2226877

andisZ

Hi, how can I deliver credentials? They are slightly different from that in my first post, that was a test clone, now I have issue in release candidate site.

May 25, 2018 at 2:30 pm #2230263

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I have set your next answer private, there you will find the fields for the required credentials. Only you and me will have access to this information.

Note: Was the issue solved in the test site?

Regards,
Carlos

May 26, 2018 at 8:51 am
May 28, 2018 at 1:03 pm #2238616

andisZ

Hi! I just wanted to let you know I reinstalled everything on a new instance of WP and the problem is not relevant anymore. Installed WPML 4 beta 🙂 So far everything is fine, except that language switch dissapears from time to time. 🙂