Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I use the woocommerce multilanguage and when I translate to greek the link doesn't use the title in the link instead it takes some automatic translation that's not correct.

Solution: Add term translation and finish the translation. You always need to finish translation 100% in order for translation to show.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by annikaN-2 5 months, 2 weeks ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
May 3, 2020 at 9:44 am #6046701

annikaN-2

Tell us what you are trying to do? Translate products from english to greek

Is there any documentation that you are following? I looked on a lot of different

Is there a similar example that we can see?

What is the link to your site? hidden link

I use the woocommerce multilanguage and when I translate to greek the link doesn't use the title in the link instead it takes some automatic translation that's not correct (I building a shoe shop and for instance Heels which is πέδιλα in greek but the link become τακούνια which mean the heal of a shoe. And plattform which is plattforma in greek turned to only plat). I try to change the links in the translation but then I got error 500 nearly on all the pages so needed to trash all the greek products. So how can I do this?

May 5, 2020 at 4:06 pm #6063651

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello,
Thank you for contacting WPML support.

1.- Please describe step by step how to reproduce the issue on the site. You can attach some screenshots or make a screencast where you reproduce the issue. This way I will have a better understanding of the problem.

2.- I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to back-up the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

3.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:`

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

May 6, 2020 at 11:04 am #6069541

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

I don't fully understand where is the problem. Could you provide a specific example where I can see the issue happening?

Please attach some screenshots and highlight where is the issue.

Regards,
Carlos

May 6, 2020 at 11:56 am #6070285

annikaN-2

Hi again,
I attached one screen print where I marked in blue on the translation where the link gets wrong and when I try to change it it's not connected to the english translation or shows up correct on the website, even if the category has the name πέδιλα, I hope this will be to some help
Thanks
Annika

May 6, 2020 at 12:28 pm #6070497

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,
Thank you very much for the screenshot.

If you set the correct translation for the category on the secondary language and finish the translation, does the issue persists?

Regards,
Carlos

May 6, 2020 at 12:53 pm #6070665

annikaN-2

As I told you if I change the link it doesn't connect with the english product and not show up on the pages, if I try just to open the shoe with the link I get error so this is the whole issue. And for another category I tried it took only the half name of the greek category. I want it of course to take the correct and whole category in the link. The visitor maybe not care but for SEO is important

May 6, 2020 at 1:09 pm #6070849

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

I finished the translation and added the greek term you said it was the correct one (I'm sorry, I don't speak Greek so I just copied and pasted) and now I can see the product on both languages correctly: hidden link

Could you visit the product in Greek in the link above and check if you still see the problem?

Regards,
Carlos

May 8, 2020 at 3:25 am #6085475

annikaN-2

Sorry I didn't got an email that you answered and now went in because it seemed to take a long time your support is always fast.
It works now very nice so you just changed the the link? Just so I know what was the issue.

Thanks,
Annika

May 8, 2020 at 6:45 am #6086153

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

Carlos is off today, so I will be taking care of his ticket.

As I understand Carlos added term translation and finished translation. You always need to finish translation 100% and save.

Can you please check and test if now everything oke?

Let me know how it goes.

Thanks and regards,
Drazen

May 8, 2020 at 9:12 am #6087025

annikaN-2

It seems fine now but I will see when I start with another category because the problem was with the category url
Thank you,
Annika