This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 8.19 hours from now. Thank you for your understanding.

This topic contains 12 replies, has 2 voices.

Last updated by Andreas Neuber 5 years, 4 months ago.

Assigned support staff: Andreas Neuber.

Author Posts
February 28, 2014 at 2:06 am #349058

beverlyM

Hi there - I have installed all the relevant plugins to run WooCommerce but am having a lot of trouble getting it to work. I have gone through all of the getting started and successfully added my translation to an example product. When on the english site I click 'swedish' - the product is not translating and actually nothing is happening. The product says 'complete' in status and when I view it in WooCommerce Multilingual I can see it is finished. Could you offer me some help please!!?? Many thanks in advance.

February 28, 2014 at 7:43 am #349114

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Beverly,

Sorry to hear about the trouble!
Lets check some points one by one..

1) Are you using WPML version 3.4.1-b6 or 3.0.2-a ?

I really recommend to switch to 3.4.1-b6, since lately some critical bugs were addressed and fixed.

You can get it from your WPML account. Go to Downloads, scroll to the bottom and you will see the beta package.
This ZIP includes several ZIP files of the individual WPML components. First, unzip it locally, get the parts that you need and upload them.

The safest way to update the plugins is to:
1. Create a backup of your installation*
2. Deactivate (don't worry, your content doesn't change)
3. Delete the folders with the older versions
4. Upload the new versions (main plugin: "sitepress-multilingual-cms" folder)
5. Activate

2) Under "WPML > Translation-Management > Multilingual Content Setup"
Could you take a screenshot of section "Custom posts" and it here?

4) Could you provide us with a screenshot of your settings under "Settings > Permalinks"?

5) On "WPML > Woocommerce Multilingual" are there any red warning icons?
(if so please feel free to take a screenshot and attach it here)

6) Also, could you check setting "WPML > String Translation > Original language of strings" ?
Is it set on English?

Thanks a lot!
Sorry, lots of points but I thought I give them all at once to you since it saves us actually time.

--
* I recommend plugin "Duplicator" - very easy to handle backups

March 14, 2014 at 11:45 pm #359517

beverlyM

I have attached the screenshots thank you.

March 15, 2014 at 4:33 pm #359774

beverlyM

Would I be able to grant you a temporary login to my site so you could take a look?

Many thanks.

March 17, 2014 at 9:58 am #360410

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hi Beverly,

Sorry for the delay on my end!
I think with the 2nd screenshot I see something which we should correct.
So, yes, a temporary login would be good.

You should see below my comment here a protected webform for adding credentials.
Starts with "Backup, disclaimer" etc.

Thanks in advance!

March 17, 2014 at 12:48 pm #360576

beverlyM

Hi Andreas,

I don't know why my menu isn't shifting when I press english.

Also - the pressing shop on swedish seems to redirect me to english shop.

Many thanks,

Bev.

March 17, 2014 at 1:39 pm #360637

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Thanks a lot for the login data - I'm checking this now..

March 17, 2014 at 1:42 pm #360642

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Me again, I think there is a small error in the WP credentials - possibly small typo.
Could you check this for me? Thanks.

March 17, 2014 at 1:45 pm #360648

beverlyM

Sorry Andreas - could you please try again?

Many thanks.

March 17, 2014 at 6:55 pm #360957

beverlyM

Details updated and checked.

March 18, 2014 at 12:04 pm #361540

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Thanks a lot - login works now.

I've updated all your relevant WPML plugins, checked different settings and went then to product "Nozzle Repair Tool". There I checked if the product has all the Swedish translations - it has them, also correct.
Nonetheless, as you mentioned, all stays simple English except the price 😐

Could you please check/try this:

1) At hidden link we see in the left upper corner a text string "ra-51ec33f76f5436de" - do you know what this could be?

2) Could you 1x time switch to the WordPress default theme - just to see if this makes a difference?
If it does then at least we know that some theme functionality interferes.

March 18, 2014 at 12:54 pm #361577

beverlyM

Hi Andreas,

I switched to default theme but the language switcher disappeared from the nav.

The string I have been told is the theme-license needing updated.

From home - the language switcher works and changes the menu into swedish.

It just doesn't seem to be working in WooCommerce at all.

Many thanks.

March 19, 2014 at 10:08 am #362375

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Beverly,

So with the WordPress default theme it worked it worked?
Or because of the missing switcher you couldn't test yet?

You could activate the option "WPML > Languages > Language switcher options > Show language switcher in footer". This way you will have 100% a switcher in the footer when you switch the theme.
Could you try this again and let me know if the SV translations appear then?

The topic ‘[Closed] WooCommerce product not switching languages’ is closed to new replies.