This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by andreac-90 3 months ago.

Assigned support staff: Yvette.

Author Posts
July 14, 2019 at 7:45 am #4205217

andreac-90

Hi, I started i support chat two days ago but I still have no answer. I sent WP credential for you to look deeper but the problem is still there (product page blank in some languages)

July 15, 2019 at 7:39 am #4207913

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I´m sorry but I cannot see any reference to the chat you are referring to.

Do you have a link or the name of the supporter that was helping you? I can then try to track down the status of the ticket.

July 15, 2019 at 8:37 am #4208343

andreac-90

Hi, and thank you,

it was a chat support "Woocommerce Product page not showing products in some languages" with Shekhar Bhandari.

here is the full text:

Shekhar Bhandari : Hello there, Welcome to WPML chat support. 🙂
Shekhar Bhandari : Have you completed the translation in the mentioned language?
andreac-90 : Yes, everything was working fine till a few days ago
Shekhar Bhandari : Could you please go to Dashboard->Products and see those products there/
andreac-90 : but this is not the first time I have this problem; it seems it appears quite randomly
andreac-90 : everything is there
Shekhar Bhandari : Do you notice any changes you have done recently?
andreac-90 : no, not in the product section
Shekhar Bhandari : Strange, can you provide me login details so I can quickly checK?
andreac-90 : ok
andreac-90 : do you also need ftp?

Shekhar Bhandari : No need right now, will let you know afterwards if needed

andreac-90 : ok, did you see my wp credentials?
Shekhar Bhandari : Yes, that's what I need

July 15, 2019 at 10:43 am #4209991

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

It seems that the chat was closed as there was no response from your side for several minutes.

In this case, we´ll take this on here as a new issue. So, could you please provide system access in the private section below, an example on your site that illustrates the problem and clear steps on how to replicate the problem on your site.

We´ll work forward from that info on this ticket.

July 16, 2019 at 9:36 am #4218173

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Thank you for the access - I confirm that I am able to connect to your site.

I still need an "example" of the problem you are describing: (product page blank in some languages)

Is there a particular product where this happens all the time ?
Is there a language that it happens in?

In order to resolve this issue as quickly as possible, we would require a case that is replicable and consistent.

Thank you for your further assistance.

July 16, 2019 at 2:44 pm #4221211

andreac-90

Hi,

the problem is in the shop page in english and italian (hidden link and hidden link) while in french all the products are present (hidden link);

single product pages are ok in all three languages.

attached are screen capture of the shop page in the three languages

July 17, 2019 at 8:33 am #4227535

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I´m not sure what the original issue was, but I did the following actions and now your shop page is visible in all langauges:

- Enter Thrive architect in EN page
- Resave and launch preview of page
- Resave the Permalinks in Settings > Permalinks

I´ve tested in icognito mode and all 3 shop pages are showing products.
Can you check yourself and close this ticket if you see all in order?

July 18, 2019 at 11:08 pm #4242535

andreac-90

Ok, I checked and the pages are visible now. Do not know what the issue was but thank you!