Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Shekhar Bhandari 4 years, 6 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
March 22, 2016 at 4:53 pm #843770

guidoL-5

My WooCommerce product pages lead to "Page not found" URL. I have tried disabling all of the plugins and also I tried updating the permalinks page.

Its not working ..

March 22, 2016 at 6:50 pm #843855

guidoL-5

I have added a screenshot of my current permalink settings. You can check the website out from here: hidden link

March 23, 2016 at 4:16 am #844064

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for contacting WPML support.

#1
It seems you have translated the product slug, could you first make sure you followed the below steps properly to translate the product slug, if not please follow it.

1) Go to WordPress -> Settings -> Permalinks -> Optional section -> Product Category base and enter “product-category’ and save the permalinks. Note: if you see this value appear in grey color it is NOT inputted, and you need to do it manually.

2) Go to WPML->Themes & Plugin Localization -> Select how to translate strings in the theme and plugins -> check the “Translate the theme and plugins using WPML's String Translation” checkbox.

3) Go to WPML -> Translation Management -> Multilingual Content Setup -> Custom posts slug translation options and enable the “Translate custom posts slugs (via WPML String Translation).” checkbox.

4) Go to String Translation -> and search for “product-category” strings.

5) You can find a product-category string where “Domain ⇒ WordPress & Name ⇒ URL product_cat tax slug”

6) Click on the strings and translate it accordingly.

#2
Could you also check if changing the product permalinks to default or shop base with category solves the problem?

I will wait for your feedback.

Thanks

March 23, 2016 at 4:28 am #844071

guidoL-5

Hello Shekhar,

Below is the response to your requests ..

#1:
1) Done
2) Was already selected
3) Was already selected
4), 5), 6) Done

#2:
Its working if I set the permalinks to default.

Still not working ..

Also I currently replaced the product category based for one you asked, but I will be needing it to be 'producten' for both languages.

If you want access to the website, I can provide you that ..

March 23, 2016 at 4:30 am #844072

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Sure, let me have a look at your settings, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues needs some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Thanks

March 23, 2016 at 8:42 am #844187

guidoL-5

I have provided the details ..

March 23, 2016 at 8:56 am #844205

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Could you please check your problem again, I have fixed the issue, the problem was that you need to use the following value as default values, which was changed.

Product category base => product-category
Product tag base => product-tag

Please let me know if the problem is fixed, I look forward to your reply.

Thanks

March 23, 2016 at 9:35 am #844234

guidoL-5

Hello Shekhar,

Isn't is possible for me to use 'producten' instead of 'product-category'

March 23, 2016 at 9:38 am #844240

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Could you please explain a bit more, as I am abit confused about where are you referring to use product-category instead of product?

I will wait for your feedback.

Thanks

March 23, 2016 at 9:54 am #844261

guidoL-5

Currently the product category base is 'product-category', which obviously affects the URL structure of product categories ..

I want them both to be 'producten' ..

Current product category page: hidden link

Required product category page: hidden link

magento-nl is a product category, just to be clear ...

March 23, 2016 at 10:06 am #844279

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Yes, you can change the product category to producten for category pages but you need to make sure your category base and custom base is not same, the reason for this is custom base works for single products and category base for category pages and if they match each other there can be 404 errors.

Thanks