This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 4 voices.

Last updated by johannesM-3 2 years ago.

Assigned support staff: Bruno.

Author Posts
June 28, 2017 at 1:56 pm #1307600

romanC-5

Hi WPML Team,

I've set the permalink structure and language for the WooCommerce product slug.

I've translated it and it's not changing when switched from french to spanish or from french to english.

It remains the french one : boutique.

Others like "product-category" are working well the same way.

I already tried to deactivate all plugins (except WPML's ones and WC) and to switch theme for twenty-seventeen. It didn't change anything.

I've tried to search some solutions on forum and tested the following one :
- Click on the WPML > Theme and plugins localization.
- Select the "Translate the theme and plugins using WPML's String Translation" option and click on the 'Save' button
- Click on the WPML > String Translation. Search for 'product' and remove this string
- Click on the Settings > Permalinks. At the end of the page, click on the 'Save change' button
- Click on the WPML > Translation Management > Multilingual Content Setup > Custom posts.
- Click on the 'Save' button, to re-save the translation options of slugs
- Translate the string again of the product slug and click on the 'Save' button.

Without more success...

We are trying to solve the problem on our test website (which is the exact mirror of our production website) and we can let you access this if needed.

URL of a translated product (it's needed to connect to see the website) : hidden link

Thank you for your help,
Regards,

Roman

June 28, 2017 at 9:18 pm #1307945

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

/Thank you for contacting WPML support. I'll be happy to help you with this

If you go to WPML -> Translation Management -> Multilingual Content Setup, scroll down to custom post types and make sure Products is set to translate. There, you should also see a check box to translate the product slug. Is this checked? If not, check the box and click Save and then you should see fields where you can add the slug translations.

Please let me know if you need any further assistance and I will be happy to help.

June 29, 2017 at 9:47 am #1308339

romanC-5

Hi,

The box for slug is not checked, but I can't check it as it's grey.
Is there an option somewhere to make it possible to check ?

Thanks for your help,
Regards,

Roman

June 29, 2017 at 4:18 pm #1308826

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

It could be a setting in the language configuration file. Please check your theme folder and see if there is a file named wpml-config.xml. If so, please open it and look for a field related to the product slug. You can remove the line and then go back to WPML -> Translation Management -> Multilingual Content Setup and see if the checkbox is still greyed out.

June 30, 2017 at 1:59 pm #1309560

romanC-5

Hi,

I've found the wpml-config.xml file but there is no product slug line.
I join a printscreen of the file content.

Thank you for your help,
Regards

Roman

July 3, 2017 at 12:46 pm #1310659

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

July 4, 2017 at 4:34 pm #1311922

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Lauren is off today. I'll help you with your ticket. I hope this is ok.

I've fixed the problem in your testing environment. To fix the problem I've followed these steps:

- Click on the Plugins > Installed Plugins
- Disable the WooCommerce Multilingual
- Click on the WPML > Translation Management > Multilingual Content Setup
- Click on the "Custom Posts"
- Check the "Use different slugs in different languages for Products." option
- Set the permalink as desired and click on the "Save" button
- Activate WooCommerce Multilingual again.

Please, could you check if your site is working as desired?

Thank you.

June 27, 2018 at 3:49 pm #2439118

johannesM-3

Hi, I have the same problem. I tried your solution, but in WPML > Translation Management I can't find any field that is called Multilingual Content Setup.

Did that maybe change with the last plugin updates?

Can I find the option "Use different slugs in different languages for Products." somewhere else?

Thanks