This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Lauren 6 months ago.

Assigned support staff: Lauren.

Author Posts
April 18, 2019 at 3:37 pm #3640441

guillaumeD-28

Hello,

A problem with my media translation... using woocommerce and WPML

1) All product feature images are displayed in English (wpml source language) but not for the Thai translation.

2) Products vignettes are not displayed on the product pages for both thai and english language.

Could you please let me know where I can fix this issue?

Thank you in advance

April 18, 2019 at 6:15 pm #3641421

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

This issue has been escalated to our developers. As soon as we have a workaround or update, I will reply here in this ticket. Thanks in advance for your patience.

April 22, 2019 at 1:17 pm #3655835

guillaumeD-28

Hello Lauren, did the developer find a way to fix the issue? Please let me know anything I can do. It is quiet urgent as it is ruining our SEO. Thank you very much. Guillaume

April 22, 2019 at 1:28 pm #3656005

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

This issue will be resolved in the next WooCommerce Multilingual release. In the meantime, there are 2 possible workarounds:

1- Rollback to a previous version of WooCommerce Multilingual (which you can find here https://wpml.org/download/woocommerce-multilingual/?section=changelog)
2- Comment out this line in wp-content/plugins/woocommerce-multilingual/inc/class-wcml-products.php:689

$data['_product_image_gallery'] = null;
April 24, 2019 at 5:32 pm #3675581

guillaumeD-28

hello Lauren,

I try your way but it still doesn't work with your version and putting the line 689 doesn't work neither. Please do you have a real feedback from the developers?

April 24, 2019 at 5:35 pm #3675583

guillaumeD-28

Also i notice since last Friday than the permalink in Thai have this double //
I guess it is related to this problem.

Please find the screenshot attached.

I am looking forward to hear back from you

Kind regards

April 24, 2019 at 7:44 pm #3676509

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I don't think the issue with the permalinks is related, I have not seen this reported else where. Please open a new ticket for this issue, and the next available supporter will be able to take a look.

As for the gallery issue, there is a beta version available here: https://wpml.org/account/downloads/ (select beta from the drop down instead of stable). This version is currently in testing, so I suggest testing this on a staging site first if you have one available. OTherwise, you can revert to an earlier version or wait for the stable release, which will come out when testing on the beta is completed.