Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Andreas W. 6 months ago.

Assigned support staff: Andreas W..

Author Posts
May 22, 2019 at 7:43 pm #3868901

konstantinosP-12

Hello,

I found a lot of threads discussing the same issue but i haven't manage to solve mine.

I'm using two languages, French & English.

When i started building the website the default language was English. After i finished adding pages and products my client ask me to make French the default language.

Now, French is the default language but all products in French have locked fields.

How can i unlock them for French and lock fields only for English translations ?

Thanks in advance

May 22, 2019 at 11:53 pm #3869777

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am not sure if I understand the issue.

Do you mean you are not able to edit the products on the product editor? Did you try to decativate WooCommerce Multilingual? Will this solve the issue?

If so, please reactivate WooCommerce Multilingual and go to WooCoommerce -> WooCommerce Multilingual -> Status and click the option "Troubleshooting" at the right bottom corner of the string. Here please run all available sync options.

Does this solve the issue?

Kind regards
Andreas

May 23, 2019 at 8:41 am #3872627

konstantinosP-12

Hello Andreas,

Thank you for your reply.

Yes, I'm not able to edit fields ( Price, inventory etc) in WooCommerce products on the default Language.

Deactivating WooCommerce Multilingual solved the issue.

Activating WooCommerce Multilingual again brings back the issue even if i run all sync task through Troubleshooting.

May 23, 2019 at 12:32 pm #3874991

konstantinosP-12

Is there any solution to my issue ?

May 23, 2019 at 2:43 pm #3877005

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 23, 2019 at 9:33 pm #3879457

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

It is default bahvior of WPML and WooCommerce Multilingual that product that have been created an a specific language will always have to be edited in the same language.
You can verify the orginal language of each product by going to WooCommerce -> WooCommerce Multilingual -> Products.

Each product includes a language flag which refers to the language inwhich the product has been created. If you now click on one of the products the product editor will open automatically choosing the admin language for the repsective product, which you can verify in the top admin bar.

We advise to always use the WooCommerce Multilingual Interface as reference when it comes to translate products.

I hope this answered your question.

Kind regards
Andreas