Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Woocommerce Products (elementor widget) is not translating the proper category to English and therefore displays ALL the content

Solution: Please update both Elementor, Elementor PRO and WPML add-ons to their latest releases.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by shaneB-8 1 year, 11 months ago.

Assigned support staff: Alejandro.

Author Posts
May 8, 2019 at 3:54 pm #3768799

shaneB-8

I am trying to:

With relation to this issue https://wpml.org/forums/topic/wpml-elementor-conditional-exclusions-do-not-work/ which was closed but still not resolved.

The remaining issue on this page is the content that appears. Woocommerce Products is not translating the proper category to English and therefore displays ALL the content. If you look at the French versus the English you will see. The items that are messed up shouldn't be there.

Link to a page where the issue can be seen:

hidden link vs hidden link

I expected to see:

It was reported that this issue is fixed but in my tests I can see that the results are not generated for English results.

May 9, 2019 at 7:06 am #3773563

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

I remember this case. Right now i can only see the content in French, could you try to make a slight edit to your french page and then try to update you English translation? (maybe add a character to the page or anything else that could trigger a WordPress revision)

Once you update the English translation, make sure you re-save it as "translation complete" in the translation editor (i mean, mark that option before you save the translation), that way it will force the resync of the post and show the right categories in the right language.

Let me know how it goes and if you've followed any steps, please mention them in the next reply so i know what you've done so far and i can send it to our developers to see if there's still something missing.

May 9, 2019 at 11:54 am #3775827

shaneB-8

Yep I already attempted that but did it again and no dice. Should I create an account so you can check out things or perhaps you have other suggestions prior. Is there certain settings that will work and others that do not?

I'm filtering by term and then Product Categories: Hebergement

May 9, 2019 at 12:08 pm #3776017

shaneB-8

For what it's worth there was an index issue that I had reported and it was repaired. I don't know if this could have some cause in terms of this not working? https://wpml.org/forums/topic/table-wp_icl_string_pages-doesnt-exist-for-query/

In my apache error logs I get

[Thu May 09 12:06:23.300119 2019] [proxy_fcgi:error] [pid 9044:tid 139892549695232] [client 142.217.250.53:34538] AH01071: Got error 'PHP message: PHP Warning: Illegal offset type in isset or empty in /wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 247\nPHP message: PHP Warning: Illegal offset type in isset or empty in /wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 257\nPHP message: PHP Warning: Illegal offset type in /wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 258\nPHP message: PHP Warning: Illegal offset type in isset or empty in /wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 262\n', referer: hidden link

May 9, 2019 at 3:06 pm #3777595

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Yes, please allow me access to the site so i can take a look at it.

Could you also leave on the next reply, all the steps i'd have to follow to replicate the problem? i think i remember how it was that i did it before but i'd like to make sure i'm doing the same thing you are, just to avoid any confusion in the future.

Thanks in advance.

May 10, 2019 at 3:49 pm #3786305

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hi,

So the first error thrown about WPML was already fixed (i added the patch) but now, the error thrown has to do with your theme, can you check it out and see if that could be related?

Let me know when you do so i can take another look if the problem is not fixed yet, ok?

Regards.

May 13, 2019 at 12:36 pm #3798215

shaneB-8

I don't see an error in my apache logs, where are you seeing this problem. Did you change the error log path or where are you see this?

May 13, 2019 at 2:18 pm #3799311

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Sorry about that, i meant the debug.log file (found in wp-content)

May 13, 2019 at 2:39 pm #3799477

shaneB-8

I'll check with Elementor about the ID issue. IN the meantime, I noticed another issue pertaining to when I switch to English regards WPML:

Illegal offset type in isset or empty in /plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 247

May 14, 2019 at 1:20 pm #3807229

shaneB-8

They are presently looking into that issue I believe, but my main issue really has more to do with the page not displaying the translation. To me this would appear to be related to the error above (perhaps)?

May 15, 2019 at 8:19 am #3813527

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello, i just wanted to update you that i replicated the problem on a clean environment and the problem is still there, indeed. It appears the reason why not even the "source" language's products aren not in your site is because you made an edit in the source language (in this case in french) and then updated the English Translation which erased everything.

It appears the way elementor is handling this, is making it very difficult for WPML to actually pick up the arguments elementor is using so it can then translate them. Our developers are actively working with the Elementor devs to find a fix for this issue.

In the meantime, you can disable the translation Editor on that page only and manually translate the page so your production site works correctly.

I'll update you as soon as the developers get back to me with more information.

May 18, 2019 at 5:49 pm #3839575

shaneB-8

I tried your suggestion but was unable to get that to work. Did you make that work on your test copy? If so could you check my configurations to verify that I have done the right thing?

May 23, 2019 at 12:38 pm #3875057

shaneB-8

Hey Alejandro did you have any luck or could you just post what you did for me to get it working?
THanks for your hard work

May 23, 2019 at 3:54 pm #3877749

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

Sorry for the late reply, It seems the correct fix is still not released but i'm trying to find a workaround for you. I'm making afew tests and will let you know once i find something.

June 12, 2019 at 11:46 am #4003721

shaneB-8

Hey

Sorry to harrass you but it's been a few weeks now and I was wondering if A) a fix has been released or B) you have a solution that might work?