This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by charlieH 6 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
March 28, 2019 at 1:08 pm

charlieH

I am trying to:
Translate all my woocommerce products and their categories.
I used the transslation manager to create translations for the categories and the bulk translator to create duplicates of the products.

Link to a page where the issue can be seen:
hidden link
hidden link

I expected to see:
- The main menu categories to list the polish versions
- Each product to be assigned to its polish counterpart taxonomy
- All the acf values for each product to be copied over.

Instead, I got:
- The product categories are duplicated and translated HOWEVER they are showing 0 in the taxonomy listing page for both english and polish.
hidden link
None of the polish categories have any products assigned to them like the english version.
Using the troubleshooting page to cleanup the taxonomy totals does nothing and using the Synchronise posts taxonomies for products removes ALL links between english terms and their respective products.

- Every product that has been duplicated does not duplicate the advanced custom fields/ meta data and category assignedment across.

Any help is solely needed.
Thank you

March 29, 2019 at 5:52 am #3488003

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Could you please go to WPML-> Support ->Troubleshooting and click the below buttons and let me know if that helps:

+ Set Language information
+ Clear Cache in WPML
+ Fix element types collation
+ Assign translation status to duplicated content

Look forward to your reply.

Thanks

April 4, 2019 at 7:30 am #3532835

charlieH

Unfortunatley this didnt help, the assign translation status returned an error as well:
hidden link

The categories are still showing 0 and the translations are still not linked to the products.
hidden link

April 4, 2019 at 12:06 pm #3534565

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

It seems like a theme/plugin conflict or a PHP error that is blocking some functionalities and creating such issues, so could you please perform the below steps and let me know if that helps?

Minimal Setup

If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?

NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Debugging

1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Look forward to your reply.

Thanks

April 4, 2019 at 2:40 pm
April 5, 2019 at 11:21 am #3543669

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

We recently released new versions of WPML plugins with fixes and improvements so could you please update the plugin to the latest version and let me know if this helps?

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

Look forward to your reply.

Thanks

April 8, 2019 at 7:05 am #3554575

charlieH

Ive updated all wpml plugins on the site, re-ran your list of checks in the troubleshooter and the issue still remains. Are you able to login to the CMS yourself to have a look at the issue as it might be something simple i have missed. You have the cms logins, the site sits behind a password:
impression: impression

Kind regards

April 8, 2019 at 11:23 am #3557117

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

It seems your db collation is different, which is creating the issue, would you mind providing me ftp details too so I can use a php file to check your database?

Also, I would need to do some edits on the database so make sure to keep a backup first.

Enabled the private reply for you.

Thanks

April 8, 2019 at 11:51 am #3557311

charlieH

Can you provide me with an email address as we assign them as collaborators to our website projects through flywheel and in return they have full access to a site.

April 8, 2019 at 11:56 am #3557359

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

You can use my email address: shekhar.b@onthegosystems.com

April 8, 2019 at 12:05 pm #3557461

charlieH

Thanks, now visit this site and signup:
hidden link

You should have received an invite to join the websites collaboration group.
Once you are signed up and the invite accepted you can access the sites DB through the advanced tab. You can get file access by using your credentails as logins with the servers IP address that is listed within the control pannel as the host.

Thank you Shekhar

April 9, 2019 at 5:33 am #3563123

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Since I didn't find a way to use the ftp/sftp on the flywheel dashboard, I am currently downloading the backup, since the backup is large, it will take some time so I will get back to you as soon as I replicate your site on my localhost.

Thanks

April 9, 2019 at 6:58 am #3563323

charlieH

Hi,
Thanks for that, sorry it mustn't have been clear but in my previous message i mentioned you can ftp into the site using your flywheel logins and the sites ip address as the host.
If you download "Flywheel Local" it will download and setup the site for you locally without you having to do it manually. If you are doing it manually download the latest version of wordpress and copy the backup to the wp-content folder as flywheel has there own config/site root structure.

Once again thank you Shekhar!

April 9, 2019 at 9:12 am #3564741

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I tried to download the file but due to large file size the download is crashing, I am not used to this flywheel admin services, so could you please provide me a backup of your wp-content (without uploads) as well as database backup so I can replicate your site on my localhost and perform further debugging.

You can zip these files and upload to google drive later to share it with me.

I think this will be much easier to move this ticket forward.

Look forward to your reply.

Thanks

April 9, 2019 at 2:37 pm #3568183

charlieH

Im sending the site files via wetransfer to your email address, you can download them through the link on that email.
The the database zip is in the root of the files and to configure your environment edit the settings.ini file within the root of the site.
Thank you