This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
April 11, 2019 at 1:12 pm #3588081

pasiS-2

Tell us what you are trying to do?
So I am making two different sites one to Estonia and one to Lithuania. They are basically the same site except that the product selection is different.
First I created the Estonian site. Imported Estonian products and then I imported Russian products. I imported the products from a magento file so I had to import the same file two times the only difference was that I chose a different column for the description. Both languages have the same product names. These will be changed in the future.
I inserted a connector column just like your documentation suggest. However the categories from the magento CSV were imported as ID numbers. So both languages had the same category "names" which were numbers. Once the second import was done everything seems to work just fine. If I pressed the language switcher on a product the language would change. Backend was also working just fine.
Once I translated the categories the products seem to de disconnected. There are products in Estonian Language and in Russian but they are not connected. The manual connecting does not seem to work either.
If I press the the meta info ontop of the product name with the categories in Russian language the site gives me an 404 error.
How can I get the products linked. What is the best option for me.
Estonain site: hidden link is were all the problems are
Lithuanian: hidden link still works. Probably because the categories have not been translated

Also the categories are not working for russian language.

Is there any documentation that you are following?
https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/
Is there a similar example that we can see?
What is the link to your site?
hidden link

P.S I actually already asked this wuestion before, but I had to mark it as solved because that site was live and I could not risk it breaking. I have now set it up on a development url so feel free to do what ever.

April 12, 2019 at 4:33 am #3594921

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

So, the problem is not with importing but once you edit the product category the products associated with the category are removed?

Since you mentioned you have a development site, could you please provide those details so I can check the issue? I have enabled the private reply for you.

Also, to make it easy to debug, please provide a step to step guide to reproduce the problem, with product and product category links and if possible with a screenshot.

Look forward to your reply.

Thanks

April 12, 2019 at 9:20 am #3596989

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The link you provided is password protected, so could you please provide me the password?

Also, I am not exactly sure how to reproduce the issue, are the following steps correct?

- Select a category that has the product assigned
- Edit the category
- The product assigned will be removed?

Look forward to your reply.

Thanks

April 12, 2019 at 12:43 pm #3599019

pasiS-2

The passwod for the front end is: IskuTallinn

Try to open any product in russian languge and you will see the issue. The product does not open ja it isn ot connected. How do we get these products connected and all the Russian content working like it is supposed to.

Once the product card opens, try pressing any of the category links ontop of the product description. The link dont work.

April 15, 2019 at 8:52 am #3611241

pasiS-2

Whats up? Taking quite long to answer. I´m on a bit of a hurry with this site.

April 15, 2019 at 9:02 am #3611325

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Sorry for the late reply, I tested the issue on your site and can see that on the following product page, hidden link

The link to Eesti doesn't work but from the Eesti the link to Russian is shown properly, it seems like a theme/plugin conflict or a PHP error that is blocking some functionalities and creating such issues, so could you please perform the below steps and let me know if that helps?

Minimal Setup

If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?

NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Debugging

1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Further, Could you please go to WPML-> Support ->Troubleshooting and click the below buttons and let me know if that helps:

+ Set Language information
+ Clear Cache in WPML
+ Fix element types collation
+ Assign translation status to duplicated content

Look forward to your reply.

Thanks

April 15, 2019 at 5:06 pm #3615223

pasiS-2

Hello,

I deactivated all plugins that were not needed and disabled the theme. Still the same issue. If I go to a product on the front end and switch to russian the right product comes. If I edit the product from the back end only the estonian version is there. Try loging in and switching the product back and fourth between russian and estonian. You will see the problem. There is some kind of issue with the connector.

I did the wp debug as instructed, but I can not find the debug.log file from the /wp-content/directory. It does not exist there. I have given you ftp access feel free to acces and do what you need to do. The site is not live and I have backed up everything.

April 16, 2019 at 6:40 am #3618491

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can view the products and it's translation correctly on the front-end now:
hidden link

If I edit the product from the back end only the estonian version is there. Try loging in and switching the product back and fourth between russian and estonian. You will see the problem. There is some kind of issue with the connector.

Could you please add a few screenshots showing the issue, I tested it and couldn't get a clue about the issue.

Look forward to your reply.

Thanks

April 16, 2019 at 9:30 am #3620475

pasiS-2

Hello,

Here is an example:
hidden link

First of all why is the url in Estonian and not in Russian?
Why is there no option to change back to Estonian Language?
Why can I not chanage between languages in the backend? If I go to the Estonian version :hidden link and press the flag in the header to change languages I get an empty product card. But If I go to the Russian version and press edit the content is there?

For example this one has some Russian. Why is the url only partially in Russian:

hidden link

I hope you can now see the issue and address it.

April 16, 2019 at 10:04 am #3620829

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

#1

why is the URL in Estonian and not in Russian?

The URL configuration doesn't seems to be completed properly, so there is difference, for example, the product hasn't been translated properly. To fix this please follow the below steps:

- Go to Settings->Permalinks

- On product permalink custom link, use the proper translation for the custom link and select language accordingly, I edited it and made it /toode/%product_cat%/ and set the language to Easti.

- Now go to WooCommerce->WooCommerce Multilingual -> Store URL and translate them

- When you translate make sure you keep the /%product_cat%/ as it is.

- Further, I can see that the slug of Мебель для дома is "kodumoobel" so it's showing mixed there, you can go to Product-Categories edit the category and fix slug accordingly.

#2

Why is there no option to change back to Estonian Language?
Why can I not chanage between languages in the backend?

It looks like slug conflict, as there are two products with similar slug it's creating the issue, for a quick test could you please change the slug of the product adding "test" at the end and let me know if that helps?

Look forward to your reply.

Thanks

April 16, 2019 at 11:05 am #3621301

pasiS-2

Hello, now the product that I linked to you does not work at all for Russian language

hidden link

This still had a Russian version before your modifications. I changed the slug for the Estonian version and it did not fix the issue.

I did all the modifications you recommended.

As a note regarding the url. At the moment the most important thing is to get the site working, but the plan is that we could remove all the extra stuff from the url. So that the url would just be hidden link . Is this even possible with wmpl. The Russian version can ofcourse have something extra at the end

April 16, 2019 at 11:36 am #3621529

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Your current settings for displaying product is "Make 'Products' appear as translated".

In these settings, a product created in default language will be shown as translated in all languages, but if the product is created other than default language it will only be accessible for those languages.

Since the product you linked is created in the second language it's not showing as translated, to make sure it's shown as translated, you will need to translate the product itself.

Available permalinks for WooCommerce is listed here: https://docs.woocommerce.com/document/permalinks/

I am not sure if you can make permalink without the product slug, this depends upon WooCommerce plugins, but afaik, a product slug is needed. You can contact the WooCommere support and ask if it's possible to create permalinks as such as they could have more information here.

Look forward to your reply.

Thanks

April 16, 2019 at 4:20 pm #3624021

pasiS-2

Hello,

Please pay more attention to this thred! As was mentioned in the very first message the products have been imported in two different languages. The reason for this conversation is to get the the product connected properly. If you remember the product:

hidden link

was in both languages on reply #3620475 and after your suggestions it stopped working.

So please don´t tell me that the product needs to be "translated" when both translations were present at #3620475 . The problem was that I could not change back from Russian to Estonian !!!

I asked you if the the url can be only with the product slug. Meaning that it is without category etc and your answer is "I am not sure if you can make permalink without the product slug". That is exactly the opposite of what I asked.....

I have now been messaging you since April 11. Thats for about a week and you and your instructions have just made my website worse.

Please log in to the site and fix the issues or connect me with an operator who can fix this. I can not afford to keep messaging you for another week.

April 17, 2019 at 5:41 am #3627203

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I used the manual connector and connected the two products:

hidden link
hidden link

While connecting make sure to connect it from the default language, so could you please try to connect it again.

Also, I noticed that while connecting the product there is 500 server error on the console, I tried to debug it further but while refreshing the product got connected, so I couldn't debug it further.

Could you please provide a few further links of products that need to be connected so I can debug and find why there is 500 server issue happening on your site?

I am sorry for the product slug issue but from the example URL you provided I thought you wanted to have URL like hidden link which is not possible, it can be hidden link so if you want to remove the category from the URL:

- Go to Settings->Permalinks

- On product permalink, custom link, use product/ and translate it accordingly.

Look forward to your reply.

Thanks

April 17, 2019 at 6:21 am #3627471

pasiS-2

Hello,

Thanks you for the reply. All the products need to be connected. All of them have the same issue. Is there a way to connect them all in bulk? Because the products are connected in some way. Since in reply #3620475 the product would go from estonian to russian but not the other way. You can try on any selected product. There is a russian version of all estonian products. Some russian products dont have the description but there is a product with the same name in the russian catalogue.

The idea is that I could get all the products connected just like it was supposed to go during the importation. A translator will then go onto the site and check threw all the products translate the product names, since now all the names are is estonaian and translate the description to the products which are missing a russian description.

The topic ‘[Closed] Woocommerce products not conneted’ is closed to new replies.