This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Woocommerce Products tags not showing as translated - there are more than 1000 Solution: Set this in wp-config.php:

define( 'WPML_TAXONOMY_TRANSLATION_MAX_TERMS_RESULTS_SET' , 3000);

Just before the "/* That's all, stop editing! Happy publishing. */" line. It resolved the issue for me on the localhost Installation.

Not only that translated tags don't show any more, but I am also able to translate tags directly from WooCommerce multilingual panel. The reason for this seems to be the sheer number of tags (when you see that message that there are over 1000 tags). Adding this constant is an official workaround, but this issue has been escalated to our WooCommerce multilingual developers as well.

0% of people find this useful.

This topic contains 11 replies, has 2 voices.

Last updated by Bruno Kos 3 months, 1 week ago.

Assigned support staff: Bruno Kos.

Author Posts
June 28, 2019 at 9:03 am #4105807

MCL van den

We are using the Woocommerce Multilingual to translate the products tags. All went fine until a few days ago.

When we translate product tags that aren't translated yet and we save them, they show up as translated with a pen icon. But after we refresh they show up as if they aren't translated anymore with a plus sign.

But there is still a translation in the products tags page. But it seems like they aren't linked anymore.

June 28, 2019 at 12:05 pm #4107183

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you tell me if you're able to test this with the following scenario:
- deactivate all the plugins and leave WPML, WPML addons and WooCommerce active only

Let me know if you have trouble testing this in that scenario - I'm simply trying to exclude whether this has something to do with incompatibility with some other plugin, possibly blocking this request or potential caching issue.

Regards,
Bruno Kos

June 28, 2019 at 12:20 pm #4107291

MCL van den

Hi Bruno,

I've tried what you said and it makes no difference.

June 28, 2019 at 1:01 pm #4107535

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can I ask you the following then? In order to debug this issue , can you install Duplicator plugin and create package so that I can try this on my localhost and possibly escalate further to 2nd tier?

https://wpml.org/faq/provide-supporters-copy-site/

Let me know if this is OK with you.

If yes, I will need WordPress admin username and password so I could download those packages. I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/
Please make a full backup of your site before sharing this info!

Regards,
Bruno Kos

July 1, 2019 at 6:05 am #4115705

MCL van den

Hi Bruno,

Did you get the package?

July 1, 2019 at 6:29 am #4115825

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I apologize for not responding earlier - I wasn't working during the weekend. As for the issue, can you tell me the following:
- for which tag (at least one) this isn't working?
- Is the problem that tag is not showing to be translated here?
hidden link
or here:
hidden link

For example, this one:
- restauratie

In the WooCommerce multilingual panel, it does not seem to be translated. However, when I open it on the WooCommerce product tag section, I can in fact see the translation. However, there is something else I have noticed - when trying to deploy Duplicator package on my localhost, I received this:

DATABASE RESULTS
--------------------------------------
**ERROR** Query size limit [length=1048576] [sql=...]
DB VIEWS:	enabled
DB PROCEDURES:	enabled
ERRORS FOUND:	1
DROPPED TABLES:	0
RENAMED TABLES:	0
QUERIES RAN:	557313

I suspect that the issue has something to do with this:
https://stackoverflow.com/questions/8062496/how-to-change-max-allowed-packet-size

So on my localhost installation, I changed this to 512MB, but I am unable to confirm if this has really resolved the issue or not. That's why I need information on one (of few) tags that weren't translated before you created Duplicator package.

Regards,
Bruno Kos

July 1, 2019 at 9:48 am #4117417

MCL van den

It's on the hidden link page that it isn't showing that a tag is translated.

You can test one on the last page called "zelfmoord deuren" what translates into "suicide doors".

July 1, 2019 at 10:50 am #4117901

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Have a look at these images - this is what I see and the results are somewhat inconclusive. The thing I would like to bring to our 2nd tier is the fact that WooCommerce multilingual does not recognize tags being translated, even though WooCommerce Tags show that they are translated and I can in fact access these pages directly.

Unless you think there's something else I should report? Perhaps using tools such as hidden link would help me narrow down the issue and to know exactly the issue you're facing or more specifically, which of these issues should I report.

Regards,
Bruno Kos

July 3, 2019 at 1:56 pm #4137137

MCL van den

Hi Bruno,

You've hit the nail on the head with the first paragraph.

July 4, 2019 at 7:14 am #4140647

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you do this? Set this in wp-config.php:

define( 'WPML_TAXONOMY_TRANSLATION_MAX_TERMS_RESULTS_SET' , 3000);

Just before the "/* That's all, stop editing! Happy publishing. */" line. It resolved the issue for me on the localhost Installation.

Not only that translated tags don't show any more, but I am also able to translate tags directly from WooCommerce multilingual panel. The reason for this seems to be the sheer number of tags (when you see that message that there are over 1000 tags). Adding this constant is an official workaround, but this issue has been escalated to our WooCommerce multilingual developers as well.

Let me know if it works for you.

Regards,
Bruno Kos

July 4, 2019 at 7:43 am #4140851

MCL van den

Hi Bruno,

That seems to work. Thanks.

July 4, 2019 at 8:00 am #4140989

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Great - marking this as resolved!

Regards,
Bruno Kos