This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Rohan Sadanandan 1 month, 3 weeks ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
August 20, 2019 at 12:10 pm #4423377

Job

Tell us what you are trying to do?
We are trying to delete a product using the WooCommerce API, expected behavior is that the translation will also be removed after deleting it via the API (it's also deleting the translation when we try to remove the main product manually.)

Is there any documentation that you are following?
WooCommerce REST API: hidden link

We are aware of the settings in WPML > see screenshot. (it's enabled)
Like to hear from you.
Regards,
Job

August 20, 2019 at 3:04 pm #4424773

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for contacting WPML Support.

As you have already enabled 'When deleting a post, delete translations as well' then the translated post should also get deleted.

If that is not working then, you can try the troubleshooting steps given below:

1. Please take a complete backup(files & database) of your site before proceeding
2. Navigate to WPML > Support > Troubleshooting > Clean up > Click on "Remove ghost entries from the translation tables"

If that is also not working for you, then you probably need to delete the translated product by sending a REST request to delete the specific product.
Please see our documentation about WooCommerce REST API.
https://wpml.org/documentation/related-projects/woocommerce-multilingual/using-wordpress-rest-api-woocommerce-multilingual/

Also, I request you to increase the WP Memory Limit to atleast 128MB which is the minimum requirement for WPML: https://wpml.org/home/minimum-requirements/
Add this code to your wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy publishing. */

Thanks,
Rohan