Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by SergeyR 6 years, 1 month ago.

Assigned support staff: SergeyR.

Author Posts
December 5, 2014 at 12:21 pm #523795

Olli

I have "Use directory for default language" setting on on my site (English is default language). That seems to cause problems Woocommerce REST API.

Querying url

<em><u>hidden link</u></em>

returns only 1 character string "1" as a response.

If I uncheck "Use directory for default language" query below works fine

<em><u>hidden link</u></em>
December 5, 2014 at 12:40 pm #523809

SergeyR
Supporter

Hi Olli,
thanks for using our products

I'll check your isssue and get back to you with results

December 5, 2014 at 12:59 pm #523830

SergeyR
Supporter

Dear Olli,
yes it's seems our bug(

Thanks for found it, I'll add this to our queue and let you know after we fix it.

Thanks for your patience

The topic ‘[Closed] WooCommerce REST API problem if "Use directory for default language" set’ is closed to new replies.