This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Diego Pereira 5 months, 2 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
April 18, 2019 at 10:58 am

salesC-2

I am trying to:When opening the Warranty request for a order in another languages as the default language: products form the order are selected and when submiiting this form (by clicking request warranty button) an errormessage in the default language (english) is shown: No order selected

Link to a page where the issue can be seen: hidden link

I expected to see:the warranty request form in the same language (like Dutch)

Instead, I got:switched back to english default language with message "NO order selected"

In English all is working fine. But in another languages it has errors. Please try it yourself by logging in to the website hidden link with username johndoe and password 123456789

April 18, 2019 at 5:28 pm #3641111

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @salesc-2, welcome to the WPML support Forum!

This seems to be a compatibility issue with the "WooCommerce Warranty Requests" plugin which is not at our comaptible plugins list: https://wpml.org/documentation/plugins-compatibility.

In these cases, these are the procedures:
- Install the plugin in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
- After this, I will check the problem in this new installation and look for a quick solution
- If I can not find a solution, I will forward the problem to our compatibility team
- The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install + Woocommerce + WPML. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the plugin to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the plugin and the related functionality, you don't need to setup a entire website or clone your existing site.

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests.

All the best,
Diego

April 19, 2019 at 12:44 pm #3645779

salesC-2

Hello Diego,

I have setup the test website.

To reproduce the problem:

- Go to the orderhistory for another language as the default (English).
Like Dutch: hidden link

- Click the button "Request Warranty" for an order

- Select the product for the order and click the button "Request Warranty"

- Now you should stay in the Dutch language shop, but the warranty request form in the default English language is shown.
(clicking "Dutch" on the bottom of the screen shows an "No order selected" message.
For my own website this is shown, the default english warranty request form is not shown omn my own website as it is in this test website. Both are wrong: the dutch warranty request form should be shown)

I hope I made it clear to you.

April 22, 2019 at 3:20 pm #3656649

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you. I did some tests and it's possible to translate the strings of the form using the String Translator, however the form page is loaded in the original language.

I forwarded the details to our Themes and Plugins Compatibility Team and they will take a look at the issue and contact the author if needed. Please note that this process may take a while as it depends on how soon the author will reply to our efforts to contact him.

It would be great if you can also contact the author and refer them to our Go Global program so that we can help them make their product compatible with WPML: https://wpml.org/documentation/theme-compatibility/go-global-program/

This may help expedite the process.

Kind regards,
Diego

May 8, 2019 at 7:19 pm #3770457

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

It seems that the issue is solved if we use the "Languages in Directories" mode. Please try the following:
- Go to WPML > Languages > Language URL format
- Select "Different languages in directories" and save
- Go to Settings > Permalinks and re-save the permalink structure

Please let me know if this is a suitable solution.

Kind regards,
Diego