This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 35 replies, has 3 voices.

Last updated by Vincenzo 2 months ago.

Assigned support staff: Vincenzo.

Author Posts
September 23, 2017 at 8:15 am #1380917

davideP-2

Hi, I'm testing a Renewal process with WooCommerce Subscription (with variable subscription).
In order to test the email sent to the costumer I'm using the following procedure:
https://docs.woocommerce.com/document/testing-subscription-renewal-payments/

My issue is very simple: the email sent to the costumer (the renewal process) always displays the default language.

Is it possible to send the email with the same language of the original order?
For example, if the costumer place a variable subscription order in spanish, the review email should be in spanish too.

Thanks for your support.

September 25, 2017 at 9:56 am #1381925

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!
I will take care of your ticket.

To be able to help, I need more information.

1. Can you please tell me if the email has been translated using WPML -> String Translation?

2. Can you please tell me if the email string is registered in the correct language?
- See the flag beside the string in WPML -> String Translation.

3. If the email string is registered in Italian, can you please verify that the "Assume that all texts in PHP strings are in English" option is not enabled in WPML -> Theme and plugins localization?
- Alternatively, you can write the email in English and translate it into Italian.

❌ Before proceeding please make a full website backup! ❌
⌥ You can use a plugin for this.
See: http://wordpress.org/plugins/duplicator/

4. Can you please try enabling the "Translate themes and plugins using WPML's String Translation only (don't load .mo files)" option in WPML -> Theme and plugins localization?

Thank you.

P.S.
If you wish we can speak Italian. Just let me know in your next answer.

September 26, 2017 at 5:54 pm #1384039

davideP-2

Hi Vincenzo, sorry for the delay.

1. yes, but not all the string are available inside "WPML" -> "String Translation"
2. yes, when available
3. it's not enabled

before to procede with the point 4 I just noticed a very strange behaviour.

Inside "Woocommerce" > "Setting" > "Email" each email has a wpml translation link related to title and subject field.

For example "customer-on-hold-order.php" email template has 2 wpml link.
Please give a look to "Costumer-order-on-hold.png" image.
You can see the link "Traduzioni".

My problem is inside the "costumer renewal invoice" email.
In this template there is no link to the title and subject translation.
Please give a look to costumer-renewal-invoice.png

if I search title and the subject string "Urgente: Rinnovo sottoscrizione EFM {order_number} del {order_date}" and "Rinnovo sottoscrizione EFM {order_number}" I do not have any results.

Inside "the costumer renewal invoice" template (costumer-renewal-invoice.png image) I translated the string "An invoice has been created for you to renew your subscription with..." but I'm not able to find the other one "The automatic payment to renew your subscription with %1$s has failed...". I suppose the second one will be available for translation when a automatic payment fail.

If you need to access to the platform I can create a staging platform for you with super admin user and STFP account let me know.

Thanks for your support.

PS: I just updated WPML Multilingual CMS 3.8.2 - WPML String Translation 2.6.2 - WPML Translation Management 2.4.1 to the last version but the problem is still present.

September 26, 2017 at 6:54 pm #1384090

davideP-2

Hi Vincenzo,

I just made the last test you told me (point 4).

Inside my staging environment I selected the option "Translate themes and plugins using WPML's String Translation only (don't load .mo files)" in WPML -> Theme and plugins localization.

I just create a new subscription (with 30 trial days) order in spanish.
I complete the first order.
I manually run the renew (https://docs.woocommerce.com/document/testing-subscription-renewal-payments/).

The result is the same of my first email (new email attached).
The email received by the costumer has italian text only.

My staging environment is ready for new test.

Have a nice day (or night in Italy 😉 )

Regards

September 27, 2017 at 1:01 am #1384289

davideP-2

Hi Vincenzo, same problem inside the "renewal email" (sent to the admin).
The translation link is missing. There is no option to see the translation.
Screenshoot attached.

Regards

September 27, 2017 at 1:03 am #1384291

davideP-2

Same problem on "Subscription Switched" email notification.

Screenshoot attached.

It looks like all the email related to woocommerce subscription has the same issue.

Regards

September 28, 2017 at 3:07 pm #1386434

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

sorry for the delay.

If I understand correctly the attached documentation, a manual administrator confirmation is needed to confirm a renewal, is this correct?

- Visit your site's administration dashboard.
- Go to: Tools > Scheduled Actions.
- In the search box, enter subscription ID.
- Find the row with the hook 'woocommerce_scheduled_subscription_payment' and the status pending.
- Hover over the row and click Run

1. Can you please try the following steps?
- Go to Users -> Your Profile
- Enable the "Set admin language as editing language" option.
- Press the "Update profile" button
- Now select the English language for the backend using the language selector in the top bar.
- Repeat the renewal confirmation or any other procedure that sends an email from the plugin backend.

Can you please tell me in which language do you receive the emails?

2. If you need to translate the WooCommerce Subscription settings, try the following steps:
- Go to the WooCommerce Subscription settings page.
- Make small modifications in the plugin's settings/strings
- Go to WPML -> String Translation and search for those strings

3. Alternatively, try these steps:
- Go to WPML -> Theme and plugins localization
- Search for the WooCommerce Subscription plugin and select it
- Press the "Scan selected plugins for strings"
- Go to WPML -> String Translation and search for the strings

4. You can also try the procedure in this documentation to register and translate the strings:
- https://wpml.org/documentation/getting-started-guide/translating-theme-options/

Please let me know if you need further details.

Thank you

Related documentation:
https://wpml.org/documentation/woocommerce-extensions-compatibility/translating-woocommerce-subscriptions-woocommerce-multilingual/

September 28, 2017 at 3:14 pm #1386444

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

you can also try adding the code in the attached post, inside the "Custom XML Configuration" tab in WPML -> Translation Management.
Once saved, please disable and then re-enable the plugin to make sure that the config file is loaded.
https://wpml.org/forums/topic/woocommerce-subscriptions-emails-cant-be-translated/page/2/#post-1350452

Please let me know if this solves the issue or if you need further details.

Thank you

September 28, 2017 at 5:17 pm #1386562

davideP-2

Hi Vincenzo,

I just tested point number one suggestion.
The results depend on which email I'm talking about.

I tested 2 subscription (first one with trial days, the second one without trial days).

All my tests are available inside my staging website.
Inside this ticket there are super admin account and SFTP details available for your internal tests:
https://wpml.org/forums/topic/variable-subscription-with-free-trial-doesnt-render-the-gateway-with-wpml/

With WPML enabled and variable subscription product with trial days there is a issue with the gateway inside the first checkout. Please read the other ticket for the details.

Coming back to this issue.

I just made this test:

- Go to page /wp-admin/profile.php
- Select the option "Set admin language as editing language"
- Select the "English" language for the backend using the language selector in the top bar
- Go to the "Tools" > "scheduled action"

- Run the subscription 8053 (no trial days)
- The sandbox transaction is completed
- The costumer receive an email confirmation in english (8053-email-confirm-payment.png attached)
- Searching the text "Your subscription renewal order has been received and is now being processed. Your order details are shown below for your reference" is available and translated inside "WPML" > "String translation" (please check "string-a-translation.png" attached)
- Searching the text "Thank you for your order" is available and translated inside "WPML" > "String translation" (please check "string-b-translation.png" attached)

- Run the subscription 8042 (with trial days) "Tools" > "scheduled action"
- The sandbox transaction is require a manual payment for the user (check the other ticket link for details)
- The costumer receive an email confirmation in italian (8042-email-payment.png attached)
- Searching the text "Rinnovo sottoscrizione" (the title) is not available inside "WPML" > "String translation" (please check "string-c-translation.png" attached)
- Searching the text "Un ordine di rinnovo è stato creato per te relativo al tuo servizio" is not available inside "WPML" > "String translation" (please check "string-d-translation.png" attached)

Maybe you should make some test inside the staging platform.

Right now I'm going to test your message number #1386444

I'll give you a response as soon as possible.

Thank you so much for your support.

Regards

September 28, 2017 at 5:40 pm #1386598

davideP-2

Hi Vincenzo,

I just tested the "Custom XML Configuration" you sent to me in your previous message.
After update this configuration I check all the email available inside Woocommerce.

/wp-admin/admin.php?page=wc-settings&tab=email

All the email related to woocommerce subscription does not have the translation link so I don't think the problem is solved.

This email have the translation link available (please see the image attached woocommerce-mail-notification-list-error.png to see the difference):
- New Order
- Cancelled order
- Failed order
- Order on hold
- Processing order
- Completed order
- Refounded order
- Costumer invoice
- Costumer note
- Reset password
- New account

This email does not have the translation link available (please see the image attached woocommerce-mail-notification-list-error.png to see the difference):
- New Renewal Order
- Subscription Switched
- Processing Renewal order
- Completed Renewal Order
- Subscription Switch Complete
- Customer Renewal Invoice
- Cancelled Subscription
- Expired Subscription
- Suspended Subscription
- Customer Payment Retry
- Payment Retry

I disabled and enable again all the WPML plugins to reload the config.

Thanks for your support

September 28, 2017 at 5:47 pm #1386604

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

the XML code in the "Custom XML Configuration" is used to register the email strings.

Can you please try to search for the email strings in WPML -> String Translation?
- It may be needed to do some small edit to the original email strings to register them.

The reason why you can't see the translation link for some emails is that the translation link is available only for the standard WooCommerce emails.

Let me know the results of your tests.

Thank you

September 28, 2017 at 7:17 pm #1386660

davideP-2

Hi Vincenzo, thanks for you message.

I just made new tests about this issue.

Here my last test
- Select the "English" language for the backend using the language selector in the top bar
- Enter inside the WC Email Setting page /wp-admin/admin.php?page=wc-settings&tab=email
- Select "Customer Renewal Invoice" email
- Make some changes inside Subject and Email Heading (costumer-renewal-invoice-setting-updated.png attached)
- Save the configuration
- Go to scheduled action
- Run the scheduled action id 8058 in order to generate all the strings to translate
- The email received by the costumer is in english (everything)
- From the order admin*** I change the order status to processed and then to completed.
- The email processing order now is complete in english
- The email completed order now is complete in english

I make another test, switching the admin language to Spanish from the WPML switch button on the topbar.

- Select the "Spanish" language for the backend using the language selector in the top bar
- Go to scheduled action
- Run the scheduled action id 8058 again to process the next renewal
- The email received by the costumer is in spanish except subject and title heading (Customer Renewal Invoice-in-spanish.png attached)
- Searching title and subject in String translation are not available (string-translation-failed.png attached). Looking for "Customer Renewal Invoice" string I should get 3 strings but I got only one.
- It look like title and subject are not registered
- I only test this email, check all the email required a lot of time of work to complete all the process.

By the way the main email subscription concept is wrong.
The email sent from the admin seems (after my test) follow the admin language and not the costumer language order.

If a costumer place a subscription order in english should be receive all the notification in english.
If a costumer place a subscription order in spanish should be receive notification in spanish
and so on...

This behaviour should be required for any multilanguage subscription service.
I don't think this version WPML is ready for Woocommerce Subscription multilanguage right now...
But I'm really hope to say something wrong because I spent a lot of time with it and woocommerce.

I'm working over WPML - woocoommerce subscription problems over 5 weeks... and I'm not able to create a stable solution yet.

Let me know if you could give a look inside the staging platform.
Maybe you can find out the problem.

Kind regards

*** I don't know why but the woocommerce order page is *always* in italian, there is no option to change language inside this WC Admin page on the topbar. So when I click every link from this page the next page in the italian lang and I have to switch to english manually clicking on the top bar link (wc-order-page-always-italian.png attached). In order to see the WC order page in english I have to attach &lang=en&admin_bar=1 to the URL

September 28, 2017 at 7:25 pm #1386668

davideP-2

Hi Vincenzo,
I just saw we can use google hangout too for support tickets.
if you want to talk to me (in italian of course maybe we can find out a solution).
I'm not in Italy right now so I need some time to organize the call because my timezone is different. Let me know.

Hava a nice day (well night right now in Italy)

September 29, 2017 at 2:40 pm #1387395

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Davide,

this seems like a compatibility issue with the plugin.

1. I have just some questions to better understand your requirements and to prepare the Compatibility request.

I can see that you are manually confirming the subscription renewal from the backend.
- Is this the normal procedure you will use or it is just for testing purpose?
- Did you try a "normal" subscription renewal made by a client? What is the result?

2. About the Spanish strings issue, I would like to request temporary access (wp-admin and FTP) to your staging site to take a better look at the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

If you don't see the form below, please don't add your credentials as they will be publicly exposed:
- hidden link

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

*Important: Be sure to backup your site and database first before you proceed!

✙ I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site.
This is also a reason the backup is really important.

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you

September 29, 2017 at 3:07 pm #1387421

davideP-2

I just made the backup.
By the way this area is my staging env, so I can rebuild the entire installation in 2 minutes using WpEngine tool.

Do not warry about that.

Regards