This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Dennis 2 months, 3 weeks ago.

Assigned support staff: Dennis.

Author Posts
July 18, 2019 at 5:06 pm

rubenM-27

I use the plugin "WooCommerce Sendinblue newsletter subscription" in order to have an newsletter opt-in checkbox on the WooCommerce checkout page.

I'm trying to make this checkbox language-wise, i.e. adapt the checkbox label and set the right subscription list. For this purpose, I created two custom fields in the xml config file :

<key name="wc_sendinblue_settings">
<key name="ws_sendinblue_list"/>
<key name="ws_opt_field_label"/>
</key>

I can access the fields and provide a translation/a list index in the String Translation module. However, the label won't be translated in the frontend and the user keeps being subscribed to the same list, regardless of the selected language.

July 19, 2019 at 6:35 am #4244203

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Could you please try to update all WPML plugins to latest versions and check if it resolves the issue?

You can update WPML plugins at Plugins > Add new > Commercial tab.

Note: Please backup your site completely before updating WPML.

Also, I would like to recommend you to increase your max input vars, currently it has a value of 1000 in your WordPress Dashboard > WPML > Support section.

Please, try to increase it to 5000. You might need some assistance from your host to properly set this up.

See:
hidden link
hidden link

Then:

-go to WPML > String Translation
-try to search for the strings again in WPML > String Translation and translate them completely.

Kind regards,
Dennis

July 19, 2019 at 6:53 am #4244275

rubenM-27

Hi Dennis, thank you for your reply.

I tried what you said :
- Updating all WPML plugins
- Increase max_input_vars to 5000
- Translate the fields again

with no success.

July 19, 2019 at 9:09 am #4245123

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your updates.

Can you check if the issue persists if you disable all non-related WPML plugins, switch to one of the default themes like twenty sixteen?

NOTE:
+ Make a backup (both files and database) for your site before doing this test.

Please let me know your results.

I tried to access your site but for some reason, the credentials does not work on end. Could you please check? I will enable the access information box for you and make your next reply as private.

Kind regards,
Dennis

July 19, 2019 at 9:38 am
July 22, 2019 at 4:47 am #4253967

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

Please let me know of your results if you put your site on a minimal environment.

If the issue still persists, I would like to request your permission to install Duplicator plugin, build a package and download a copy so I can continue debugging locally and without affecting your site.

Thank you.

Kind regards,
Dennis

The topic ‘[Closed] WooCommerce Sendinblue – Translated custom fields not updating’ is closed to new replies.