This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.13 hours from now. Thank you for your understanding.

This topic contains 7 replies, has 3 voices.

Last updated by Andreas W. 2 days, 3 hours ago.

Assigned support staff: Andreas W..

Author Posts
November 7, 2019 at 10:39 am #4904913

Angelos

What are you trying to translate?
Woocommerce Settings Payments

What are you seeing? (please include a screenshot)

What's missing or not working for you?

So i am trying to translate woocommerce settings payment descriptions but for some reason i write the description i want i translate it via String Translaton but on my page it does not translate. The same happends with Woocommerce Settings Emails

November 8, 2019 at 2:36 pm #4914135

SergeyR
Supporter

Hello Angelos,
Thanks for contacting us!

If you want use not default values which we automatically translating to all languages then you need go to WC->Payments->Payment method setting page and enter your custom string. After this please save settings ( it's important to save settings first ) and use links to translations and there you need to select correct string language ( if you're entering in not site default language ) and translate to other languages using String Translations module.

November 9, 2019 at 12:57 pm #4918141

Angelos

So i did add my custom string i saved but when i press the translation link the string doesnt show up !

November 10, 2019 at 4:19 pm #4921027

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

As I see on your screenshots it seems to look good on String Translation, but there is an issue on the WC Settings for Payments.

As far I can see here you edited a English text message and assigned it to Greek language. inside of the WC Options. Please change the language here accordingly.

In case this did not solve the issue please provide access in order for me to have a look at the site.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

November 11, 2019 at 3:52 pm #4926405

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

The provided site credentials are not valid. Please verify and provide access again in order for me to troubleshoot the issue.

Kind regards
Andreas

November 12, 2019 at 9:30 pm #4934947

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

As far as I can see this seems to be a theme issue.

Strings, which are edited in theme or plugin options can be added to String Translation using the option "translate text in admin screens", which can be found at the bottom of the String Translation screen.
I added the strings again and translated them, but they are not showing up on Front-End, even when all additional plugins are disabled.

The issue does not occur on a new install.

I can offer you to have a more detailed look at the theme but please take note that our support policy does not include any custom code solutions, as your theme is a custom theme.

Please install the theme on the following test-site:

One-Click Login: hidden link

Leave me a short notification once the theme has been installed.

Kind regards
Andreas

November 14, 2019 at 6:45 am #4944239

Angelos

Hello Can i have the FTP Logins too??

November 14, 2019 at 9:20 pm #4950199

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Please log into the test-site and go on the Dashboard to WP-Sandbox.

Here you will find the credentials in order to connect to the server.

Kind regards
Andreas