Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Select English as language ->Add a product to the cart from the category sculptures-> select the shipping country Germany and you will read zero shipping cost

Do exactly the same procedure by selecting the french or german language and you will read a cost added as shipping cost

Solution: Our 2nd tier specialists solved the issue by following these steps: - Go to Woocommerce > Settings > Shipping > Europe (edit) - Switch the language to german or french - Scroll down to Shipping methods > Shipping then click on edit - Set the "Sculptures and others" shipping class cost as 0.0 (see screenshot) - Save

Relevant Documentation:

0% of people find this useful.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 3 voices.

Last updated by Carlos Rojas 4 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
March 10, 2020 at 7:43 pm #5657431

anitaK-2

Dear Support,

I am contacting you following a ticket that I opened and closed few weeks ago. The title was: Woocommerce shipping classes not working with WPML 4.3.6.

I realized that the issue was only partially solved.

Summary: when I contacted you the first time I could not properly save the shipping classes and wrong shipping classes were used for the translated website. The first part of the request was properly solved by adding some code.
However, I have noticed that when I add a product to the cart and I am not in the main website language, therefore one of the translated languages for example french or german, the wrong shipping cost is added to the cart.

To reproduce the problem:

Select English as language ->Add a product to the cart from the category sculptures-> select the shipping country Germany and you will read zero shipping cost

Do exactly the same procedure by selecting the french or german language and you will read a cost added as shipping cost

Could you please help me to solve the issue?

Thanks.

March 11, 2020 at 7:48 pm #5666431

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Can you please confirm that this is the ticket that you are referring too?
https://wpml.org/forums/topic/woocommerce-shipping-classes-not-working-with-wpml-4-3-6/

March 11, 2020 at 7:53 pm #5666465

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi again.

By looking at the debug info I can see that WPML and its add-ons including WooCommerce Multilingual are not updated on your site. We have recently released a fix for the issue that you had with the latest versions. Please update everything including WooCommerce and check if the problem persists.

Thanks,
Itamar.

March 11, 2020 at 9:50 pm #5666865

anitaK-2

Dear Itamar,

Thank you for your reply. I have just updated the WPML to the latest version and the problem persists.
I have not updated Woocommerce because it is a major upadate the 4.0 and I do not believe that has any influence on WPML problem that I raised. The problem was already present before Woocommerce was released to 4.0 and already present in the previous version of WPML.
Could you please help me to understand the reason and solve it?

P.S. I confirm that the post that you reported is the correct one

Thanks.

March 12, 2020 at 12:12 pm #5672395

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello,
My name is Carlos and I will be taking this ticket from now long.

I was able to reproduce the issue on the site and I would like to ask you to follow these steps:
- Create a full backup of the site.
- Update all WPML plugins to the latest version in Plugins -> Add new -> Commercial tab.
- Go to Woocommerce -> Woocommerce Multilingual -> Make sure all categories and shipping classes are translated -> Go to Settings tab -> Troubleshooting link (bottom right) -> Select all options and click on the 'Start' button to sync all products.
- Flush any cache memory that might exists.

Could you tell me if the issue persists?

Regards,
Carlos

March 12, 2020 at 9:58 pm #5675917

anitaK-2

Dear Carlos,

Thank you for your reply.

I have implemented and followed all the requested steps however, the problem is still present.

Do you have other suggestions?

Thanks.

March 13, 2020 at 12:02 pm #5679859

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,
Thank you for your message.

1.- I can't see any shipping cost in any of the languages. Could you provide a screencast (video) where the issue can be seeing?

2.- I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to back-up the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

March 16, 2020 at 12:35 pm #5693283

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,
Thank you very much for the information provided.

I was able to reproduce the issue on the site. I would like to ask your authorization to run tests (activate/deactivate functionalities) in order to isolate the cause of the issue.

Regards,
Carlos

March 16, 2020 at 9:41 pm #5696633

anitaK-2

Dear Carlos,

Yes you can perform the tests on the staging site that I have provided you.

Please let me know the results.

Best regards.

March 17, 2020 at 1:51 pm #5701993

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,
Thank you very much for your authorization.

I'm running several tests on the staging site. I will get back to you as soon as I have an answer.

Regards,
Carlos

March 17, 2020 at 6:44 pm #5704337

anitaK-2

Dear Carlos,

Thank you, looking forward for your results.

Could you please confirm that you will not save any copy of the website locally and all the data will not be shared with any third party?

Thank you in advance for your understanding.

March 18, 2020 at 1:51 am #5705969

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

I can confirm that no information will be disclosed to third parties and that I won't save any copy of the site.

You can read more about our privacy and security policies in this link: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Regards,
Carlos

March 18, 2020 at 2:50 pm #5712237

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

After running several tests on the staging site I decided to escalate this ticket to our 2nd tier of support. Please don't delete the staging site because I wasn't able to create a copy so our 2nd tier specialists will be working directly on the staging site to try to solve the issue.

I will keep you updated on the evolution of this ticket.

Thank you very much for your understanding.
Regards,
Carlos

March 19, 2020 at 4:15 pm #5721545

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

Our 2nd tier specialists solved the issue by following these steps:
- Go to Woocommerce > Settings > Shipping > Europe (edit)
- Switch the language to german or french
- Scroll down to Shipping methods > Shipping then click on edit
- Set the "Sculptures and others" shipping class cost as 0.0 (see screenshot)
- Save

See the attached image.

Could you tell me if the issue disappeared?

Best regards,
Carlos

March 21, 2020 at 4:08 pm #5733625

anitaK-2

Dear Carlos,

I followed the instruction however, they do not solve the problem.

You adviced to put the shipping class of sculptures at zero (after switching the language) however, as you can also see in your screenshot, they are already at zero. So, what is the change that I should implement?
I tried to re-save the menu although the sculpture shipping class is at zero already but there are no effects.

The instructions appear to not have any effect.

Did you try the instructions on the staging site? did they work on your side?

Thanks for your help.