No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 1 reply, has 2 voices.

Last updated by Andrés 3 weeks, 3 days ago.

Assigned support staff: Andrés.

Author Posts
September 19, 2019 at 3:13 pm #4606801

Valérie Hébert-Gentile

Hi,
I created a page in french, then duplicated and translated it in english. (so I have a french and an english version of the same page).
The french version slug is "services-calinotherapie" and
the english version slug is "cuddletherapy-services".
I want that page to be my woocommerce shop page.
So I go in woocommerce settings, in the products tabs and for the shop page, I select "cuddletherapy-services" (because I only see the english versions of my pages anyway)
and for the product permalink I use the personnalized version with /cuddletherapy-services/ set as the english language, and in the woocommerce multilingual I make sure that the shop page slug is "services-calinotherapie" in french.
...
It used to work well: I could switch from my french to my english shop page and vice versa. I could see all my french products (each on their page, but with the "services-calinotherapie" slug) and I could see all my english products (each on their page, but with the "cuddletherapy-services" slug).
(I have different products in french than in english; I mean, they're not translations of each other, they really are completely different from one language to another).

But now, it's not working anymore!
Well, my english version of the shop page works, and my english products are showing up each on their page with the "cuddletherapy-services" slug.
BUT the french version of the shop page is NOT SHOWING ANYMORE, AND the french products are with the "cuddletherapy-services" (english) slug too!

And if I go back in woocommerce settings, products tab and switch for the french version of my shop page (if I've been working on french pages before, when I get there, I see the french versions of my pages, but again only the french version)... well then it's the english version that doesn't work anymore!
and if I change the product permalink for /services-calinotherapie/, even though I make sure, in woocommerce multilingual that the shop page slug is well translated in english "cuddletherapy-services", then all my products are showing the "services-calinotherapie" slug (the english ones too!!)!

my website: hidden link
French shop page:
hidden link
French product:
(the address that should be:)
hidden link
(the address that actually is:)
hidden link (see the english there, that's bad)
English shop page:
hidden link
English product:
hidden link

...please fix this!

thank you

P.S. I tried to do it all again with a new page created from scratch, that I translated and then set as my new shop page... and I got the same problem!

September 20, 2019 at 5:33 am #4609811

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

Welcome to WPML support forum.

This forum is intended for how to questions. It seems that the issue that you are experiencing is beyond that and it is more a technical problem, maybe a compatibility issue. Also, please keep in mind that WooCommerce Multilingual is intended to work as only one boutique for all the languages.
https://wpml.org/documentation/support/accounts-for-wpml-end-users/

However, we committed with the site developer that this forum is only for that and we won't mess his development. So, for this kind of questions, you should ask your developer (license owner) to open a ticket in the technical forum, we can help you better there.

Best regards,
Andrés