This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Raja Mohammed 3 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 11, 2019 at 11:27 am

matteoP-15

I am trying to: Translate woocommerce product, attribute, and variation.

Link to a page where the issue can be seen: In all product's page. for example that one:
hidden link

I expected to see:
the english product's page

Instead, I got:
404page (error)

July 11, 2019 at 1:06 pm #4189999

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue.

I have noticed that the product base slug is set to prodotto however the language is set as English. Which might be the cause of the issue.

Please secure a backup of your site and database

- Goto Settings > Permalinks > Product permalinks
In the custom bases section change the language to "Italian"

- Click on translate make sure the English slug is translated to "product"

- Save the permalinks

- Clear cache, check if the issue persists

I hope this helps in resolving the issue, Let me know if you need further assistance.

Kind regards
Raja