This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: My variable products appear as out of stuck only when WPML is active.

Solution: This usually happens when Multicurrency is active and the problem is that in WooCommerce > WooCommerce Multilingual > Multicurrency you have "Show only products with custom prices in secondary currencies" enabled while you have the following option enabled in each of your variations: "Calculate prices in other currencies automatically", i suggest that you read the tooltip on the multicurrency option and disable it so it works again.

Tagged: 

This topic contains 9 replies, has 4 voices.

Last updated by Giacomo 6 months, 2 weeks ago.

Assigned support staff: Alejandro.

Author Posts
March 26, 2019 at 3:57 am

joonkyul

I am trying to: I made woocommerce variable product. But Its detail page shows "out of stock". I set all option's inventory and quantity. It's plugin problem. When I deactivate plugin 'WPML Translation Management', It show options. please solve this problem. It's urgent.

Link to a page where the issue can be seen:hidden link

I expected to see:

Instead, I got:

March 26, 2019 at 3:59 am #3459103

joonkyul

I didn't receive any answer.

March 26, 2019 at 4:17 am #3459119

joonkyul

One more problem.
And even my theme "flatsome" admin menu is not working when I activate wpml.

March 26, 2019 at 12:29 pm #3462261

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

HI there,

Welcome to our forum,

I would like to ask you to follow these steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons. please don't ignore
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Sync products

Let me know the results

Kind regards
Raja

March 26, 2019 at 6:14 pm #3465451

joonkyul

I've done. what you asked. But still have two problems below.

1.

I made woocommerce variable product. But Its detail page shows "out of stock". I set all option's inventory and quantity. It's plugin problem. When I deactivate plugin 'WPML Translation Management', It show options. please solve this problem. It's urgent.
hidden link

2.

One more problem.
And even my theme "flatsome" admin menu is not working when I activate wpml.

March 27, 2019 at 6:07 am #3467723

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there

The stock issue is due to recent changes in the code,

However, we have identified a workaround,

Goto WPML > Settings > Custom fields translation enable show systems fields and search for _stock and set the field to Copy.

I would now request you to update your product original content you don't have to add or change anything just click the update button on the product edit page,
You will see the secondary translation needs an update click on the second language and update the translation, again you don't need to do any changes here.

This process will make sure the stocks are copied and set to sync with the original. I hope this solves your stock issue.

Please remember to secure a backup of your site and database

let me know the results.

kind regards
Raja

March 28, 2019 at 8:20 am #3478057

joonkyul

I've done. what you asked. But still doesn't work...

1.

I made woocommerce variable product. But Its detail page shows "out of stock". I set all option's inventory and quantity. It's plugin problem. When I deactivate plugin 'WPML Translation Management', It show options. please solve this problem. It's urgent.
hidden link

March 29, 2019 at 4:33 pm #3492981

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, my name is Alejandro,

Since Raja is currently not available, I will replace him here in the forum.

I hope this is OK with you.

The problem was in your multicurrency configuration (in WooCommerce > WooCommerce Multilingual > Multicurrency), you just had to disable "Show only products with custom prices in secondary currencies" (if you read the tooltip next to the option it will tell you that it will hide the products if you set the option you set in the product variations, which is: "Calculate prices in other currencies automatically")

I already did this for you, so you don't have to worry about it anymore.

Regards.

March 30, 2019 at 5:14 am #3497271

joonkyul

My issue is resolved now. Thank you!

May 15, 2019 at 8:35 pm #3820085

Giacomo

I had the same problem with variable products even if the Multicurrency was not enabled; I had to enabled it (but leaving just one currency) and then the problem is partially solved: the backoffice is still showing that the product is out of stock (even if the stock is showing it is not just after that), but at least now it's buyable on the front-end.