This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Raja Mohammed 5 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 27, 2019 at 7:21 am

nhung-thi-thaoP

Hi,
Besides categories and tags I also have location as a variation to products. But I can not translate this and also not translate/change the taxonomy. It is added from one of the Multilingual Ready Plugins called WooTour.
How can I add this to WPML?

April 29, 2019 at 7:48 am #3700733

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I have checked your site, the custom taxonomy location should be set to "Translate" . Please go to WPML > Settings > Taxonomy translation change the option for "Location (wt_location)
" to "Translatable - only show translated items". this will make your location attributes translatable. You can then translate the taxonomy from "WPML > Taxonomy Translation.

Please let me know if this helps

Kind regards
Raja

April 29, 2019 at 8:11 am #3700883

nhung-thi-thaoP

Hi,
Thank you for your reply.
Can you check my screenshot. I don't see it in the list.

April 29, 2019 at 10:20 am #3702041

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I have enabled the settings for you, The location taxonomy is now available for translation under WooCommerce > WooCommerce Multilingual > Custom Taxonomies ( screenshot attached ).

I hope this solves your issue.

Kind regards
Raja

April 30, 2019 at 1:46 am #3707165

nhung-thi-thaoP

Hi,
Thanks!!
Almost everything is working! But I can not chance the slug. I want to change it for both Dutch and the default of English, because wt_location is a bit weird. But it stays on wt_location when I click save. In settings -> permalinks I don't see location, so I can not change the permalink there. I have a similar problem when I want to translate the Strings. Nothing chances. If this has nothing to do with each other I will make a different ticket for the strings problem.

May 2, 2019 at 2:30 am #3720799

nhung-thi-thaoP

Can you please help me with this problem?

May 2, 2019 at 5:06 am #3721725

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Kindly apologize, Somehow this thread got missed out.

I can see the default slug can be changed from WooTours > General settings.
Try to change the default language of Location taxonomy to English from WPML > Taxonomy Translation, Select the Location taxonomy. You will have the option to change the slug language to English. Please check the attached screenshot.

Please let me know the results

Kind regards
Raja

May 2, 2019 at 1:22 pm #3724825

nhung-thi-thaoP

No problem.

"I can see the default slug can be changed from WooTours > General settings." = I already did and it does not work.

"Try to change the default language of Location taxonomy to English from WPML > Taxonomy Translation, Select the Location taxonomy." = I already did and does not work, for both Dutch as English is stays on wt_location.

May 2, 2019 at 1:45 pm #3725001

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Honestly, I don't see any other option to update the slugs.

I have created a sandbox test site for you hidden link

Please upload the plugin and try to reproduce the issue in the sandbox test site.

WPML plugin is already installed and activated in the test site,

please Let me know once it is done.

Kind regards
Raja

May 9, 2019 at 12:54 pm #3776243

nhung-thi-thaoP

Sorry, for very late answer, but had some very important things I had to deal with.
I installed the WooTours plugin. So right now in Taxonomy I can not select The "Location".

May 10, 2019 at 7:38 am #3782019

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi

Thanks for the uploading the plugin, The taxonomy was set to not translation which I have fixed now. I can now see the taxonomy in Taxonomy translation. However, the Base slug can only be changed either from the permalinks section or the from the plugin settings section, I don't find the option in both places. However this is not related to WPML, Can you please check with the plugin author how to change the default 'location' slug to your custom slug name.

Kind regards
Raja