This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 32 replies, has 5 voices.

Last updated by Mihai 5 years, 12 months ago.

Assigned support staff: Mihai.

Author Posts
September 24, 2013 at 6:54 am #267988

Régis

Hi,
my problem is the following one.
I've created a lots of products with color attributes in french.
These products have variations based on colors and images (featured and gallerie).

I need to translate this product catalog in dutch.
I've duplicate all my products and everything seemed OK to me (products in NL, duplicated images, galleries, variations...)
Unfortunately, something is wrong because even if my variations are also duplicated, they are not assigned to the translated color...
As you can see on my screenshot, attributes values are duplicated since we can see values in the attributes panel.
In the variation panel, variations are also duplicated, main color is filled, but the color assigned to variation is lost.

When I manually pick a color in the select field and save my product, these values are never updated and these fields stay empty.

On the front-end, the product page then is broken since the user cannot switch between variations (Empty select box : Choose an option...)

Any about what I'm doing wrong? I've I missed something somewhere? At least can you explain why colors links are not saved when I do it manually?

Thanks.

September 24, 2013 at 7:22 am #268004

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Régis,

Not too long ago we added improvements for attributes and variations into our "Woocommerce-Multilingual" plugin. Could you check if you are running these versions:

> WPML 2.9.2
> String Translation 1.8.2
> Translation Management 1.7.2
> WPML Media 1.6
> Woocommerce 2.0.14
> Woocommerce 2.3.2

September 24, 2013 at 10:57 am #268194

Régis

Hello, Andreas,
Here are my versions :
> WPML 2.8.1
> String Translation 1.7
> Translation Management 1.6
> WPML Media 1.4
> WooCommerce 2.0.9
> WooCommerce multilingual 2.3.2

I know some of these are not the latest versions but my website cannot be updated easaly as it is in production now. Can you at least tell me which one of these plugins was the problem?

Thanks

September 24, 2013 at 12:46 pm #268283

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Régis,

Thanks for the feedback!

# Actually your WPML plugins versions are not the latest. Since lots of improvements were made I would recommend to update them in any case.

To keep track easier with our different plugin versions, I can recommend using our "Installer" plugin, available here: hidden link
(Since WPML is a commercial plugin its not listed in the WP.org repository and no update notifications are sent the usual way. The "Installer" plugin hooks into many more repositories.)

Once you have installed this "Installer" plugin, please go to "Settings > Repositories", login into WPML.org and then under "Plugins" you should see which WPML versions are in need of updating.

# Woocommerce-Multilingual
Version 2.3.2 is the one recommended in our docu. But I've got a notification today from our developement department that a (highly improved) new beta version is just around the corner.
Release date: September 25 or 26
I think it would be worth waiting for it.

September 25, 2013 at 9:12 am #268652

Régis

Hello,
I've installed Installer but I can't see auto update notice for WPML Media (I'm in 1.4)
I've updated others and I'm going to test if it's better.

September 25, 2013 at 10:07 am #268706

Régis

So,
I've updated all my plugins.

Here are my versions now:
> WPML 2.9.2
> String Translation 1.8.2
> Translation Management 1.7.2
> WPML Media 1.6
> WooCommerce 2.0.14
> WooCommerce multilingual 2.3.2

Unfortunately, my problem isn't solved and i'll need a quick solution or a workaround since my client needs its website for next week...

How can I force variations to link the correct color?

Note: you can see on my screenshot that the color is automatically selected for the main color. So there must be a problem with variation/color management...

Thanks in advance for your feedback, it's really important for us to solve this problem and telling our client we're waiting for a eventual "beta" version is really not a thing we can do.

September 25, 2013 at 12:03 pm #268760

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Régis,

Thanks for the feedback, all up-to-date.
I think we should wait for the new Woocommerce-Multilingual plugin - also because the handling of things is a bit different in the new version.

September 25, 2013 at 1:01 pm #268800

Régis

Hmm,
can you at least tell me when this update will be available?
I'm a bit confused here since we've chosen to use WPML and WooCommerce because your website says these solutions are fully compatible and "make possible to run fully multilingual e-commerce sites"...
Obviously there is an issue with variations management, attributes translation and/or duplication process...
So please, let me know:

1. when will the update be available?

2. Is your development team aware of this specific problem? I think they have an up-to-date bug tracker and are able to tell you if this issue will be fixed in the new beta version. I cannot wait for this update to see that in a few days the problem is still here...

Thanks in advance.

September 26, 2013 at 6:09 am #269096

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Régis,

As mentioned here http://wpml.org/forums/topic/woocommerce-variationattributes-link-is-lost-after-duplication/#post-268283 - officially release data is September 25 or 26.

But we have meanwhile also a new beta version. Available here: http://wpml.org/my-account/downloads/ all the way down - could you try it out?
If we notice that it really doesn't improve things I will refer you to our Woocommerce developer to provide a fix.

September 27, 2013 at 8:25 am #269649

Régis

Hello,
I've tested your beta version. My bug seems to be fixed even if there are some features which are still pretty unstable. So I'll wait for the official release and let you know if it's better.

September 27, 2013 at 12:22 pm #269801

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Régis,

Glad to hear 🙂
The official release shouldn't take too long anymore - seems that QA testing takes a bit longer than expected.

September 27, 2013 at 2:45 pm #269896

Régis

Andreas,
if the beta version fix my original issue, it also creates new issues.
Categories are not well translated when I duplicate items.

My product catalog is like that:

1 - Men (men)
1.1 - Shoes (men-shoes)
2 - Women (women)
2.1 - Shoes (women-shoes)

For example, when I duplicate a product from the men-shoes category from french to dutch, the duplicated dutch product is not linked to the exact category translation (men-shoes-nl) but to the women-shoes-nl one

I've check and category translation are good :

men-shoes<>men-shoes-nl
women-shoes<>women-shoes-nl

Maybe thats because somewhere your code doesn't compare category slugs but names. I have duplicated names in different subcategories but slugs are all different...

I hope official release will fix all that.

September 30, 2013 at 11:31 am #270593

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Régis,

So "men-shoes" links to "women-shoes-nl" ? Not good.
I will pass you on to our developer who takes care of the current Woocommerce issues to have a closer look. His name is Bernat; he might ask you for credentials.

October 1, 2013 at 2:17 pm #271266

Bernat Torras

Dear Régis,

I’ll send you a private email right now asking you for some private information that will help me debug this issue for you. Please check your email in a couple of minutes, and if you don’t get it, let me know so I can send it again.

Thanks.
Bernat

October 7, 2013 at 7:44 am #273412

Régis

Hi, sorry for the delay, I was not at work last week so I was not able to follow this thread.
I'm going to check my inbox.