This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
February 9, 2019 at 11:44 pm #3178845

AndreasTanke1

Hi I'm developing a website with a webshop in DE/EN.
The loading time is awful.
I takes up to 15seconds until the pages are loaded.
I'm have tried to help with "WP Rocket" and "Premmerce Performance Optimizer" but it helps just a little.
When I deactivate "WPML Translation Management" and "WPML String Translation" the speed is rapidly increasing.
Do I need them? How can I increase the speed of my shop?
I can send you the admin data, 'cause it is a development copy of it. So you can also test in this version.
I have also deleted the unused strings via "DELETE FROM `wp_icl_strings` WHERE status = 0;" but it doesn't helped...

February 11, 2019 at 12:10 pm #3182758

AndreasTanke1

Hello? Is anyone out here?

February 11, 2019 at 6:32 pm #3184952

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @andreastanke1, welcome to the WPML support Forum!

Perfomance issues can be related to many variables, such as server type (shared, VPS, dedicated), CPU, memory, PHP version, theme, active plugins, etc.

Please take a look at this article to see how to optimize your website with WPML: https://wpml.org/2012/01/can-your-site-run-faster/

Here is some tips on how you can improve some points:
- Check if your server meet the minimum WPML/WordPress requirements
WPML: https://wpml.org/home/minimum-requirements/
WordPress: https://wordpress.org/about/requirements/

Also, disable the following settings:
- Adjust IDs for multilingual functionality (WPML > Languages)
- Track where strings appear (WPML >String translation)
- Auto register strings(WPML > String translation)

If the issue persist after these steps, please try to regenerate the String Translator cache:
- Backup the website
- Go to WPML > Support > Troubleshotting
- Click on "Recreate ST DB cache tables"
- Navigate on the front-end of the website. It should be slow on first access (because it will regenerate the string cache), but it should be faster after that.

Please let me know if it worked for you.

All the best,
Diego

February 11, 2019 at 7:30 pm #3185190

AndreasTanke1

Ola Diego,
I'm working on a perfomant V-server.

Infos
PHP
Version 7.2.10
Speicherlimit 1024M
Speichernutzung 33.38 MB
Max. Ausführungszeit 60s
Max. Eingangsgrößen 1500
Utf8mb4-Zeichensatz Ja
Multibyte String-Erweiterung Geladen
SimpleXML-Erweiterung \n Geladen
WordPress
Version 5.0.3
Mehrere Seiten Nein
Speicherlimit 1024M
Max. Speicherlimit 1024M

The sitemaps needs up to 20s, to load,

It doesn't looks really faster than before.
I can install a test admin account for you, for further checks.
I have two installations, one with more than 600 products with 2-3 variations each, and another one without any products in it.
I'm using Divi as theme.

Something in WPML slows it really massiv down, can you check it?

Obrigado, Andreas

February 12, 2019 at 2:13 pm #3189065

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Andreas,

Yes, please provide a temporary access to us. I have enabled the private field.

IMPORTANT: Please backup your site first before making any change, this is important for security reasons.

Please also:
- Install this plugin: https://wordpress.org/plugins/query-monitor/ - we will take a look on the slow queires
- Provide us the steps to see/reproduce the issue

Kind regards,
Diego

February 13, 2019 at 7:24 pm #3195915

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I noticed some slow queries related to WPML (not many). I'm not sure if they are the main cause of the delay in loading.

Anyway, we need to replicate the site to our server to do some performance testing and also check the website in a different environment. I've beaten you some instructions through a private message, please let me know if it worked.

Kind regards,
Diego

February 13, 2019 at 9:08 pm #3196227

AndreasTanke1

Hi Diego, I've tried to do this, but it fails. The progress bar is at 2/3 of end, but it doesn't do anything.... hidden link

February 14, 2019 at 8:16 am #3198067

AndreasTanke1

ok, now it is finally migrated.
but be careful, the english version isn't changed, it is just the original source...

Best Regards
Andreas

February 14, 2019 at 5:33 pm #3201208

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks. I'n running some tests and will send you a feedback soon.

Kind regards,
Diego

February 15, 2019 at 1:48 pm #3205148

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I did some tests and the cause seems not related to slow queries, but to images. On my tests, there is no slow queries, but the images are with a big size and taking a lot of time to load. Please take a look at the screenshot: it took 2 seconds to run the queries but 15-20 sec to load the images.

I was able to improve the performance using the steps below:
- Install and activate the "EWWW Image Optimizer" plugin: https://wordpress.org/plugins/ewww-image-optimizer/
- Go to Settings > Wp Rocket > Media, disable lazy load (uncheck all boxes) and save
- Clear the cache for all languages

The page loads much faster after these steps: hidden link

I also recommend to reduce and compress the images size's.

Kind regards,
Diego

February 15, 2019 at 9:53 pm #3206687

AndreasTanke1

Hi Diego, I know this with the slow pics, but that's no prob. My main prob are the several slow queries.
Not in this cloudinstallation, but in my test installation (test.*)
There are still lots of slow queries (Plugin: sitepress-multilingual-cms).
So also the sitemap needs several seconds to load.
Thats happens not in the cloudinstallation, just in my testinstallation.
Have you changed something more?

Best Regards

Andreas

February 18, 2019 at 3:20 pm #3213018

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

They were resolved with the steps below. I think there was a conflict with LazyLoad that was using a lot of server resources. Disabling it, the problem has been solved. Please follow the steps below and tell me the results:
- Install and activate the "EWWW Image Optimizer" plugin: https://wordpress.org/plugins/ewww-image-optimizer/
- Go to Settings > Wp Rocket > Media, disable lazy load (uncheck all boxes) and save
- Clear the cache for all languages

Please note that it may also related to your server settings and not to WPML, as it is working well on the test server. The issue with the sitemap is indicative of this because it has no relation to WPML or even to the WordPress performance.

Kind regards,
Diego

February 18, 2019 at 3:47 pm #3213153

AndreasTanke1

Hi Diego, I've deactivated the lazyload.
Actually it make no sense to use EWWW, 'cause there are to many pics, but I didn't understand where is the context between slow queries in "wpml-string-translation" and "sitepress-multilingual-cms" and the size of the pics.
Of course, later, for the final site it is important, but not now for developing. Or is there any context between these, that I didn't understand?
My Webspace is a V-Server at a premium hoster here in germany, with a lot of power, that can't be the prob. They have checked it before, too. And I find lots of slow queries from wpml...

Best Regards Andreas

February 19, 2019 at 1:58 pm #3216988

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I've made some optimizations on your website like re-enable auto-register strings (in some cases it is better for performance) and re-create the WPML and String Translator cache. This seems to have greatly improved website performance. In my tests, only 1 slow queries were displayed and none in some cases.

When logged in to WordPress, the caches are not loaded, so the lower performance. You can access the website in incognito mode to test it with the cache. In my test this is much faster: hidden link

Please note that your website has 96 plugins and 32 active. Each plugin requires server resources, which can slow it down. If many server resources are being used, slow queries are normal.

Kind regards,
Diego

February 19, 2019 at 2:27 pm #3217116

AndreasTanke1

Hi Diego,
> I've made some optimizations on your website
ok, thanks for that 🙂

> like re-enable auto-register strings (in some cases it is better for performance)
ok? I've deactivated it 'cause I thought it makes it slower, but when you think it's better with it, - no prob 🙂

>and re-create the WPML and String Translator cache. This seems to have greatly improved website performance.
where I can do this?

> In my tests, only 1 slow queries were displayed and none in some cases.
ah, ok, I see, it is just 'cause of the cache plugin.
Are there any options to speed up WPML in general?
When I deactivate the cache, there are again 20-50 slow queries. Is that typical for a Multilanguageshop?
Do you know the Premmerce Performance Optimizer?
Does is speed up WMPL&Woocommerce, like they promise:
"Optimizing multilingual stores which use WPML
Acceleration occurs by caching the menu and optimizing a number of WooCommerce queries.
For online stores with two languages and 16000 products, optimization gives acceleration up to 2-3 times."

> When logged in to WordPress, the caches are not loaded, so the lower
> performance. You can access the website in incognito mode to test it
> with the cache. In my test this is much faster: hidden link
yes, I know, but I was working also on the layout and css and there a cache plugin isn't helpful 😉 but later I will use it, of course!

> Please note that your website has 96 plugins and 32 active. Each plugin
> requires server resources, which can slow it down. If many server
> resources are being used, slow queries are normal.
yes, that do I know. But I'm searching for the best combination. I think at least 30-50% of the plugins will I delete, but I have to figure out which ones...

Best Regards

Andreas