Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: What can I do to optimize WPML performance and increase website speed?

Solution: WPML 4.3 version solved the performance issues that some sites experienced. Updating to the latest version of WPML and its add-ons should resolve the problem.

If you are still running into performance problems, first follow our FAQ entry about preventing performance issues with WPML. This FAQ includes a number of simple steps to follow.

In case you want to profile your site's performance and get to the bottom of performance problems, follow the guide for debugging performance problems.

Author Posts
February 20, 2019 at 2:11 pm #3222159

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

The String Translator cache can be cleaned on WPML > Support > Troubleshotting > Recreate ST DB Cache Tables.

The "Premmerce Performance Optimizer" is not listed at our compatibles plugins list: https://wpml.org/documentation/plugins-compatibility/ - It only means that it was not tested yet by our team, so It may work or not. I suggest to send a message to the plugin developers asking about the compatibility.

Kind regards,
Diego