This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
May 10, 2019 at 1:02 pm #3784495

viktorB-10

I am trying to: Translate specific content parts of the Products. The text is placed into I am trying to: Translate specific content parts of the Products. The problematic text is placed into a Woocomposer Product Builder tempate,(in an 'inner column element' inside Wp Bakery Visual composer editor - i attached images) and that part we can't figure out a way make available for translation.

Link to a page where the issue can be seen: hidden link . Here the paragraph straight under the price. ("Elképesztő öröm..")

I expected to see: That text to be translated as well.

Instead, I got: Can't see it in ATE translator, nor in string translator, etc. Where to search for it?

ps.: now the site is temporarily translated with another plugin, but we would be happy with wpml on the long run. Wpml is deactivated now. (i only activated it to output the debug info.)

Hope you have the quick solution for this!
Best wishes,
Wiktor

May 11, 2019 at 2:11 am #3788531

viktorB-10

Hii! I tried to fix it via xml config file, but in the wpml settings > xml editor i found empty lines. Instead it supposed to show the file content i guess? The website is quite protected, so maybe there are extra 'firewalls' that block it to show up?

I also tried to wrap the problematic text into wpml shortcode according to the guide, which works, and i found the text in the String Translator, but it shows up as english text, however it should be hungarian (the default lang.) and i would like to add the english version of the text in the String Translator instead.

I attached images of all. Also i don't know if it's alright, that The Wp Bakery's Visual Composer editor doesn't have any language options, no flags, nothing., so there is no option to switch languages. Is that normal (in the product template editor) or is that some bug/plugin conflict tho?)

Hope we can solve this puzzle this soon.;)
Best wishes,

May 13, 2019 at 8:26 am #3796039

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

It's alright if you found the XML configuration file empty, because that was made for you to write your own code (or overwrite the ones from the plugins/themes), the file you're looking for is called wpml-config.xml and it's located in the root folder of your plugins / Themes.

In this case, it's very likely that you will not find what you're looking for in those files, though, because you will need to register them (i.e: add that new information in the XML file using the "empty lines" page you mention)

If you need more information, let me know what you've tried to do so far, and follow the guide i sent you before (if you need to check how to correctly write the XML code) or give me access to your site and i'll try to do it for you (and, of course, i'll let you know how i did it, so you can do it in the future)

Remember that the credentials need to be added on the private fields i activated for you, do not post them in here (on a normal reply box) otherwise they will be public.

Regards.

May 17, 2019 at 11:50 am #3834155

viktorB-10

Hi Alejandro! I updated the wpml-config.xml from the OnTheGoSystems github repo. But it still seems to be not enough. My problem is still: that it seems, the wpml language editor box simply doesn't show up at all at the Visual Composer editor screen at all.. (see the attached screenshots).

As you see, there is no language box at the right column. There was also no option/prompt showing up to activate the Translation Editor when i installed wpml. However i read/see that it should be there. Have you met this kinda bug/issue before?

Maybe it's about the order how these 2 plugins installed? First should install wpml and then (re)install Wpbakery's VC ?
Cheers, Wiktor

May 17, 2019 at 4:56 pm #3836113

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

In this case, the order is not really important.

Can you upload your version of VC composer and add the same theme in this sandbox site?

then create a page and add the shortcodes that are not being translated, because i believe these particular shortcodes are not registered (or maybe they were edited by a plugin or theme).

By uploading them in the sandbox site, i'll be able to isolate the problem a little bit faster without having to touch your site at all!

this is the link of the sandbox: hidden link

May 26, 2019 at 1:30 pm #3891745

viktorB-10

Hey Alejandro! I havn't yet managed to do this separation/sandbox you suggested. Had no capacity for it, but i answer here now, to get a few more extra days, to keep this thread not closed by a sweeper robot. Maybe i will try to setup the sandbox (which may take some time which i'm short of recently). Thanks for ya understanding!

May 27, 2019 at 1:11 pm #3897483

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Oh don't worry about it, take your time, i just opened the sandbox site so it' doesn't expire (it expires after 7 days of inactivity). the status i set for this ticket allows the ticket to be open for more or less 14 days, so if you can, please open the ticket whenever you can and open the sandbox site so it remains active.

Let me know if it expires so i can create a new one for you.

The topic ‘[Closed] Woocomposer / Wp Bakery Visual Composer plugin content not translatabl’ is closed to new replies.