Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: WPML Translation Management showing wrong (high) word count for pages created with Elementor.

Solution: It should be fixed in the next WPML version, 4.4.0.

0% of people find this useful.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 36 replies, has 3 voices.

Last updated by zoeyY 1 year, 4 months ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
April 20, 2020 at 1:23 am #5944207

zoeyY

HI Andreas, thanks for the info. I have tried on two of my existing prod site and the count problem still exist. As per image1.

I have also checked on a 2nd site which has nothing at the moment, just for the sake of comparison, there is now an option to run this mo scan (which I didn't get before or now in my existing prod site, as in image2.

I then checked the staging and noted the problem you highlighted - the classic test page is similar to the contact-us page but one is 26 words and the other is 1373 words. Both look like something you have created. So why there is a difference since both are exactly same except title?

Also on the staging, I noted there is no msg on the mo file, like the one I got on the 2nd test platform which seems to have no problem w word count.

I follow the same way to install all 3 environments. So to be sure, I went back and did the reset troubleshooting page but same problem exists. I have also check the file permission and they are all the same. So why one instance gives the mo file option to run as per image and the staging+prod do not? what config that makes this mo file option appears?

mo write.PNG
newsletter 1 page translation on prod.PNG
April 20, 2020 at 9:26 am #5946935

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello Zoey,

Andreas is on vacation and will be taking over this ticket.

I will try and answer your question the best I can and please if you having any other issue follow our guidelines and open a ticket for each issue.

1) It scans your theme and plugins for strings. Then you can translate them using WPML>String translation.

Please check: https://wpml.org/documentation/getting-started-guide/string-translation/

2/3) You can manually clear data created by String scan by deleting data from icl_strings SQL table.

More info: https://wpml.org/documentation/support/wpml-tables/#string-translation

> We do offer the option to reset all tables and clear all WPML tables created.

Be aware this will delete all translations made by WPML

WPML reset cannot be undone. We recommend that you create a backup of your site before resetting WPML.

More info: https://wpml.org/faq/how-wpml-reset-works/

4) I am not sure what Andreas did. But:
I am really not sure what is causing the issues on your site but seems somehow to be solved, as it does not occur on newly created content.

Can you try the same and see if it happens with the newly created content?

Thanks and regards.
Drazen

April 22, 2020 at 7:21 pm #5971711

zoeyY

HI Drazen, thanks for the concise explanation. So to follow thru on your answers for the questions I posted:

1. is this mandatory? cos we don't care if the themes are not in English or the plugins. What we need is the content, e.g. the quiz or data we use to build the pages needs (e.g. the image box, the call to action box, text, etc.) to be translatable. We don't mind the WP dashboard etc is in English only.

2. we have done the reset but the size of DB is still as big. Before installation of WPML, it's around 50mb, after running the install and NO translation done for content yet but did the string theme and plugin translation button during config, it went up to 140mb

3. So it looks like reset didn't clear the tables, even after deactivate, delete, and reinstall, all the theme and plugin translations are still there. so how to get rid of them??

4.

April 22, 2020 at 9:24 pm #5972179

zoeyY

Hi Drazen, I have further created a new page with less than 350 words but then on translation mgr, it shows: Word count estimate: 2406 words in 1 document(s) Word count for the entire site. I have also tested in on another site, a 600 words turned out to be 1650 words. Both sites use Elementor and both pages are brand new.

I am now trying to activate my Elementor license on the staging site you have access, I suspect it has to do w Elementor. Once I get it activated on staging, I will do a same test page and update you. Pls check into the problem first.

April 22, 2020 at 9:30 pm #5972211

zoeyY

HI Drazen, further in another thread on folder permissioning, your other colleague said there is no need to make any changes to permissioning. Then Andreas told me my word count problem is due to the .mo file write problem. So what is what now? Am so confused and frustrated by just a new install on a simple website with nothing fancy except use of Elementor. Pls see his msg below:
Hi,

WPML does not require any special permission settings if your WordPress and it's folders are set it correctly according to the WordPress standards.

We currently follow WordPress guidelines and need only permissions to write on directories located in the /wp-content/ folder.

Only if the owner of the webserver changes the permission to "/wp-content/" directory you will face any issue.
If the "/wp-content/languages/" and "/wp-content/plugins/" directories has the same permissions as the "/wp-content/uploads/" or /wp-content/ you should not face any issue.

So, you do not have to check WPML folder or /languages/ folder permission if you set the WordPress folders permission correctly as :
- https://codex.wordpress.org/Changing_File_Permissions
- https://codex.wordpress.org/Hardening_WordPress (Core directory and files)

Regards,
Riffaz.

April 23, 2020 at 8:16 am #5974215

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello Zoey,

I seem to figure out what is causing to show the word count not correct. I have checked your staging site and it shows approx correct wordcount for new pages, but not for old ones. So I went and checked what is wrong with the old ones, it seems and the time of the creation/translation some of the custom fields were set to translate (like elementor template, css etc) saved in MYSQL database which then is counted for transition but when you access ATE translation screen it is showing correct number since ATE recognized this is not for translation.

It could be that you didn't do anything wrong but just some settings were not working correctly since there are some issues with the Siteground optimization process and WPML settings being correctly saved.

Info:
- https://wpml.org/errata/siteground-optimizer-changes-in-wpml-settings-wont-save/
- https://wpml.org/home/minimum-requirements/

I have increased your memory limit and disable some SG cache as per link, just in case to avoid any further issues. Make sure you test on other new pages with the same.

Can you please check and confirm this is not happening on new pages?

For all other questions:

1) it is not just in the backend, there could be buttons text, read more strings, some theme elements heading etc that show up on the frontend. It depends on the plugin/theme.

3) Delete manually tables from MYSQL (backup database first)

- The strings are kept in the icl_strings table with the following columns

- Translations to the string are kept in the icl_string_translations table

Info:
- hidden link
- https://wpml.org/documentation/support/wpml-tables/

4) There is no need if permission set correctly as per WordPress standards

If you having troubles we will have to open new tickets for each issue.

Please let me know how it goes and don't hesitate to ask if you find any problem along the way.

Regards,
Drazen

Screenshot_3.jpg
Screenshot_2.jpg
Screenshot_1.jpg
April 23, 2020 at 6:36 pm #5980699

zoeyY

HI Drazen, thanks for the explanation.

I have previously raised ticket #5870111 about potential setup instruction conflict w Elementor and was told something I couldn't understand which I gave up answering. I believe you are right about Elementor and the caching problem. I checked again the DB size on prod site and it's now back down to normal 45mb instead of the 140mb. So this makes sense of the caching cos there is a delay on my wpml reset and db size. So DB size question is resolved.

Now, the mem problem -
1. I have added the two lines you added to my staging to my prod and app domains so now wp mem is good for my subdomains.
2. My app subdomain doesn't have SG optimizer plugin but my prod has. Both sites have Elementor. Both sites have word count problems. The old files on Staging was done w Elementor cos it was a replica of the prod. So I can see why you can't replicate the problem w the new pages.
I can't move the license to staging yet but will do later since you are working at a different timezone than I am (seems to be) So I will move over end of my day for you to check why elementor seems to add so much more word to the translation count.

3. I noted the root folder in my hosting public_html/wp-content/languages has a bunch of mo etc files. Pls see image. This is the master root folder of the hosting site where my staging and prod etc. reside. So should I clear these?

folders.PNG
mo files.PNG
April 24, 2020 at 6:54 am #5983331

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for the reply.

I have tried recreating with Elementor but there is no issue with the new pages, only old ones. Not sure if I am doing something wrong. If you have the same problem with new pages, please share where I can see it / how to replicate the issue.

Please check the video: hidden link

As for old pages, I will check with my colleagues if they can advise on this case and get back to you.

2) Those are mo files from WordPress/plugins themes

More info:
- https://wordpress.org/support/topic/filechange-warning-wp-content-languages-json/
-hidden link

I will get back to you on the word count issue.

Thanks and regards,
Drazen

April 26, 2020 at 4:24 am #5994901

zoeyY

Hi Drazen, I have done another test on my prod and I can confirm the following:

1. using just basic Elementor text block, there is no extra word count problem.
2. just by adding a block that has a bunch of images/call for action widgets, a 1123 word page turned into: Word count estimate: 2865 words in 1 document(s) Word count for the entire site. Remove that block, it went back to : Word count estimate: 1155 words in 1 document(s) Word count for the entire site
3. Added 8 call for action widget, nothing inside except an image and the default text, word count went up to: Word count estimate: 1746 words in 1 document(s) Word count for the entire site. The actual total words added was only 120 words, so it should not be anything more than 1300 words but it shot up instantly to 1746 words.

4. I did exactly the same thing on my app subdomain: initially has a test page of Word count estimate: 1684 words in 1 document(s) Word count for the entire site, after adding 8 call to action widgets, which in total added 120 words, the new Word count estimate: 2300 words in 1 document(s) Word count for the entire site

So something is not right w the Call to Action Widget in the translation mgmt process.

It so happens that my two main pages on this new site only mainly used call to Actio.

Pls pls help figure out what's wrong. IF we can't fix this, I will have to deinstall and get a refund.

We have both spent too much time on one problem that seemingly not being resolve.

I really don't know what to do now. I have compared every setting on my prod site to my app site and everything are nearly the same except it says on my prod site:
No translation languages configured for this user. under Translation. While admin on both sites have been configured as the translation mgr.

PLS advise.

April 27, 2020 at 6:32 am #5999255

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hey Zoey,

I just took over few days ago so I haven't been able to test everything and investigate the issue further. No worries we will find a solution, sorry it is taking so long.

I have just now received information from you how to replicate the issue, so this helps a lot. I am still working on staging without Elementor PRO and I can not get the same issue, I hope you understand why I am not able to advance.

I need to be able to replicate the issue as you have described, but I can't since Elementor PRO is not activated on your staging site I can't do I thing. Maybe there is a bug with a new version, but since I can not use it I can not understand the issue.

My colleagues and I will be waiting so we can move to the next step, and if needed escalate this ticket to our developers to fix the issue.

But to understand it better I need to be able to replicate the issue like you are.

So please enable Elementor PRO licence on staging site or please share credentials to the site where I can replicate the same issue, I have enabled private next reply.

Please let me know and no worries we will solve this issue you are having.

Once again sorry it is taking so long.

Thanks and regards,
Drazen

April 27, 2020 at 12:30 pm #6002171

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

just to update and add to my last reply.

I went and tested if there is some compatible issue with Elementor and WPML, and tested on a clean install on my side. All work correct, please check the video:

Link: hidden link

So please as I have mentioned in my previous reply please enable me to replicate the issue on your side. Either add Elementor PRO licence and confirm the issue is replicable on staging site or provide me URL and login details for website where I can replicate the issue.

Since this seems to be an issue that is happening on your side only.

If I am doing it wrong if possible help me reproduce the issue correct way by sharing the video of the steps and issue.

Thanks and regards,
Drazen

April 27, 2020 at 8:39 pm #6005693

zoeyY

Hi, Drazen, I have not been able to connect and activate to my existing Elementor license (I have 3 and I am disconnecting my dev one for staging but unsuccessful). I already had a ticket w them and they have asked that the URL on staging to change to staging but I can't seem to be able to do that. When I tried, wp reverted it back to the one w/o subdomain, pls see attached. No error prompted. Any clue? without being to activate Elementor you can't access staging properly. If you can fix that, I can connect to my license for u to test.

URL address.PNG
April 28, 2020 at 11:53 am #6011775

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

I think you need to change URL of webpage in Elementor myaccount page and select where licence is going to be used.

You should be able to Disconnect the licence from one URL and then connect to another.

Deactivate the license from your former website in "Elementor > License" on your WordPress Dashboard, then activate the license on the new website.

Please check next instructions:
- hidden link

I would advise contact Elementor support to help you out with switching licence, if you are having problems.

Let me know how it goes, I will be waiting.

Thanks and regards,
Drazen

file-xy0INPP6RV.jpg
April 29, 2020 at 4:53 am #6017467

zoeyY

Hi Drazen, I got the ftp info. Pls send me the option to pass to you on private msg. I need to pass u access to prod site cos the staging setup wont allow me to connect to Elementor no matter what. So I could only ask you to pls check the prod site.

I have just now tried my home page on my subdomain prod app.happinessandwork.com and you can see the homepage only has a few words but the count is: Word count estimate: 1196 words in 1 document(s) Word count for the entire site

This page has NO call to action. Only heading and 1 button. Pls visit the prod site URL home and you can see. I have attached the image from wmpl. The only thing is I am running a buddyboss theme.

word count on app subdomain.PNG
April 29, 2020 at 2:02 pm #6022249

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello Zoey,

I have enabled private reply and private fields for your next reply.

Please make sure you have a backup.

1) Please provide WP administrator access and FTP credentials

2) Please provide steps on how to replicate the issue on a new page

Thanks,
Drazen