This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 17 replies, has 8 voices.

Last updated by Amit 7 months, 1 week ago.

Assigned support staff: Amit.

Author Posts
December 5, 2018 at 8:23 pm #2971640

Amit
Supporter

Our new WPML release is specifically dedicated to Gutenberg integration. To learn how to translate content that you create with Gutenberg, read WPML https://wpml.org/2018/11/wpml-4-1-adds-gutenberg-compatibility - 4.1 announcement post.

We also have 3 known issues you should be aware of:

- Translations of Gutenberg Reusable Blocks are not displayed - https://wpml.org/errata/translations-of-gutenberg-reusable-blocks-are-not-displayed
- Gutenberg Latest Posts block displays posts in all languages - https://wpml.org/errata/gutenberg-latest-posts-block-displays-posts-in-all-languages
- Gutenberg blocks created using ACF 5.8 are not translatable - https://wpml.org/errata/gutenberg-blocks-created-using-acf-5-8-are-not-translatable

Gutenberg is such a different editor that it requires many changes from all plugins and themes.

Gutenberg on existing sites
If it ain't broken, don’t fix it. For existing sites, the safest approach right now is to stay with the classic editor. To do this, we recommend that you use the Classic Editor plugin.

Gutenberg on new sites
When you’re building new sites, there’s less to break. Give Gutenberg a try and see how you like it. If the plugins and theme that you use work great with Gutenberg, you might be into a nice new experience.

December 7, 2018 at 6:10 pm #2979060

Patrick Cruz

Hi Amit,

You can add that WPML 4.1.1 is not working with WPBakery 5.6 on WordPress 5.0.

Error when both activated:

TypeError: e is undefined[Learn More] shortcode.min.js:1:1650

December 7, 2018 at 6:17 pm #2979113

Amit
Supporter

Thanks, @patrick, we did not see this when testing, looking at this.

December 7, 2018 at 6:59 pm #2979186

Amit
Supporter

Hi @patrick, my colleague Ahmed have just tested and both front and back-end are working fine, we were also able to translate and publish a post as usual.

Can you please open a new ticket with as many details as possible so we can debug your site and see what's going on?

Thanks!

December 10, 2018 at 10:18 am #2983390

mmoI

Hello,

I have same problem between WPML 4.1.1 / WPBakery 5.6 but with WordPress 4.9 (previous version).

December 10, 2018 at 4:01 pm #2985225

martin

Hi, I can't see the admin post page. It' completely blank after updating to wordpress 5.0.

December 10, 2018 at 6:15 pm #2985658

Patrick Cruz

WPML 4.1.2 fixed this issue for me.

My Versions:
Wordpress Version 5.0
WPML 4.1.2
WPML CMS Nav 1.4.24
WPML String Translation 2.9.0
WPML Translation Management 2.7.0
WP Bakery 5.6

December 10, 2018 at 6:30 pm #2985704

davidG-36

I don't see the update possibility in WordPress 4.9 Dashboard > Plugins.
It still shows 4.1.1 as a last version.

Is it necessary to update my wordpress to 5.0 for WPML 4.1.2?
If yes, I will not do it! Because of too many bad reviews for 5.0

I need the solution for wordpress 4.9

December 11, 2018 at 7:13 am #2987348

Amit
Supporter

@ davidG-36, thanks for the heads up - I am checking the update issue. and NO - you do not need to update to WP 5.0 for WPML 4.1.2.

December 11, 2018 at 7:56 am #2987483

dennisL-14

Hey since the Wp 5.0 update my Avada Fusion Builder does not work with WPML activated anymore. If i want to change something in the page i have to deactivate WPML. Any solutions?

December 11, 2018 at 10:36 am #2988119

nicolaC-4

Also I have he same problem:

My Versions:
Wordpress Version 5.0
WPML 4.1.2
WPML String Translation 2.9.0
WPML Translation Management 2.7.1
WP Bakery 5.5.5

December 11, 2018 at 5:30 pm #2989810

Patrick Cruz

@nicolac-4 you should update your WPBakery to 5.6 as it has the WP 5.0 fix.

hidden link

December 12, 2018 at 8:03 am #2991921

nicolaC-4

@patrick Cruz, I have updated WPBakery to 5.6 but the problem still remains.
The strange thing is that with some page I see the editor of visual composer but with the others not!
See screenshots

December 12, 2018 at 5:12 pm #2994469

Patrick Cruz

@nicolac-4 you need to disable Gutenberg Editor.

December 13, 2018 at 11:17 am #2997335

nicolaC-4

Ok, now it works!
Thanks veru much.