This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by samuelL-19 2 months, 4 weeks ago.

Assigned support staff: Bruno.

Author Posts
June 26, 2019 at 4:53 pm #4094153

samuelL-19

I cannot change WordPress language in Settings>General because WPML locked it... also, wordpress language is already "français". Can you help? My client have a big issue with that.

June 26, 2019 at 5:01 pm #4094185

samuelL-19

when I try reinstalling wordpress 5.2.2 FR, left menu is in french "just after the installation" but goes back to english as soon as I click on any link.

June 26, 2019 at 8:27 pm #4095043

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. To change the default language you must change in WPML > Languages > Site URL. About the interface, you can change this in Profile > Your Profile > Language.

By following the steps above, can you change the language of your site as desired and change the interface language?

Thank you.

June 26, 2019 at 10:05 pm #4095243

samuelL-19

Hi Bruno, thank you for your fast reply. Unfortunately, changing interface language (Profile>your profile>Language) doest not work... English, French or Default (which is french). Please note that when I try "English", then everything is in english, but "french" and "default" gives a mix of both language.

Interresting fact, disabling the "WPML Multilingual CMS" plugin and everything is back in french.

Any clues?

Regards,

June 29, 2019 at 5:20 am #4111107

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Please, could you follow the steps below to see if the problem persists?

- Click on the WPML > Theme and plugins localization
- On the "Localization options", uncheck the "Assume that the original language of all strings is English"
- Click on the Save button

This will make the strings to display correctly. Please, note that this has already been reported to our developers for them to review. At the moment, this is a workaround that changes the backend strings as expected.

Thank you.

July 1, 2019 at 12:22 pm #4118737

samuelL-19

Hi, thank you for your fast reply. Unfortunately, the "Assume that the original language of all strings is English" checkbox was already unchecked. I try to check, then uncheck again. No changes.

But then I tried the
- "Ne pas utiliser la Traduction de chaîne pour traduire les thèmes et plugins"
and
- "Traduire les thèmes et plugins à l'aide de la Traduction de chaîne WPML et charger systématiquement les fichiers .mo comme sauvegarde"

radiobutton options. Both made the admin interface back to french (entirely).

What do you suggest I do next?

July 1, 2019 at 11:24 pm #4122495

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

To be able to check what may be happening, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

July 8, 2019 at 9:21 pm #4165817

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. When I access your website and convert the user I am using to French, the menus are displayed correctly. I'll attach an image for you to see.

I should take other steps to see the problem you are reporting.

Thank you.

July 12, 2019 at 4:56 pm #4200571

samuelL-19

Hi Bruno, yes to reproduce the problem, you need to activate the "Traduire les thèmes et plugins uniquement à l'aide de la Traduction de chaîne WPML (ne pas charger les fichiers .mo)" radio button (which was selected by default)

July 12, 2019 at 10:31 pm #4201743

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. Now I can see the problem you are reporting. To fix this I followed the steps below:

- Click on the WPML > Theme and plugins localization
- Select the "Traduire les thèmes et plugins uniquement à l'aide de la Traduction de chaîne WPML (ne pas charger les fichiers .mo)"
- Click on the Save button
- Click on the WPML > Support > Troubleshooting
- Scroll down and click on the "Recréer des tableaux de mise en cache de BD de TC" button
- Refresh the page

Following the above steps, the admin interface is displayed in French as desired. I've already followed this in your testing environment and it worked, too. Please, could you check?

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

July 18, 2019 at 4:16 pm #4240951

samuelL-19

My issue is resolved now. Awesome, thank you very much!