This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Bruno Kos 8 months, 2 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
January 11, 2019 at 12:31 am

kennethS-3

I am trying to:
It appears the error message of mixed content from wpml is affecting the functionality of the wordpress administration panel

Link to a page where the issue can be seen:
can only be seen in the admin panel

I expected to see:

Instead, I got:

January 11, 2019 at 8:43 am #3079655

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

We had an exact error reported by some of our users when they were switching their sites from HTTP to HTTPS. There are several ideas and advice on how to get this possibly resolved. Can you check the following threads and try ideas that my colleagues (as well as some clients) suggested and then let me know if any of these got your issue resolved?

https://wpml.org/forums/topic/ssl-mixed-content-error-after-switching-from-http-to-https/
https://wpml.org/forums/topic/how-do-i-fix-the-ssl-mixed-content-error-message/
https://wpml.org/forums/topic/need-help-on-https-getting-mixed-content-error/

Please make a full backup of your site before trying this or make these changes on a staging/development site!

You can use plugins such as Duplicator ( https://wordpress.org/plugins/duplicator/) or ask your host to perform a site backup.

Regards,
Bruno Kos

January 14, 2019 at 4:43 pm #3088870

kennethS-3

I have done these steps again and the problem still remains. I have many other sites where the problem cleared up after clearing the cache both on WPML & Cloudflare. I am not using caching plugins. Plus I would rather not install another plug in (example force SSL) to fix the problem.

January 15, 2019 at 9:55 am #3091914

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I've tried clearing WPML cache with:
hidden link

But since we have backend errors, none of these buttons work. Could you try temporarily installing plugin such as https://wordpress.org/plugins/really-simple-ssl/ and try clearing WPML cache (perhaps any of these plugins will temporarily bring back these buttons to life) then or to see if that resolves the issue?

I can completely understand any concerns related to installations of any new plugins, but we are bit limited with options here without even trying this approach, since other ideas may require much more manual work such as hidden link

Regards,
Bruno Kos

January 21, 2019 at 8:40 pm #3113992

kennethS-3

The backend errors go away if you tell the browser to load unsafe scripts. I have cleared the WPML cache and the Cloudflare cache. The problem still exits. The plugin does not help. The site is already secured and if you deactivate the WPML plugin the problem goes away.

I have a dozen or so websites using WPML, on the same hosting, same plugins, same everything. I have 3 sites that have the very same issue with WPML.

Is there a way to completely uninstall WPML and install without losing all the translated pages?

January 22, 2019 at 8:18 am #3115055

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Uninstalling the plugin from dahsboard or FTP would not delete any of the translations or plugin settings. Can you tell me what happens on removing/uploading anew?

Otherwise, since I don't have any other ideas to suggest at this point, I can escalate this to our 2nd tier and they would look into this directly. Let me know about results so that I can proceed with that.

Regards,
Bruno Kos

January 30, 2019 at 5:21 pm #3145227

kennethS-3

I've tried everything. I uninstalled all the WPML plugs in and the minute I install and the error messages happen again. I still have this site (and a couple more) that are experiencing this same issue. It is starting to become a huge pain. Please advise next steps.

January 31, 2019 at 8:45 am #3146663

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

So just to confirm - you've tried exactly these as well?
https://wpml.org/forums/topic/need-help-on-https-getting-mixed-content-error/#post-1349042

Two more things:
Based on provided debug information, I can see the following - WP Memory Limit: 40M.

Specifically, could you set WP Memory limit to at least 256MB?
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

If unsure on how to set this, you can consult your host/server admin to do this. After you increase this value, you can confirm it by checking on WPML -> Support by finding the “Memory limit” value.

Another thing - what happens when you temporarily disable caching? I am not talking about Cloudflare or other caching plugins/systems only - I am also referring to server caching. Many hosting companies have their own and very strong caching systems, some of which are not even available through admin panels and you might need to ask your host to assist on this - at least clearing it.

Because that's what comes to my mind when you say "I have many other sites where the problem cleared up after clearing the cache both on WPML & Cloudflare.".

Regards,
Bruno Kos

January 31, 2019 at 5:46 pm #3149109

kennethS-3

Bruno,

I will address the memory issue but it is not related to this issue. All my hosting is done with Google Cloud VM's that I have complete control. There is no server caching. If I resort back to version 3.7.1 the issue goes away. I am a web developer with websites that do millions of dollars online and very experienced in hosting. The plugin once upgraded to version 4.+ is when all the sites went crazy. Some upgrades went without an issue, some went away after clearing the cache and now I still have three websites where I cant get the issue resolved and its starting to affect my business and I'm done trying to figure out what went wrong.

On one site I am going to do a complete uninstall. Please advise how to completely uninstall WPML so I can start fresh and see if this issue goes away.

Ken

February 1, 2019 at 6:52 am #3150477

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

You can completely wipe up WPML installation by going on WPML -> Support - > Troubleshooting. You will find Reset button on the bottom.

However, based on your latest reply and if Reset isn't working also, can you tell me if it would work for you that you send me FTP/WP-admin access for the sites in question only and that I can escalate that to our 2nd Tier so that they can check what's going on? Since you have other sites on the same server without issues, I see no point in migrating these sites to our Cloudways, it might be faster to check this directly.

Let me know so that I can mark your next reply as private where you can send credentials.

Regards,
Bruno Kos

The topic ‘[Closed] WordPress Administration Not functioning’ is closed to new replies.