This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: WordPress backend language is not the language selected in the user profile.

Solution: 1. go to WPML > Theme and plugins localization 2. select the option "Translate themes and plugins using WPML's String Translation and always load .mo files as backup" in localization option : https://take.ms/VLhND 3. save 4. switch back to "Translate themes and plugins using WPML's String Translation only (don't load .mo files)"

This topic contains 2 replies, has 2 voices.

Last updated by ZanK 1 month, 3 weeks ago.

Assigned support staff: Riffaz.

Author Posts
August 25, 2019 at 9:19 pm #4455199

ZanK

Hello,

My default language is set to Slovenian language but when I log-in into wp-admin, I have everything in english even though Slovenian language is selected in the upper menu. The reason I need this to be translated is because I believe that this is the reason why core wordpress strings are not translated in front end (for example days, Leave a Reply,...). I have already tried to change default language in user settings but this does nothing.

Thank you!

August 26, 2019 at 4:09 am #4455921

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I could be able to fix this same issue for another user.

Please try this:
1. go to WPML > Theme and plugins localization
2. select the option "Translate themes and plugins using WPML's String Translation and always load .mo files as backup" in localization option : hidden link
3. save
4. switch back to "Translate themes and plugins using WPML's String Translation only (don't load .mo files)"

Your issue should be fixed.

This worked and solved two other tickets with the same issue.
i. https://wpml.org/forums/topic/woocommerce-not-translated-backend-in-english-not-italian-as-expected/
ii. https://wpml.org/forums/topic/default-site-language-is-not-working-its-set-to-slovak-but-everything-is-in-en/

Let me know how it goes.

Regards,
Riffaz.

August 26, 2019 at 8:28 am #4456821

ZanK

Thank you for your suggestion. When I switch to "Translate themes and plugins using WPML's String Translation and always load .mo files as backup" it's working, but when I switch back to the first options strings are not translated anymore. So I will just use second option.