This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Error Deadlock found when trying to get lock

Solution:

Fixed by updating to beta versions

This topic contains 11 replies, has 2 voices.

Last updated by davidF-64 4 weeks ago.

Assigned support staff: Riffaz.

Author Posts
September 11, 2019 at 8:18 pm #4556371

davidF-64

Tell us what you are trying to do?
We were experiencing this issue a few weeks ago and it is reoccurring on on of our site with string translation. This is the error message from earlier today.
[Wed Sep 11 20:03:17.060253 2019] [:error] [pid 6666] [client 64.191.39.194:50731] WordPress database error Deadlock found when trying to get lock; try restarting transaction for query INSERT IGNORE INTO wp_cp_icl_strings (`language`, `context`, `gettext_context`, `domain_name_context_md5`, `name`, `value`, `status`) VALUES ('en', 'admin_texts_wpseo_titles', '', 'e378148fddf4e947517c053abc51db93', '[wpseo_titles]title-home-wpseo', '%%sitename%% %%page%% %%sep%% %%sitedesc%%', 0),('en', 'admin_texts_wpseo_titles', '', '2476ea778a362cacbfea45d366f8cd81', '[wpseo_titles]title-author-wpseo', '%%name%%, Author at %%sitename%% %%page%%', 0),('en', 'admin_texts_wpseo_titles', '', '6e3e4dba90fc74ab7a07293176821ffd', '[wpseo_titles]title-archive-wpseo', '%%date%% %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', '281293b22d86402357ed7621ded8febf', '[wpseo_titles]title-search-wpseo', 'You searched for %%searchphrase%% %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', 'c7cd70b815da0a1bc7a89f114689fef9', '[wpseo_titles]title-404-wpseo', 'Page not found %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', '3a08c2a7139303582e57ac47e86e7258', '[wpseo_titles]metadesc-home-wpseo', '', 0),('en', 'admin_texts_wpseo_titles', '', 'ec66abe8df773eba4a10f9e587d19cd3', '[wpseo_titles]metadesc-author-wpseo', '', 0),('en', 'admin_texts_wpseo_titles', '', '9ea43ca30a5675bb241cf1b9dbf6c8f8', '[wpseo_titles]metadesc-archive-wpseo', '', 0),('en', 'admin_texts_wpseo_titles', '', '514b0030e57abe01aa16f1455b311f24', '[wpseo_titles]rssbefore', '', 0),('en', 'admin_texts_wpseo_titles', '', 'a3a851d2d2adda24739621eb44271ff7', '[wpseo_titles]rssafter', 'The post %%POSTLINK%% appeared first on %%BLOGLINK%%.', 0),('en', 'admin_texts_wpseo_titles', '', '74bd89c9815aa4045eec71c60c016450', '[wpseo_titles]breadcrumbs-404crumb', 'Error 404: Page not found', 0),('en', 'admin_texts_wpseo_titles', '', '641c15f2451a6edc83e71d2653ee3633', '[wpseo_titles]breadcrumbs-archiveprefix', 'Archives for', 0),('en', 'admin_texts_wpseo_titles', '', 'd58f3fed38fae2244472c2b21e5027d5', '[wpseo_titles]breadcrumbs-home', 'Home', 0),('en', 'admin_texts_wpseo_titles', '', 'b41fa82224fb46efaf102cbf074d4058', '[wpseo_titles]breadcrumbs-prefix', '', 0),('en', 'admin_texts_wpseo_titles', '', 'a8c9368c56519fc68d22cc69d3d95eab', '[wpseo_titles]breadcrumbs-searchprefix', 'You searched for', 0),('en', 'admin_texts_wpseo_titles', '', '9ccdb80bbe3e08134cca2eaf7c238da4', '[wpseo_titles]breadcrumbs-sep', '»', 0),('en', 'admin_texts_wpseo_titles', '', '641cd92566753b75b04223f0aced98ca', '[wpseo_titles]company_name', '', 0),('en', 'admin_texts_wpseo_titles', '', '97000059f301201826039d176e79ae1d', '[wpseo_titles]title-post', '%%title%% %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', '86bc56a1012403e5bcbb4a176ec00b85', '[wpseo_titles]metadesc-post', '', 0),('en', 'admin_texts_wpseo_titles', '', 'a6209b6b34e4cd196567cd7d81fde939', '[wpseo_titles]title-page', '%%title%% %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', '2ef2ef0ea428ec30cb0c8a734a448f19', '[wpseo_titles]metadesc-page', '', 0),('en', 'admin_texts_wpseo_titles', '', 'a2de5a5477dce81fe97d2525971d5494', '[wpseo_titles]title-attachment', '%%title%% %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', 'e2877c922395c662313e7dfcd52ea1e4', '[wpseo_titles]metadesc-attachment', '', 0),('en', 'admin_texts_wpseo_titles', '', '1cdcfb9dfac3caa2663085e8e3710518', '[wpseo_titles]title-tax-category', '%%term_title%% Archives %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', '726337e20451bbaaa317cf566b424fd3', '[wpseo_titles]metadesc-tax-category', '', 0),('en', 'admin_texts_wpseo_titles', '', '4873100137ee1cbfd8873e4fcae8c704', '[wpseo_titles]title-tax-post_tag', '%%term_title%% Archives %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', '31c0e350d880d263a46e9d62ef426d8d', '[wpseo_titles]metadesc-tax-post_tag', '', 0),('en', 'admin_texts_wpseo_titles', '', '59dc5fd50c05a504ef3c5ad46761ab8c', '[wpseo_titles]title-tax-post_format', '%%term_title%% Archives %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', '5b41172c28e2e54322cf6072ee4e0fcf', '[wpseo_titles]metadesc-tax-post_format', '', 0),('en', 'admin_texts_wpseo_titles', '', '93442a051143698b26c982d3ba0aacde', '[wpseo_titles]title-features', '%%title%% %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', 'a61a2699585ba38d475da58c8818a543', '[wpseo_titles]metadesc-features', '', 0),('en', 'admin_texts_wpseo_titles', '', 'ec1d4e7edb19d448d9b558d079de145f', '[wpseo_titles]title-ptarchive-features', '%%pt_plural%% Archive %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', '717beeb6eac4ff8d0ee2662757ac3c9a', '[wpseo_titles]metadesc-ptarchive-features', '', 0),('en', 'admin_texts_wpseo_titles', '', 'c97f6ca909f0cd2ab91a4ed6fba39b87', '[wpseo_titles]title-testimonials', '%%title%% %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', 'b6e15e3d6aef999d5378d0500fcb528d', '[wpseo_titles]metadesc-testimonials', '', 0),('en', 'admin_texts_wpseo_titles', '', 'c786e8258393fdfd4660c4ed08aa9397', '[wpseo_titles]title-ptarchive-testimonials', '%%pt_plural%% Archive %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', '977bed6449aede450799e4dfe60be86c', '[wpseo_titles]metadesc-ptarchive-testimonials', '', 0),('en', 'admin_texts_wpseo_titles', '', '8b35ca318197b379e64c2762f7ba456f', '[wpseo_titles]title-instructions', '%%title%% %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', 'c3c4651dbe6d45b76f53a11d95d76095', '[wpseo_titles]metadesc-instructions', '', 0),('en', 'admin_texts_wpseo_titles', '', '40b3c961ad1351adfd2d80bba45275ba', '[wpseo_titles]title-ptarchive-instructions', '%%pt_plural%% Archive %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', 'c8b045a40455c279ba076d8dc8d74f95', '[wpseo_titles]metadesc-ptarchive-instructions', '', 0),('en', 'admin_texts_wpseo_titles', '', '037196582b455458c337c005e0a40df4', '[wpseo_titles]title-case-studies', '%%title%% %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', 'd86f33c9101f473cdb4ff0283c6ce345', '[wpseo_titles]metadesc-case-studies', '', 0),('en', 'admin_texts_wpseo_titles', '', '1d36e4648f532e66e358d2b24e45e9c9', '[wpseo_titles]title-ptarchive-case-studies', '%%pt_plural%% Archive %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', '6d2e24fcf6ea64d24264e8a0442eb661', '[wpseo_titles]metadesc-ptarchive-case-studies', '', 0),('en', 'admin_texts_wpseo_titles', '', 'b08007d8e18942b778f603bf78e1c223', '[wpseo_titles]title-partners', '%%title%% %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', 'c78729f5474973a9faa8d84e9a48d43a', '[wpseo_titles]metadesc-partners', '', 0),('en', 'admin_texts_wpseo_titles', '', 'ba85bad9d218415ff6318921e1fe1fe5', '[wpseo_titles]title-ptarchive-partners', '%%pt_plural%% Archive %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', '33a91c5df748336fea66430c937b3358', '[wpseo_titles]metadesc-ptarchive-partners', '', 0),('en', 'admin_texts_wpseo_titles', '', '2cb80bcd6ec9f3656d127e33987ba065', '[wpseo_titles]title-accreditations', '%%title%% %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', '67816bb5f7403339bc81897e5f14c0b2', '[wpseo_titles]metadesc-accreditations', '', 0),('en', 'admin_texts_wpseo_titles', '', '58c5b0a28a0078a15e0f8e2e3b867ad6', '[wpseo_titles]title-ptarchive-accreditations', '%%pt_plural%% Archive %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', 'f3a3b2254d566563a6af62611195e0ec', '[wpseo_titles]metadesc-ptarchive-accreditations', '', 0),('en', 'admin_texts_wpseo_titles', '', 'f904548031e9ee45b6cee629ab672f88', '[wpseo_titles]title-customers', '%%title%% %%page%% %%sep%% %%sitename%%', 0),('en', 'admin_texts_wpseo_titles', '', '13aba0ab57afd86f32751a8c5fd26a9a', '[wpseo_titles]metadesc-customers', '', 0),('en', 'admin_texts_wpseo_titles', '', 'c79167e7f1d8a4a8bc398eb2e505d952', '[

Is there any documentation that you are following?
Rebooting the server did not help and only deactivating the plugin stops the errors.

Is there a similar example that we can see?

What is the link to your site?

September 12, 2019 at 4:15 am #4558259

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Take a full backup of your site and database.

Go to WPML > Support > Troubleshooting
click on 'Recreate ST DB Cache tables'
Then check the issue.

Let me know how it goes, please.

Regards,
Riffaz.

September 12, 2019 at 12:40 pm #4560935

davidF-64

Thanks for the reply Riffaz, unfortunately I cannot see this option anymore. This was the suggestion the last time and seemed to have worked then but now when I go to WPML > Troubleshooting that option is not listed.

Please advise, even with the plugin disabled our sites are still really slow do to the deadlock issue.

Thank you,
Mario

September 12, 2019 at 12:46 pm #4560937

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

That is strange.
That option is very important.
So all the sites which use WPML should have that option.

Could you please disable all your third party plugins except WPML and check the issue?

Let me know how it goes.

Regards,

September 12, 2019 at 3:53 pm #4562799

davidF-64

In the mean time I downloaded fresh copies of String Translation, Media Translation, Sitepress CMS and translation management and that corrected another error that surfaced related to sitepress. We also had that issue a few weeks ago and the resolution was to get a fresh copy of the plugin.
So at this moment for this one site I still have string translation deactivated. we have no errors in the logs but the sites are still running slow. When I activate String Translation, the deadlock errors come back so to me, that narrows it down a lot and also because we had that issue previously.
Could you send me a screen shot of where the Recreate option is located on the troubleshoot section, maybe I am just missing it.

Thank you,
Mario

September 13, 2019 at 12:39 pm #4568665

davidF-64

It's been almost 24 hours without a response.
Could I have some direction on how to Recreate the table without that specific option listed under troubleshooting?
This issue has been affecting our sites for the second time for a couple of days and needs to be resolved.
Please advise what next steps should be taken to fix your plugin.

Thank you,
Mario

September 15, 2019 at 5:03 pm #4575097

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

This has been fixed in newer version of WPML plugins.
You can check the latest versions here: https://wpml.org/account/downloads/

Try to update all the WPML plugins and check the issue.

Could you send me a screen shot of where the Recreate option is located on the troubleshoot section, maybe I am just missing it.
- here: hidden link

Anyhow, I escalated this to our developers as well.
They will update again by Monday evening.
Before that please check try suggestions I explained above.

Ps:
I do not work on Fridays and Saturdays

Regards,

September 16, 2019 at 2:23 pm #4581253

davidF-64

Hi Riffaz,

Thanks for the reply and the screen shot. Compared what I see on my screen (see attached) this option is not there at all, seems cut off for some reason. and also note that this is the same for our 5 sites although the deadlock issue is only occurring on the processfusion.com site.
As for updating the plugins, I have already performed all updates directly downloaded from your site, deleted the files on the server and re-uploaded the fresh downloaded files.
As for disabling all other plugins, that was also performed over the weekend and the result is the same.
So from my perspective, we have the latest version of all your plugins so your reference to this issue being fixed in the latest version is not accurate for us.

Please advise as soon as you hear from your development team.

Thank you,
Mario

September 17, 2019 at 9:50 am #4587223

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Then the safest way is just install the beta version of WPML plugins.
That will fix this issue. we tested it.

Could you please try to update all WPML Plugins to their latest version by going to Plugins -> Add new -> Commercial.

If this will not solve the issue please change from "stable" channel to "beta" channel and install all our Beta versions: hidden link

Let me know if this solved the issue.

Kind regards,

September 18, 2019 at 3:07 pm #4597815

davidF-64

Hi Riffaz,

Updating to the beta versions from the WP admin did not work but manually downloading the beta versions from your site and uploading them to our site worked and so far no deadlock errors in the logs.

I will give it some time and if the deadlocks don't come back I will close the ticket.

Thank you very much for your help.
Mario

September 19, 2019 at 11:54 am #4604377

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Glad the fix works now.
Let me know if you need anything else regarding this in future. otherwise, just close it.
A rating with a comment is appreciated. 🙂

Regards,
Riffaz.

September 19, 2019 at 12:43 pm #4604823

davidF-64

My issue is resolved now. Thank you!