This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by 8 months, 2 weeks ago.

Assigned support staff: Yvette.

Author Posts
September 23, 2019 at 11:38 am

I am trying to:

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

Exact same issue as my previous ticket>
But now it´s super slowing down my site and had to deactivate WPML in order to create a user for you 🙁

September 23, 2019 at 3:47 pm #4625507

I´ve added to the drive folder where the duplicator backup is, a log file that shows wpml errors. Hope it helps solve this soon as we need to launch the web soon. Thanks in advance!

September 23, 2019 at 9:36 pm #4626689


Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)


I have been researching other like tickets and I can see that some have been linked to the versin of SQL that is running.

On your site, I see that you are using version 5.5.5. The minimum version required to run WPML is actually 5.6

1. Please upgrade your mySQL version to see if this addresses the issues of the database errors in the log

2. Also, please try increasing your allocated PHP memory to 512M as the same error is also related to resource constraints.

Thanks for addressing these installation configuration issues before we continue debugging.

September 24, 2019 at 8:08 am #4628951

Hello Yvette
Thanks for your reply.

According to my hosting providor the versions I´ve got are:

PHP memory 1024M (1GB)
MariaDB 10.3

So we can discard that.

September 24, 2019 at 8:25 am #4629027

p.d> i´ve got a staging site from a coupe of days ago on the same server which works better. If it´s usefull for you, you can access it via ftp or with the same access details I provided + "/stage" after the url

September 24, 2019 at 12:16 pm #4631469


Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Yes - thanks. I´ll be using the staging site to do any testing/investigations.

I was able to connect, but I amnot seeing the same behaviour as you described in your original ticket. e.g. you described the steps to replicate the issue as follows:
- connect to system
- go to Settings / Ajustes
- observe that the backend dashboard language switches to English

Is this problem happening on your staging site still? Should I only be looking at your original site?

September 24, 2019 at 1:08 pm #4631797

That´s right, the staging site does not have the problem (though it had others before, when I activated Mailchimp multilingual..i fixed it following a solution from this forum but since then everything went weird).

I´ve just created a new staging site for you from the live site on "/wpml". Please use that one to perform tests. Thank you!

September 24, 2019 at 1:37 pm #4632005


Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Can you please double check this on your "WPML" site? I am still not able to see a switch to English when I login. Everything stays in Spanish.

My expectation is that once I start navigating the wp-admin dashboard, the admin language changes to either English or mixed spanish-english. Is this a correct expectation?

September 24, 2019 at 1:49 pm #4632177

I´m checking "/wpml" and the bug does not occurr as easily as in the live installation.

If you prefer to check it on the live site, I will keep "/wpml" as a backup.

What for sure you cannot do is create a new user on both installations. It sends a "Request Timeout" (i know this is server related, but they told me Wpml might be causing it, you can check the error_log file on the link I provided for the backup on Duplicator)

On the live site, you will see the bug happening when you click on different buttons from the left menu, for e.g> "Ajustes> Medios"

September 24, 2019 at 2:50 pm #4632533

More info> MYDB_icl_string_pages Size: 17.43MB

In experiencing massive increases in this DB on other websites too (i´m trying to follow solutions on this forum before opening a ticket)

Maybe it has sth to do with this bug too..

September 25, 2019 at 3:01 am #4635069


Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)


You wrote: "..On the live site, you will see the bug happening when you click on different buttons from the left menu, for e.g> "Ajustes> Medios"..."

I connected to your live site but I still could not see the error.

I set my profile language to "Idioma predeterminado" to test as well. For me, the dashboard remains in Spanish when navigating through the different menu options.

With regard to the increasing table size, please open a new ticket for this issue The icl_string_pages table is a caching table. For the moment, you can recreate the caching tables here:
WPML > Support > Troubleshooting > Recrear tablas de caché de BD de TC


September 25, 2019 at 6:59 am #4636097

Thanks for your reply.

The fact that you cannot recreate the bug does not mean it doesn´t exist.
It happens with the "idioma predeterminado" setting and that is the important, as new users are created by default like that. Do you want a video from my screen recreating the bug?

Also, the facts that I cannot create new users while Wpml is active and that the installation began to work unproperly after installing "Mailchimp for WP multilingual", are indicators that something is not alright with the plugin.

Regarding "icl_string_page", thank you. As I mentioned before I sorted it out following the solution in other thread.

If you cannot debug this, can you please pass this ticket to another supporter?
It´s quite urgent for us to launch the website.
Thanks again.

September 26, 2019 at 10:12 am #4645541

Are there any updates?
3 days have passed already..

September 26, 2019 at 11:23 am #4646255

My update:
I´ve been testing conflicts with plugins by activating/deactivating different ones.

I deactivated Wpml and after activating it, even though the WP default language, my user and WPML default language are Spanish, my admin dashboard is now completly in english and all the translations are not showing on the frontend.

Woocommerce> checkout never redirects to the order page (but the order appears done andd processing on the dashboard).
I guess it could be a slug/endpoint translation issues, all coming from Wpml.
But that is only my guess.

I think now you will be able to see the bug easily.

Will bee waaiting for your news.

September 27, 2019 at 7:27 am #4652007

Is it possible to solve this today? Please do not postpone it for after the weekend. We are depending on this issue to be solved to launch the website. Thank you.