This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Nexys 7 years ago.

Assigned support staff: sarah.n.

Author Posts
October 3, 2012 at 7:39 am #78053

Nexys

Hi!

I'm using WordPress HTTPS plugin on a project with "Force SSL Administration" option enabled via the plugin settings.

Here is what I get in Chrome:

The page at <em><u>hidden link</u></em> displayed insecure content from <em><u>hidden link</u></em>.
XMLHttpRequest cannot load <em><u>hidden link</u></em>. Origin <em><u>hidden link</u></em> is not allowed by Access-Control-Allow-Origin.

Do you plan making WPML fully compatible with WordPress HTTPS, or is there some kind of patch I can use instead?

October 3, 2012 at 8:09 am #78057

Nexys

Cannot adjust the WPML Settings in the backend, cause ajax calls fail.
As far as I can remember there was no such a problem with WordPress 3.4.1 and WPML 2.5.2

October 3, 2012 at 12:42 pm #78110

Nexys

Forgot to mention that I'm using WP 3.4.2 / WPML 2.6.0

Also on:

<em><u>hidden link</u></em>

I get this error:

Uncaught ReferenceError: ColorPicker is not defined languages.js:772
(anonymous function)
October 3, 2012 at 1:16 pm #78126

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello Nexys,

You can please try add the following code in your wp-config.php:

define('FORCE_SSL_LOGIN', true);
define('FORCE_SSL_ADMIN', true);

Before /* That's all, stop editing! Happy blogging. */

See also: http://codex.wordpress.org/Administration_Over_SSL

Let me know how you get on with this.

October 3, 2012 at 1:54 pm #78133

Nexys

Yeah that was odd, with the constant in the config things look normal. I think FORCE_SSL_ADMIN is enough because it covers the login as well as the whole administration. FORCE_SSL_LOGIN should put only the login under SSL (or I might be wrong).

Thanks for that!

And just to let you know the ColorPicker js error from my last reply is still there.

October 3, 2012 at 2:29 pm #78139

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Nexys,

I am looking into it right now. I will report back here once I have something for you.

October 3, 2012 at 2:35 pm #78143

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Nexys,

the error you see should be fixed with the next release. So once you see that the update has been released update WPML. If the issue pesists (which should not), then you can get back to me.

October 3, 2012 at 2:39 pm #78144

Nexys

All right then, thanks again! I'll put that to resolved in the meantime 🙂

The topic ‘[Closed] WordPress HTTPS Compatibility’ is closed to new replies.