Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 4 voices.

Last updated by Gianluigi 6 years, 6 months ago.

Assigned support staff: George Botsev.

Author Posts
May 8, 2015 at 4:01 pm #615281

Gianluigi

Wordpress is slow when updating posts or custom posts, and sometimes it gives me error 500.
I tried deactivating all the plugins except WPML multilingual cms, which is causing the problem.
wpml is version 3.1.9.7 and wordpress is 4.2.2.
I tried changing the theme but the problem persists.

Thanks

May 11, 2015 at 9:03 am #616071

Dat Hoang

#1,
For this kind of problem, please take a look at this page: https://wpml.org/errata/performance-problems-related-to-custom-fields-after-upgrading-to-wordpress-4-2-1/

#2,
Actually with your info, it's really hard to say what the problem is.
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of saving posts.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

#3,
Please check your server log as well. Error 500 is a problem related to the server, so you should check there.

May 15, 2015 at 7:46 am #619356

Gianluigi

Thanks for the reply.

#1 I tried but the problem persists.

#2 If you want I've created a test area and I can send you the credentials (Ftp and admin).

#3 The 500 error is caused by wpml when i save. If the plugin is disabled the problem does not persists.

Thanks again

May 15, 2015 at 10:05 am #619494

Dat Hoang

#1,
OK. Thanks for your info.

#2,
Please let me know what you got?
With this info, I may help you without requesting your credentials.
In the case, there is nothing to help you with these info. I will ask your site credentials.

#3,
I understand that but with just error 500, I can not what's causing the problem.
Could you try to take a look at your server error? Do you see anything?
Please see this as well: http://stackoverflow.com/questions/4731364/internal-error-500-apache-but-nothing-in-the-logs

May 21, 2015 at 3:23 pm #623685

Gianluigi

In the debug.log there are no error (only for comments.php in fronted). See below:

PHP Notice: Tema senza comments.php è deprecata dalla versione 3.0 senza alcuna alternativa disponibile. Includere un template comments.php nel proprio tema. in /site.com/wp-includes/functions.php on line 3450

The error log:

[Thu May 21 17:20:31 2015] [warn] [client xxx.xxx.xxx.xxx] mod_fcgid: read data timeout in 60 seconds, referer: hidden link
[Thu May 21 17:20:31 2015] [error] [client xxx.xxx.xxx.xxx] Premature end of script headers: post.php, referer: hidden link
[Thu May 21 17:20:46 2015] [warn] [client xxx.xxx.xxx.xxx] mod_fcgid: read data timeout in 60 seconds, referer: hidden link
[Thu May 21 17:20:46 2015] [error] [client xxx.xxx.xxx.xxx] Premature end of script headers: post.php, referer: hidden link

Thanks

May 22, 2015 at 7:04 am #623993

Dat Hoang

That seems not a problem with PHP.
Please see a discussion:
hidden link

Does that help?

May 25, 2015 at 7:47 am #625178

Gianluigi

There is this errror because when i save the article Wmpl takes about 60 seconds to save. After that the server stop the script. I reacreated the site in a test area. Here the server don't generete 500 error but it takes too long to save.

May 25, 2015 at 9:47 am #625298

Dat Hoang

Please try with this: https://wpml.org/errata/performance-problems-related-to-custom-fields-after-upgrading-to-wordpress-4-2-1/

I hope that it may help for your case.

If not, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only.

Note that:
+ Backup (both files and database) your site before giving us your credentials
+ It would be better if you give me the test site rather than the live site.

May 26, 2015 at 5:35 am #625835

Dat Hoang

Your credentials are fine.

I'm looking at it.

Have you tried this Please try with this: https://wpml.org/errata/performance-problems-related-to-custom-fields-after-upgrading-to-wordpress-4-2-1/ ?

May 26, 2015 at 5:40 am #625836

Dat Hoang

I can see you tried with this https://wpml.org/errata/performance-problems-related-to-custom-fields-after-upgrading-to-wordpress-4-2-1/

I am testing more and getting back to you soon.

May 26, 2015 at 7:09 am #625877

Dat Hoang

I disable all plugins exceprting for WPML, switch to a default theme (Twenty Fourteen) but the problem persists.

Could you monitor and get the SQL queries? I think there is one or more queries that's slowing down the queries.

I would like to get a snapshot of your site (using Duplicator) for testing on our local sites. Is that OK?

May 26, 2015 at 1:05 pm #626243

Gianluigi

I don’t think i have a tool to monitor my queries, you can take snapshots. Thank you

May 27, 2015 at 7:10 am #626725

Dat Hoang

#1,
I'm sorry that I can not create any Duplicator snapshot. It seems that there are some failed permissions. See at hidden link

Could you please check your server and create a snapshot for me?

#2,
And another thing you can try is that installing our WPML3.2-RC3 in https://wpml.org/account/downloads/ and see that helps or not. If yes, you can wait for this version to fix the problem.

Does that help?

NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

+ You should make a backup for your current staging site as well because WPML 3.2 includes some changes in WPML custom tables.

June 4, 2015 at 8:08 am #631997

Gianluigi

#1 I resolved the file permissions but i can't use "Duplicator" because the php version installed on the server is old. Can i create a snapshot in another way?

#2 WPML3.2-RC3 didn't resolve the issue

June 5, 2015 at 3:49 am #632656

Dat Hoang

Thanks for your info.

#1,
If so, PHP version 5.2.8 might be the problem. You can not upgrade to the newer version of PHP?
Yes, please create the backup including:
+ Your files (but excluding /wp-content/uploads and .zip, .rar, .sql, .gz... files)
+ Your database

#2,
Thanks for your info.
Would you mind if you try to test on the newer versions of PHP as I said on #1?