This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Otto 4 years, 11 months ago.

Assigned support staff: Otto.

Author Posts
April 24, 2015 at 1:48 pm #605707

yasmines

My wordpress is super slow. error_log.txt shows this error a thousand times. How can I solve this issue? Thanks.

[22-Apr-2015 13:01:37 UTC] WordPress database error Lost connection to MySQL server during query for query
SELECT s.name, s.value, t.value AS translation_value, t.status
FROM wp_icl_strings s
LEFT JOIN wp_icl_string_translations t ON s.id = t.string_id
WHERE s.context = 'plugin woocommerce'
AND (t.language = 'nl' OR t.language IS NULL)
made by require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), call_user_func_array, wp_widgets_init, do_action('widgets_init'), call_user_func_array, wc_register_widgets, register_widget, WP_Widget_Factory->register, WC_Widget_Cart->__construct, __, translate, apply_filters('gettext'), call_user_func_array, icl_sw_filters_gettext, icl_t, icl_t_cache_lookup

April 24, 2015 at 5:32 pm #605900

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi,
I navigated your site and looks right. Can't see any performance issue.
Maybe your server had some troubles.
Let me know if I missunderstood the problem.
Kind Regards

April 27, 2015 at 8:31 am #606565

yasmines

Hi Otto,

Indeed, the site looks faster now.
However GoDaddy told me there were no server issues...
But do you know what's causing the errors in the error log?
I would like to prevent the site from being so slow again..

Thanks.

April 27, 2015 at 1:25 pm #606930

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi,
Are new errors in the log? If not, I think that it was just an issue with the database connection.
Kind regards

April 27, 2015 at 2:24 pm #607007

yasmines

No, there are no new errors in the log.
But my site is slow again... (min. 5 seconds to load a page, Google PageSpeed Insights tells me to reduce server response time).
When I disable WPML the site runs fast (+- 1 second to load a page, PageSpeed tells me there's no server issue)
Thanks.

April 27, 2015 at 3:23 pm #607068

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi,

I think that the ups and downs of your site's speed are *mainly* due to server issues.

Anyway, you may want to disable the following WPML options:
-Auto ID adjust state (WPML > Languages > Make themes work multilingual)
-Track where strings appear (WPML > String Translation > Track where string appear on the site)
-Auto register strings (WPML > String Translation > Auto register strings for translation)

And to take a look at this documentation?
http://wpml.org/2012/01/can-your-site-run-faster/
especially the section under “Using WPML Better”

Regarding the decrease in speed when you activate WPML, it's possible as you have WooCommerce, WCML and WPML installed.

Please, do let me know if it helps.

Kind regards

April 28, 2015 at 8:49 am #607549

yasmines

Hi Otto,

All the WPML options you suggested to disable, already were disabled.
I have installed a performance profiler and I have attached some screenshots of the results.
Could it be that the server issues only appear with the WPML plugin?

Thanks.

April 28, 2015 at 6:26 pm #608182

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi,

You are right, let me take a look at it.

To further investigate the problem I’d like to replicate your site locally. For this I'll need to temporarily install a plugin called "Duplicator" on your site. This will allow me to create a copy of your site and your content. If you prefer to do it on your own, you can provide me with the snapshot following these directions:

If you already know how Duplicator works (http://wordpress.org/plugins/duplicator/), please skip the following steps and just send me the installer file and the zipped package you downloaded.

:: Duplicator instructions
hidden link

. Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)
IMPORTANT: remember to create or keep an admin account for me before creating the snapshot, or I won't be able to login. You may delete the new admin account once the snapshot has been built.

Once the problem is resolved I will delete the local site

Kind Regards

April 30, 2015 at 8:36 pm #609987

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Thanks! I've downloaded the copy and will deploy locally.
I'll let you know when I have test results and come to a conclusion.
Kind Regards

May 8, 2015 at 1:25 pm #615098

yasmines

Hi Otty,

Do you already have any updates on the issue?

Thanks.

May 8, 2015 at 3:15 pm #615231

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi,

So sorry for the delay in the response. But just yesterday an errata was published and I think it will improve your site's performance.

I installed the Query Monitor plugin in your site. It shows that it's making many queries like the one described here: https://wpml.org/errata/performance-problems-related-to-custom-fields-after-upgrading-to-wordpress-4-2-1/

This was the most time consuming element, by far, of WPML.

I couldn't try the workaround that is described there because I don't have FTP access. Please try it and let me know if it helps.

I also found in your site an HTTP request that took too much time, but it was related to W3 Total Cache. I deactivated the plugin, and activated it again and it's gone now.

Take into account that every plugin that you add to your WordPress site will add execution time and database queries, and WPML is no exception. So you'll notice a difference with and without it. But not to the exreme of making your site unusable, of course.

Please, let me know if this helped.

Kind Regards

The topic ‘[Closed] WordPress is super slow. error_log.txt shows this error a thousand times: [22-Ap’ is closed to new replies.