Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by jefM 2 years, 3 months ago.

Assigned support staff: Bigul.

Author Posts
May 7, 2018 at 11:53 am #2010533

jefM

I'm trying to translate a website from Dutch to English and French. Everything works fine, except for the last Front Page Section. It shows one of the three languages for every version (for example: the French content appears for every language).

This only happens on the front page. I have seperate pages for every section, and those display the correct translations.

When I go to the Customizer, the field for the last (in this case the fourth) Front Page Section is blank for every language, except the one that's being displayed on the site. Selecting content for this field resets the language that's being displayed (for example: if I select the content I want to display on the English version of the site, it shows the English version for every language).

I've tried to add and remove sections via the functions.php file, and if I set the amount of sections to 5, the problem occurs for the fifth Front Page Section. Adding blank sections doesn't help either, the problem always occurs for the last section that displays content.

May 8, 2018 at 8:55 am #2025660

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please translate the Customizer options via WPML>>String Transltion>>Translate texts in admin screens. Then check you are getting the expected result or not. Please check the following documentation for more details.

https://wpml.org/documentation/getting-started-guide/translating-theme-options/

--
Thanks!

Bigul

May 8, 2018 at 11:38 am #2029220

jefM

Hello

Thanks for your reply. The Customizer options are already translated, so it still doesn't work. Retranslating them doesn't help either.

May 8, 2018 at 5:46 pm #2037611

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please fill the private details fields after a full site backup. I would like to access admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

May 9, 2018 at 5:52 pm #2059287

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. It was happening because the string for *panel_4* is registered with the wrong page ID and language. It works after the following steps.

1) Delete the *[theme_mods_twentyseventeen]panel_4* string of *admin_texts_theme_mods_twentyseventeen* string domain
2) Then the string has re-register for the translation
3) Translate it to other languages

Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

May 14, 2018 at 9:47 am #2114620

jefM

Hello

Thanks for your reply and your solution, this solved the problem.