This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Yvette 6 months, 3 weeks ago.

Assigned support staff: Yvette.

Author Posts
April 3, 2019 at 9:40 am #3524123

athoss-gbrT

Hi,

we have a multiste network using WordPress, WooCommerce and WPML.

1.
We have on site in the network for our Website that has the default language "de" which is used for germany, swiss and austria visitors. Therefore we changed the hreflang from the german language to "de".
The language in WordPress for this subsite is set to "German".

2.
We have a second site in the network running a WooCommerce Shop only for swiss customers. Therefore we changed the hreflang from the german language to "de-CH" for swiss.
The language in WordPress for this subsite is set to "German (Swiss)".

Eyerything was running fine the last month until I updated WordPress yesterday from 4.9.X to the current version. I also updated WPML, WooCommerce and all other plugins to the current versions.

The problem:
When I visit the Website as a normal visitor without backend login then WordPress uses the correct german language in the frontend. You can see this by creating a 404 page on the Web-Subsite. The Title and the information text is displayed correct in german language. See here:
hidden link

The same happens correct at the shop Installation:
hidden link

But when I log into the WordPress-Admin as a customer or admistrator (doesn't matter), some parts of the backend are in german and some in english. Example: User menu upper right corner (see screenprint english_menu.png). And the englisch language files for WordPress and WooCommerce are used in the front when logged in for both sites and not the german ones.

Please check the screenshot (english_after_login.png), which shows the exact 404 error page like above, but after the admin login. It is now in english language. When I logout it is in german again.

When I visit the network settings page, the menu in the admin (upper right) is displayed correct in german (same as default language). Not sure why it is correct here.

To me it seems like that after the update something with the language files is wrong maybe!?

I was only able to insert one debug log into the field below. I inserted the debug Log from the Web-Subsite and not from the Shop-Subsite.

It would be amazing, if you can check and help me to fix this as soon as possible, because the client wants to start his eshop this week.

Please contact me if you need more information.

Thank you
Tobias

April 3, 2019 at 12:16 pm #3525973

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I´ll be helping you with this issue.

Clarifications:

1. Please upload screenshots for the following
1.1 WPML > Languages > Site Languages (for each site)
1.2 Users > Your profile > Personal options > Language
Users > Your profile > WPML language settings

Just as an FYI: once WPML is active, the site language is more-or-less disregarded with the default language taking over that is set in WPML > Languages > Site Languages. The languages you see once you are logged in will be determined by the languages set in your user profile.

So I just need to see these values to complete the picture of the situation you have.

Thanks

The topic ‘[Closed] WordPress uses english language instead of default language’ is closed to new replies.