This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Vincenzo 3 months, 2 weeks ago.

Assigned support staff: Vincenzo.

Author Posts
March 21, 2019 at 7:38 am #3396143

herko

I am trying to: update wordpress core, update other plugins

Link to a page where the issue can be seen: /wp-admin

I expected to see: Update succesful

Instead, I got:

This is found at various sites under different administrations and can be reproduced at my site.

I have a setup on my webserver where i work with 2 users:
- a ssh user
- a php system user
They share a group.

Files in my document root are owned by ssh-user. php-user uses group read rights to access files. Only specific locations that should be writable by php are chowned or chmodded.

Therefor i use the ssh update feature of wordpress to update plugins and core.

When updating plugins i get an error message stating "Update Failed: Could not create directory." When SSH credentials are removed from my wp-config, I am not asked by wordpress what method of updating I want, it looks like WordPress forces to use the Direct method of updating. My own preferences are overwritten.

What does this have to do with WPML, you might ask?

As soon as I disable WPML Multilingual CMS updates work again. This way i've been able to update WPML from 4.2.0 to 4.2.4.1. After reactivating WPML, other plugins again are not updatable.

This also happens at other WordPress instances on other servers, maintained by others, I have seen.

Please fix WPML so we can keep using the safe SSH enabled updates.

March 21, 2019 at 1:32 pm #3404847

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

as you may already know, this seems like a known issue with the recent versions of WPML String Translation plugin.

More details in this Spanish ticket:
- https://wpml.org/es/forums/topic/wpml-string-translation-afecta-al-sistema-ftp-de-wordpress/

To verify if this is the same issue, can you please tell me if the issue is reproducible when String Translation is disabled?

Thank you

March 21, 2019 at 2:43 pm #3407983

herko

As noted, I tried with WPML Multilingual CMS as disabled plugin (as i've seen others do) and this removes the issue.

When string translation is the only disabled plugin of WPML Media, WPML Multilingual CMS, WPML String Translation and WPML Translation Management I also get the error message. With this it is pinpointed to WPML Multilingual CMS.

Changes in "define ('FS_METHOD', " do not change the issue, it seems overridden.

Even though I have this line in this file:
wpml-string-translation/inc/functions.php: add_filter( 'filesystem_method', 'set_direct_fs_method', PHP_INT_MAX );
It seems to work when string-translation is enabled but WPML Multilingual CMS is disabled.

Based on the spanish ticket I researched:
/public_html/wp-content/plugins$ grep -iR "filesystem_method" wpml-*
wpml-string-translation/inc/functions.php: add_filter( 'filesystem_method', 'set_direct_fs_method', PHP_INT_MAX );

This means this is the only file where filesystem_method is mentioned.

March 21, 2019 at 3:15 pm #3409443

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

thank you for your test.

Please note that when WPML Multilingual CMS is disabled, WPML String Translation and all the other add-ons plugins will not work, even if they are enabled.

As you can see in the other ticket, there is already a confirmation that when WPML is enabled and String Translation is disabled, the issue is not reproducible.
- https://wpml.org/forums/topic/updating-wordpress-plugins-with-ssh2/#post-3406697

Can you please try again and confirm that the issue is still reproducible when WPML is enabled and String Translation is disabled?

Thank you

March 21, 2019 at 8:30 pm #3421749

herko

I appologize, i have tested badly the last time.

I have retested as you asked and can now confirm your expectations that it is working with WPML enabled and String Translation plugin disabled.

March 22, 2019 at 10:06 am #3439101

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Thank you for your confirmation.

I added your ticket to our internal ticket.

I will inform you as soon as this issue will be solved or when a workaround will be available.

Thanks for your patience

May 2, 2019 at 2:07 pm #3725377

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

the issue has been fixed. The fix should be available in the next major versions of WPML plugins.

I will keep you updated.

Thanks for your patience.

July 1, 2019 at 9:53 am #4117541

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

can you please verify if the issue has been solved with the latest versions of String Translation?

Thank you!