Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.42 hours from now. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 8:00 – 13:00 9:00 – 13:00 9:00 – 13:00 8:00 – 12:00 8:00 – 12:00 -
- 14:00 – 17:00 14:00 – 18:00 14:00 – 18:00 13:00 – 17:00 13:00 – 17:00 -

Supporter timezone: Europe/Zagreb (GMT+02:00)

This topic contains 12 replies, has 2 voices.

Last updated by Bruno Kos 2 months, 2 weeks ago.

Assisted by: Bruno Kos.

Author Posts
February 23, 2024 at 10:18 am #15336906

Stefan Hansel Solutions

## Tell us what you are trying to do?

I try to get things automatically translated as much as possible. But sometimes I realize "this should be done by an agency".
I don't understand how I can do that as a workflow, I don't manage to get the translations from the agency into the system, once I have translated manually.

My current workflow:
- I have existing documents
- ATE prominently suggest to autotranslate them (which I do)
- I'm (sometimes) not happy with the results.
- For these documents I delete the translation, then I create an order with an agency
- I receive the results from the agency (automatically via WPML integration) -> but the final document now again has the previous DEEPL manual translations
- I also don't manage to get the XLIFF import to override the manual translation.

- What I do now? I go now line by line through the ATE and have the XLIFF in XML form open in a second window and manually override the automatic translation. This is massivly time consuming, but I haven't found a different way.

# Is there any documentation that you are following?
I've found several help articles, which say this has either to do with your translation memory on your servers and/or that I use the classic editor (because it doesn't have automatic translations).

However: the classic editor is massivly inferior to the ATE, also here I still cannot import the xliff that I have from a translation that started in ATE.

If I have a dedicated import of manual translations, how can I override any automatic translation with it?
I'm a developer, give me an API to delete translation memory, I would even invest into programming anything.

But it must be possible to ask a professional agency to override automatic translations.

## What is the link to your site?
hidden link

February 24, 2024 at 8:42 am #15340040

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch ) French (Français )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Since you are using ATE, did you consider this?
https://wpml.org/translation-reviewer/

Because the switch from ATE to Professional translations would not work, see this:
https://wpml.org/faq/why-arent-my-translations-showing/#switching-to-advanced-translation-editor

Regards,
Bruno Kos

February 24, 2024 at 10:08 am #15340150

Stefan Hansel Solutions

- I looked into the xliff coming back from the translation agency. It's in the little snippets (typically sentences) that wordpress created via ATE, so why is the the translation memory not updated with the improved file from the agency?
I also see in the file transmitted to the agency that it has all the IDs that WPML gives to each snippet,so it can be matched 1:1 on a very fine grained way.

- If I want to follow your proposal, how can I (re) set a document in a 'to be reviewed' state.
Right now it all feels one way, if I dared to click a single time on 'accept' for a translation Ich habe don't get it back into review state for a second external reviewer that I invite to my wordpress instance.

February 26, 2024 at 10:06 am #15343354

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch ) French (Français )

Timezone: Europe/Zagreb (GMT+02:00)

The thing with ATE and professional services is that translations for translation services go through a different system in WPML. Implementation of such option where ATE would pick up these translations and overwrite them would be difficult so was never implemented, even though it was considered some point.

That's why we offered reviews - however once something has passed the review, it can't be set again as pending review unless a new automatic translation job is created for it. However this is not possible for pages that were already translated.

translate automatically.jpg
February 26, 2024 at 10:19 am #15343405

Stefan Hansel Solutions

OK - then final thing, I somehow need to cleanup the intermixed state I have.

To reiterate:
- after installing WMPL it urged me to translate everything automatically, which I did
- I then wanted to try out an agency, for 5 documents I deleted the translation and created a translation request (via WMPL means) - these are imported in my system in the meantime.

Now whenever I want to continue to edit the document:
- the ATE pops up - but showing a different state, than the live translation (I have understood why it is this way in the meantime).
- to stay consistent, I would love to 'mark' these (5 via agency translated) documents that they should be edited in the classical editor (i.e. deactivate ATE for these).

Looking into the settings, documents seem to have a flag, that if they've intially been created with classic editor they will continue in it (even though ATE is activated for the other documents).

How can I change the flags (I'm a developer, I could even do things in phymyadmin if it helps).

I would then have consistent state between website + editor:
A) documents that have been translated with ATE automatically will open in ATE in the future
B) documents that I did delete, then imported an XLIFF for them will open consistently in the classic editor

February 26, 2024 at 11:35 am #15343839

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch ) French (Français )

Timezone: Europe/Zagreb (GMT+02:00)

I see, so "Editor for translations previously created using Classic Translation Editor" is set to be "Classic Translation Editor (recommended)"?

But content translated using ATE before and now with professional services still open in ATE, even though deleted in the meantime? As it should not happen like the above.

But does this help for these 5?
https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/#deactivating-the-advanced-translation-editor

this setting.jpg
February 26, 2024 at 12:17 pm #15344018

Stefan Hansel Solutions

Hi Bruno,

yset '"Editor for translation previously created using Classic Translation Editor" is set to "Classic Translation Editor".

- I deleted the document,
- THEN sent it to the Agency and imported them from the agency
- now if I click the edit/translate icon, they still open in ATE (and don't have the translations the agency send). Opening the page with default wordpress means (i.e. full page view), show the agencies translations, but nudges me to open in ATE.

February 27, 2024 at 8:22 am #15347560

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch ) French (Français )

Timezone: Europe/Zagreb (GMT+02:00)

I see, I am checking this with our 2nd tier because this is not very common scenario, perhaps we missed something during the testing of all these features.

February 27, 2024 at 11:18 am #15348748

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch ) French (Français )

Timezone: Europe/Zagreb (GMT+02:00)

Typically when using professional translation services, XLIFF files are uploaded into the system automatically and translations applied.

Is translation service sending you XLIFF files so you upload them directly? Which translation service is it? Can you clarify this a bit more?

February 27, 2024 at 3:20 pm #15349852

Stefan Hansel Solutions

The translation service is sending translations back automatically, they are also applied automatically by WPML. I do have access to the XLIFFs through the portal of the agency in addition (this is why I can see, that the agencies actually translated the small ATE text snippets, with proper identifiers).

I tried out TextMaster and Linguarum as translation agency, with 5 pages each.

Anyway: I do accept that I cannot use ATE after a translation from an agency.

However - obviously I might want to change a small things after the files have been imported/applied. But when click the 'Edit' button after the (automatic) import, ATE opens, which shows its own translations from its own TM, not the translation by the agency.

So I cannot continue to work on the page based on the work of the agency.

If the document was put into a "I was edited via Classic Editor"-mode, I could continue with the work from the agency, as these specific documents would just open in the classic editor for these specific pages.

February 28, 2024 at 10:27 am #15353045

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch ) French (Français )

Timezone: Europe/Zagreb (GMT+02:00)

I did a test on my localhost as well and I can see this issue, I am checking this with our 2nd tier.

this is old ATE translation.jpg
it should open CTE with this.jpg
February 28, 2024 at 2:01 pm #15354290

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch ) French (Français )

Timezone: Europe/Zagreb (GMT+02:00)

I escalated this case to our 2nd tier for further checks, I will keep you posted.

March 1, 2024 at 9:08 am #15361536

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch ) French (Français )

Timezone: Europe/Zagreb (GMT+02:00)

Can you try this?

Edit wp-content\plugins\sitepress-multilingual-cms\classes\editor\Editor.php, On line number 65 replace

wpml_tm_load_old_jobs_editor()->get_current_editor( $jobObject->get_id() ) === \WPML_TM_Editors::WPML;

with:

in_array(wpml_tm_load_old_jobs_editor()->get_current_editor( $jobObject->get_id() ), [\WPML_TM_Editors::WPML, \WPML_TM_Editors::NONE], true);

This change will open the CTE if job is translated using TS (may not work for translation jobs that already open in ATE though, try resaving their originals)

When importing the XLIFF file, the editor is already set to ATE when you send the job to local translator, so this change will not fix that part.

The topic ‘[Closed] Workflow auf automatic vs. manual translation with an Agency’ is closed to new replies.